hifiberry digi+ in Kodi 18.4 – Raspbian Buster Raspberry Pi4

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI hifiberry digi+ in Kodi 18.4 – Raspbian Buster Raspberry Pi4

This topic contains 1 reply, has 2 voices, and was last updated by  Heiner Moderator 1 year, 2 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • 26. September 2019 at 16:42 #47165

    Hallo,

    nach dem Update auf das neueste Raspbian Buster und Kodi 18.4 kann ich in Kodi die hifiberry digi nicht mehr auswählen.
    Da wird mir nur Pulsaudio digital Audio ICE958 angezeigt. Damit habe ich in Kodi aber keinen Ton.
    In der max2play webconfig unter Audioplayer wird auch nur hdmi und Kopfhörer angezeigt obowohl unter “ Raspberry Einstellungen “ die Digi+ ausgewählt ist.

    Scheinbar fehlen nach den Updates da die Treiber.
    Bin für jeden Tipp dankbar,

    vg Stefan

    __16:14:[email protected] [max2play] ~ # aplay -l
    **** Liste der Hardware-Geräte (PLAYBACK) ****
    Karte 0: sndrpihifiberry [snd_rpi_hifiberry_digi], Gerät 0: HifiBerry Digi HiFi wm8804-spdif-0 []
    Sub-Geräte: 0/1
    Sub-Gerät #0: subdevice #0

    Audiodebug:

    #### SQUEEZELITE VERSION ####
    Squeezelite Max2Play v1.0.3 based on v1.8.7-999, Copyright 2012-2015 Adrian Smith, 2015-2017 Ralph Irving.

    #### SQUEEZELITE BUILDOPTIONS ####
    Build options: LINUX ALSA EVENTFD RESAMPLE FFMPEG VISEXPORT IR GPIO DSD CONTROLSBS ALSASYNC BLUETOOTHSYNC

    #### AUDIOPLAYER CONFIG ####
    ### Configuration of Audioplayers
    SQUEEZELITE_PARAMETER=-o sysdefault:CARD=sndrpihifiberry -a 80:4:: -C 5
    SQUEEZESLAVE_PARAMETER=-n plugequal
    SHAIRPORT_PARAMETER=-d default:CARD=sndrpihifiberry
    USE_USB_DAC=0
    USE_EQUALIZER=0
    SYSTEM_USER=pi
    BLUEALSA_PLAY_AUDIOCARD=hw:0,0

    #### SQUEEZELITE -l ####
    Output devices:
    null – Discard all samples (playback) or generate zero samples (capture)
    jack – JACK Audio Connection Kit
    pulse – PulseAudio Sound Server
    default
    sysdefault:CARD=sndrpihifiberry – snd_rpi_hifiberry_digi, – Default Audio Device
    iec958:CARD=sndrpihifiberry,DEV=0 – snd_rpi_hifiberry_digi, – IEC958 (S/PDIF) Digital Audio Output
    dmix:CARD=sndrpihifiberry,DEV=0 – snd_rpi_hifiberry_digi, – Direct sample mixing device
    dsnoop:CARD=sndrpihifiberry,DEV=0 – snd_rpi_hifiberry_digi, – Direct sample snooping device
    hw:CARD=sndrpihifiberry,DEV=0 – snd_rpi_hifiberry_digi, – Direct hardware device without any conversions
    plughw:CARD=sndrpihifiberry,DEV=0 – snd_rpi_hifiberry_digi, – Hardware device with all software conversions
    usbstream:CARD=sndrpihifiberry – snd_rpi_hifiberry_digi – USB Stream Output

    #### SHAIRPORT (SYNC) VERSION ####
    3.3.1-OpenSSL-Avahi-ALSA-soxr-sysconfdir:/usr/local/etc

    #### OUTPUT SOUND DETAILS CARD 0 ####
    access: MMAP_INTERLEAVED
    format: S16_LE
    subformat: STD
    channels: 2
    rate: 48000 (48000/1)
    period_size: 44100
    buffer_size: 88200

    #### OUTPUT SOUND DETAILS CARD 1 ####

    • This topic was modified 1 year, 2 months ago by  corgan.
    27. September 2019 at 10:03 #47169

    Hallo Stefan,

    Bitte deaktivier den build-in audio in den Raspberry Settings. und starte neu. Danach sollte hifiberry in Kodi als Auswahl auftauchen.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.

Register here