[SOLVED] DHCP assigns two IP addresses on wlan0

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI [SOLVED] DHCP assigns two IP addresses on wlan0

This topic contains 3 replies, has 2 voices, and was last updated by  gls premium 3 years ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • 5. April 2018 at 7:58 #34985

    Hello All,

    my Raspi is on WIFI (on-board), DHCP client. Plain M2P install.

    On the WIFI page, I see:

    WiFi & Network configuration
    Status: WiFi USB adapter status is active. WiFi connection status is active (IP: 192.168.ww.xx 192.168.ww.yy)
    (Only WPA/WPA2-Encryption possible)

    I can ping both addresses, and load the web interface from both.
    It works fine, in fact, but I wonder if this is a misconfiguration of the Raspi.
    I setup the Raspi from the web interface, and did not do any manual intervention.
    So, it should be a common issue for all of you.

    Thanks for your comments,
    regards,
    -Gian

    5. April 2018 at 8:01 #34986

    some details:

    ip addr show wlan0
    3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether b8:27:eb:c3:21:ee brd ff:ff:ff:ff:ff:ff
    inet 192.168.ww.xx/24 brd 192.168.ww.255 scope global wlan0
    valid_lft forever preferred_lft forever
    inet 192.168.ww.yy/24 brd 192.168.ww.255 scope global secondary wlan0
    valid_lft forever preferred_lft forever
    inet6 fe80::ba27:ebff:fec3:21ee/64 scope link
    valid_lft forever preferred_lft forever

    5. April 2018 at 11:45 #34997

    Hi Gian,

    We have had this issue once or twice before. What router is your home network based on?

    Please try removing your WiFi setup and reassigning it using WPS or the automatic access point (manual).

    25. April 2018 at 7:53 #35326

    My router is IpFire.

    Now, something strange happened.

    I needed the 7″ display for another project, so I moved the SD card to another Raspi, thinking to run Max2Play headless.
    And indeed it does, wifi and BT work as usual, web interface is loaded, but.. lo and behold! now it has only ONE IP address.

    It seems related to hardware, since the SD card was just swapped from a Raspi with display to another one without.

    However, I can’t figure out the reason.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

Register here