Cant't connect to WiFi with Raspberry Pi 3

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Cant't connect to WiFi with Raspberry Pi 3

Tagged: 

This topic contains 16 replies, has 5 voices, and was last updated by  Heiner Moderator 2 years, 3 months ago.

Viewing 17 posts - 1 through 17 (of 17 total)
  • 7. Mai 2018 at 22:29 #35568

    Hallo allerseits, habe gerade Max2Play auf einen Raspberry Pi 3 installiert und versuche mich auf http://max2play.local/ mit dem W-Lan zu verbinden, kriege dabei aber folgende Fehlermeldung:

    Setup WiFi Started
    2018-03-20 17:48:00|
    Disable Accesspoint
    rm: cannot remove ‚/tmp/automatic_accesspoint_mode‘: No such file or directory
    ifdown: unknown interface wlan0
    0
    OK
    OK
    FAIL
    OK
    OK
    OK
    No IP-Address could be received – WiFi NOT working correctly. Please check Network-ID and Passphrase!
    ifdown: ignoring unknown interface wlan0=wlan0
    FAIL
    OK
    WiFi detected
    Restarting hostapd (via systemctl): hostapd.service.
    Restarting dnsmasq (via systemctl): dnsmasq.service.
    Finished Please Click here Reload Page!

    Habe eine WPS Verbindung bereits erfolglos versucht, über Lan Kabel scheint es zu gehen, nur das W-Lan will noch nicht.

    Freue mich über alle Hinweise und Hilfe 😀

    8. Mai 2018 at 11:59 #35581

    Hi Anon,

    Wenn du über WLAN verbunden bist, versuche einmal den Automatic Access Point im WLAN/LAN Menü zu deaktivieren und manuell die WLAN-Verbindung zu etablieren (Scan, Auswahl Netzwerk, Haken „Load WiFi Interface“, Passwort, speichern).

    8. Mai 2018 at 19:33 #35601

    Danke das scheint schon mal einen Schritt weiter zu helfen. 😀

    Habe den Raspberry Pi über ein Lan-Kabel an den Router angeschlossen, den Automatic Access Point im WLAN/LAN Menü deaktiviert und das W-Lan manuell eingestellt, jetzt kommt folgende Meldung:

    Status: WLAN Adapter status ist aktiv. WLAN Verbindungsstatus ist aktiv (IP: KEINE IP! Keine Verbindung!)
    (Nur WPA/WPA2-Verschlüsselung möglich)

    Auf der Seite von fritzbox steht das Gerät als über Lan angeschlossen mit einer IP-Adresse.

    Habe versucht das Lan-Kabel zu ziehen und mich dann zu verbinden, aber wenn ich das tue komme ich nicht mehr auf die max2play.local Seite und es wird in den Netzwerken auch nicht „max2play“ angezeigt um sich über W-Lan zu verbinden.

    8. Mai 2018 at 21:24 #35603

    Hast Du eventuell in den WLAN Sicherheitseinstellungen der Fritz!Box eingestellt, daß nur bekannte Geräte eine Verbindung aufbauen dürfen?

    9. Mai 2018 at 7:38 #35610

    Habe gerade nachgeguckt und unter WLAN/Sicherheit/WLan-Zugang beschränken steht „Alle neuen WLan Geräte zulassen“.

    Ich vermute das wenn einmal die Lan-Verbindung steht, was problemlos funktioniert, diese auch erzungen wird und damit das W-Lan nicht mehr aktiviert werden kann.

    9. Mai 2018 at 18:27 #35636

    Nein, das kann nicht die Ursache sein. Ich habe inzwischen einige Raspis mit Max2Play in Betrieb genommen, vom Pi2 mit WLAN Stick bis Pi3B+ mit integriertem WLAN, die Einrichtung wurde immer im Webinterface per LAN vorgenommen, WLAN lief anschließend problemlos.

    9. Mai 2018 at 21:35 #35638

    Ok verstehe, also nochmal zusammengefasst:

    Die Einrichtung über Lan funktioniert bis zu diesem Punkt:

    Status: WLAN Adapter status ist aktiv. WLAN Verbindungsstatus ist aktiv (IP: KEINE IP! Keine Verbindung!)
    (Nur WPA/WPA2-Verschlüsselung möglich)

    mit folgenden Nachrichten darüber:
    Debug: Saving WPA-Supplicant (Successfully initialized wpa_supplicant ioctl[SIOCSIWENCODEEXT]: Invalid argument ioctl[SIOCSIWENCODEEXT]: Invalid argument 0 OK OK OK OK OK OK )
    WLAN aktiviert – bitte Neustarten
    Konfiguration aktualisiert – neuer Eintrag wurde erstellt
    Konfiguration aktualisiert – existierender Eintrag wurde geändert
    Daten gespeichert

    und diesem Debug-Log:
    eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
    inet 192.168.178.25 netmask 255.255.255.0 broadcast 192.168.178.255
    ether b8:27:eb:13:32:57 txqueuelen 1000 (Ethernet)
    RX packets 9 bytes 1778 (1.7 KiB)
    RX errors 0 dropped 0 overruns 0 frame 0
    TX packets 14 bytes 7673 (7.4 KiB)
    TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

    lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
    inet 127.0.0.1 netmask 255.0.0.0
    loop txqueuelen 1000 (Local Loopback)
    RX packets 2 bytes 100 (100.0 B)
    RX errors 0 dropped 0 overruns 0 frame 0
    TX packets 2 bytes 100 (100.0 B)
    TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

    wlan0: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500
    ether b8:27:eb:46:67:02 txqueuelen 1000 (Ethernet)
    RX packets 12 bytes 1188 (1.1 KiB)
    RX errors 0 dropped 0 overruns 0 frame 0
    TX packets 13 bytes 2481 (2.4 KiB)
    TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

    ### WLAN ###

    Ab dem Punkt an dem die Lan-Verbindung getrennt wird ist sowohl http://max2play.local nicht erreichbar als auch über WLAN kein max2play mehr sichtbar, egal ob man den Raspberry Pi zwischendurch neu startet oder vom Strom trennt.

    Woran kann es liegen das er keine IP hat?

    Bzw. wie sahen die Schritte bei deiner Einrichtung genau aus?

    1. Mit Lan-Kabel verbinden
    2. Automatic Access Point Deaktivieren / W-Lan manuell einrichten
    3. Gerät neu starten
    4. Lan-Kabel (im Betrieb) ziehen
    5. W-Lan geht?

    oder wie hast du es genau gemacht?

    • This reply was modified 2 years, 8 months ago by  Anon.
    • This reply was modified 2 years, 8 months ago by  Anon.
    • This reply was modified 2 years, 8 months ago by  Anon.
    • This reply was modified 2 years, 8 months ago by  Anon.
    • This reply was modified 2 years, 8 months ago by  Anon.
    • This reply was modified 2 years, 8 months ago by  Anon.
    10. Mai 2018 at 13:22 #35647

    Update: Habe den von Werk eingestellten Routernamen geändert, so dass keine Leerzeichen mehr vorkommen. Jetzt gehts. 😀

    14. Mai 2018 at 10:07 #35664

    Hi Anon,

    Danke für das Update 🙂

    19. Mai 2018 at 15:26 #35777

    I’m having the same problem but renaming my Wifi network isn’t an option. I’d have to change the connection everywhere in the house. When I use a standard Raspian Stretch image, it connects without a problem. Any other suggestions?

    Wait, it gets weirder. I changed the SSID of a range extender in my house so it does not have any spaces. I wanted to try to connect to it so I rebooted my RPi and it connected to the SSID that I didn’t change that has spaces.

    It seems that the connection is fairly random. I’m going to burn a new Max2Play image and try it again.

    • This reply was modified 2 years, 8 months ago by  ahnyerkeester.
    24. Mai 2018 at 10:39 #35852

    Hi ahnyerkeester,

    You can also try using WPS or automatic access point for connecting.

    24. Mai 2018 at 20:29 #35878

    I tried that too and it didn’t work. As I said, it seems to be random. If I find anything more I’ll update this thread.

    28. Mai 2018 at 10:18 #35909

    What kind of router do you have?

    28. Mai 2018 at 17:40 #35930

    TP-Link Archer C9

    30. Mai 2018 at 10:00 #35966

    Very odd, connection should work very stable under WiFi. Do you know which WiFi channel the router is using?

    15. Oktober 2018 at 22:24 #38629

    Ich habe eine Fritzbox 7490,die den Standardnamen ‚FRITZ!Box 7490‘ hat.

    Es will mir beim besten Willen nicht gelingen, meinen Raspberry Pi 3 unter der aktuellen max2play-Version mit diesem WLAN-Netz zu verbinden.

    Liegt das tatsächlich am Leerzeichen im Namen?

    Ich möchte das Netzwerk ungern umbenennen, da ich sonst jede Menge Geräte vollständig neu einrichten müsste :-/

    16. Oktober 2018 at 10:45 #38636

    Hallo manwald,

    Du kannst vorerst noch WPS ausprobieren.
    Außerdem kannst du noch, wie zuvor erwähnt, checken welchen Kanal dein Router nutzt. Kanal 12 udn 13 können manchmal Probleme beim Pi hervorrufen.

Viewing 17 posts - 1 through 17 (of 17 total)

You must be logged in to reply to this topic.

Register here