Boot stuck at time syncho with HifiBerry Amp2

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Boot stuck at time syncho with HifiBerry Amp2

This topic contains 25 replies, has 8 voices, and was last updated by  MatzederZweite premium 5 months ago.

Viewing 26 posts - 1 through 26 (of 26 total)
  • 6. November 2019 at 20:27 #47511

    Hi all,

    I mounted an HifiBerry Amp2 onto a RPI 3B with Max2Play 2.49.

    When the Raspberry+Amp2 boots, it gets stuck at the starting of the Network Time Synchronization :

    [FAILED] Failed to start Network Time Synchronization.
    See 'systemctl status systemd-timesynd.service' for details
    [  OK  ] Stopped Network Time Synchronization.
    	 Starting Network Time Synchronization.
    [*     ] (2 of 2) A start job is running for Raise network interface (49s / 5min 1s)

    After removing the Amp2 board, the boot process come back to normal.

    After several tests & tries, I partially solved the issue by unsetting the „fixed IP“ parms in Max2Play and in my router config.

    But, I’d like to get a fixed IP adress for this machine in order to ease its management. What to do to have both a running Amp2 board and an fixed IP adress ?

    By the way, I noticed a curious detail : this issue never occures when using an HifiBerry DAC+ Light with a RPI3.

    Regards,

    Stéphane

    13. November 2019 at 16:05 #47528

    Sounds like just my problem. However, my Amp2 is mounted on a Pi4. Max2Play version is the latest 2.50 beta for the Pi4.

    I have a screenshot, but it seems like I can’t upload images.

    Unfortunately I can’t report what happens after removing the Amp2 board, since I don’t have a fitting AC adapter (whole device is powered via Amp2 like it should be).

    For me, I’m 100% new to Max2Play so everything is still at the default settings. There’s no physical LAN cable attached, and I never configured any kind of Wifi connection.

    Thanks!

    20. November 2019 at 13:04 #47560

    Hi Stephane and max2headroom,

    This issue has not occurred with Max2Play in quite some time.

    This topic from 2018 describes to possible fixes.

    Please check first whether the router issue might be your fix.

    If not, please check the config.txt and see whether there are conflicting entries.

    If so, please reply here with your faulty entry so we can find a fix asap.

    24. November 2019 at 13:40 #47592

    Hello Heiner,

    My max2play install is fresh out of the box, so there shouldn’t be conflicting entries (none by default, I guess, and I didn’t add any).

    I did have a Pi1 in my network previously, but since the problem also occurs with the router turned off, and my new Pi4 was never connected to the internet (no cable and no Wifi configured) I can’t see how that thread (which I had already digested before replying to Stephane’s post) could be related.

    (And sorry for the late reply, to me the problem is urgent, but as it turns out I wasn’t subscribed to this thread – now I am.)

    27. November 2019 at 14:36 #47616

    Hi max,

    Very odd indeed. When no network is available, the system should automatically go into access point mode and you should have a max2play wifi network available on your devices to connect to. Here’s our guide

    If this is not the case, please try burning a fresh image onto the SD card and see if the access point sets itself up then. Here’s how you burn the image

    27. November 2019 at 15:07 #47617

    Hm. I am happy to try out anything to solve the problem, but please bear in mind that my setup is 100% new: I already burnt a fresh image onto SD card and ran into these problems. Burning the very same image (it’s still m2p_buster_rpi-v250.img.zip) onto SD card will most certainly lead to the very same problems. Or is there something I’m missing?

    Since I can’t attach an image here, I will be mailing you a screenshot to you can see what’s going on. Possibly there’s some enhanced logging function I can use to provide further details?

    29. November 2019 at 12:44 #47643

    Hi max,

    You can also link to uploaded images from other hosts in the forums to share screenshots.

    I would advise you connect a screen via hdmi to see where the boot sequence stops and whether the access point initiation is even started or not.

    29. November 2019 at 13:11 #47644

    Heiner, with all respect, but you are not being helpful. Either commit yourself to solving this problem, or let it be known that it’s not on your priority list (fair enough) and save the time (please).

    The setup with the screen is what I reported over two weeks ago (it’s in the word „screenshot“). I mailed you the screenshot last Wednesday. I can’t see any access point initiation, although I would assume the boot sequence has a fixed order – if Network Time Sync comes before access point initiation, or as an alternative to it, and the boot is stuck at time synchro, it is probably logical that the initiation never happens.

    4. Dezember 2019 at 15:17 #47678

    Hi max2headroom,

    We tried to recreate your issue with the exact same setup and tried with three different variants.

    Either your Pi has a specific issue, your sd card does or it’s something to do with your home network.

    How many newly burnt images did you try out? Did you burn it using Etcher or another software?

    4. Dezember 2019 at 15:38 #47679

    Hello Heiner,

    Thanks for the effort. It’s a bit unfortunate that Stephane doesn’t chime in – that would make it a lot easier to figure out what his setup and mine have in common (at least it looks like its not only my Pi having this problem – of three known setups with Amp2+Pi4+max2play, it seems like two had problems). Did you try to email him?

    You haven’t responded to my statement that my installation is out of the box, and the pi isn’t connected to the internet. In my book, that 100% rules out any issues with the home network or my router, as the pi4 doesn’t even know I have internet. If I’m missing something, please let me know.

    As for the rest, I have followed the instructions on this site and used the recommended Win32Disk-Imager. If I should use a different SD card and different burning software or change other parameters, let me know and I will try that. For obvious reasons, the only thing I can’t provide is a second Pi.

    Last but not least: In your test setup, was your Pi connected to the internet? Just to point out the obvious: The error sounds like max2play is trying to do something over internet, but can’t. So maybe the problem isn’t with the home network, but with the fact that there is no network to begin with. Thanks!

    5. Dezember 2019 at 18:59 #47682

    Hi Heiner and Max2Headroom,

    As stated before, my config is a brand new RPI 3B with Max2Play 2.49 and an Amp2 board.
    The disk image is writen to a fresh Sandisk 8Go SD card.
    And the RPI was connected to my network and, as a consequence, to Internet.

    In my case, the two key facts I find out are that the boot process is flawless when I remove :
    – either the Amp2 board,
    – or the fixed IP.
    Of course, I choosed the second solution.

    One last thing : I detected this issue on October, 27th, precisely the day when France moved to winter time. I don’t know whether this be related to the time synchro issue cause I didn’t move further on analyzing the case.

    6. Dezember 2019 at 10:41 #47684

    Just to give some details on my boot process…

    I get:

    [ OK ] Starting Network Time Synchronization…
    [FAILED] Failed to start Network Time Synchronization
    [ OK ] Stopped Network Time Synchronization

    So far, so good. System wants to sync, notices it can’t (no network available in my case) and stops. But then I get:

    Starting Network Time Synchronization…
    A start job is running for Network Time Synchronization (27s / 30s)

    It starts to count from 1s to 30s, but at 27s it hangs.

    Looks similar to Stephane’s protocol, doesn’t it. The problem for us, of course, is that the boot process hangs, but maybe the actual question to ask is, why does the boot process try to synch network time AGAIN after it already found out that it won’t work?!

    • This reply was modified 11 months, 3 weeks ago by  max2headroom.
    6. Dezember 2019 at 12:48 #47697

    Hi guys,

    Stephane, you mentioned that the issue occurs when the AMP2 is connected and it doesn’t when it’s removed.

    What power supply are you using with the AMP2?

    max2headroom, have you tried booting the Pi without AMP2? Do you have 5V power supply to test this out?

    6. Dezember 2019 at 13:23 #47698

    „Do you have 5V power supply to test this out?“

    Nope I’m afraid I haven’t – if I did, I would have tested and reported. (I’m *assuming* it will be fine then, but of course assumptions aren’t perfect for troubleshooting.)

    PS: Power supply for the AMP2 is 19V/3.42A

    • This reply was modified 11 months, 3 weeks ago by  max2headroom.
    6. Dezember 2019 at 15:30 #47700

    Okay, so a PSU issue is unlikely.

    Could you try out another image (official Raspbian download) to rule out a general issue with the Raspberry Pi and AMP2 hardware?

    9. Dezember 2019 at 13:06 #47715

    I’m currently running LibreELEC without any issues, so I guess that rules out any hardware problem.

    PS: Starting tomorrow, I will be traveling until the day before X-mas, so I won’t be able to do any additional testing on my hardware.

    • This reply was modified 11 months, 3 weeks ago by  max2headroom.
    12. Dezember 2019 at 16:19 #47759

    Hi max,

    Sorry that we didn’t find the issue in time before your departure.

    I suggest you try another time when you get back and download the newest image. Try connecting to ethernet to see if the error is completely generally occurring or if we can focus on the automatic access point mode.

    25. Dezember 2019 at 20:33 #47831

    With an ethernet cable connected, I still get the same results.

    But to my surprise, when I install Max2Play on an old 8GB Hama 4x MicroSD it boots without problems (albeight slowly). No luck, however, with a brand new 32GB Samsung EVO Plus.

    Dunno. Maybe some weird timing glitch, where one process is supposed to wait for another, but when the card loads too quickly, those ends never meet?

    2. Januar 2020 at 10:46 #47862

    I completely concur that it looks like there is some sort of timing issue. I have a Pi 4 and a HiFiBerry Amp 2. Previously they ran Raspbian with no issues. On a clean boot with MAX2Play it continually stuck at

    A start job is running for Network Time Synchronization (24s / 30s)

    I tried 2 different SD cards each time same result (though they were the same 16G SAN disk cards). As it was a new boot no files to edit. I also tried it with wireless and WPS/no WPS and with a fixed LAN cable, same result each and every time. Tried 2 different power supplies both the same.

    At this point I only had a display plugged into the HDMI port and had tried it multiple times.

    I then plugged in a Keyboard and mouse to the USB ports (didn’t use them) and suddenly it all booted fine. It was interesting to note there were more lines displayed on the initial boot screen and boot was a fraction longer.

    I then did have to edit the config.txt to comment out the line as it only worked once and was then back to the same situation.

    dtoverlay=iqaudio-dacplus

    But after that all good and now boots cleanly every time.

    This makes me think there are 2 issues, a timing one and the extra line in the config file one. I really think its worth you investigating further.

    Barry

    5. Januar 2020 at 20:23 #47875

    Hi,

    I have the same issue as stated above.

    Setup:
    RPI 3 Model B v1.2
    SD Card: Kingston 8Gb
    Flashing software: Etcher
    Board: Hifiberry Amp2 1.0

    Boots without a hiccup without the board

    When I plug the board: Gets stuck at Time Synchro. Stops it once. Retries and freezes after 24sec out of 30.
    I tried with an RJ45 cable (Ethernet) plugged in and without.
    Both the Raspberry, the flash card and the Hifiberry board are brand new.

    Any suggestion? I’d love for my multiroom audio system to work 🙂

    Thanks guys!
    Geoffrey

    5. Januar 2020 at 21:22 #47876

    Have you tried plugging a keyboard and mouse into the USB ports, re-doing a fresh image on the MicroSD card and trying again with the Network cable attached. That did it for me.

    If you have a Keyboard and mouse plugged in, try it with them unplugged, it seems like a timing issue and you just have to change enough to make it work.

    I am also trying to get a multi-room system running. It is a bit frustrating as I think it will work, it just isn’t quote as smooth as it should be..

    Barry

    21. Februar 2020 at 22:55 #48054

    Hi

    I had the same issue today when installing Max2Play using the Max2Play Image. It’s a Raspberry Pi 3B+ with an Amp2.
    I couldn’t find any solution. I reinstalled the Image several times on different SDs. No luck.
    But the solution of BarryW was working for me too. Thanks!!

    Ralph

    • This reply was modified 9 months, 1 week ago by  baerengraben.
    16. Mai 2020 at 18:12 #48799

    Hi there again,

    After leaving that project aside for some months, I’m getting back on it.

    I still run in the same issue.. With 3 Raspberry Pi 3 and AMP2.

    Setup:
    RPI 3 Model B v1.2
    SD Card: Kingston 8Gb
    Flashing software: Win32 DiskImager
    Board: Hifiberry Amp2 1.0
    Power supply: 12V/5A

    Just downloaded the latest image I could find on the site: m2p_stretch_rpi_v249.img

    Tried multiple burn, didn’t work.
    Tried scenarios where I pluggued the network cable, unpluggued the cable, added keyboard and mouse, removed it, so far none of them worked…

    Has any progress been made on this?
    Looking forward to hearing from you,
    Cheers,
    Geoffrey

    19. Mai 2020 at 15:40 #48811

    Hi Geoffrey,

    I recreated and tested your setup, but I didn’t come across the problems you were experiencing. Can you connect a screen via HDMI to see where the boot process stops? As a workaround, you could try to set up your Pi without an amp first and connect the amp later when you already selected the right driver.

    3. Juni 2020 at 0:24 #48936

    Hi Geoffrey,

    Don’t waste your time with Max2Play. If you look through the responses given (something which MarioM couldn’t be bothered to do), it’s obvious there’s no real interest in fixing this. Switch to OpenELEC and don’t look back (which is what I did). All the best.

    24. Juni 2020 at 12:18 #49079

    Hi!

    I’ve got the same issue with following setup (4x same):
    Raspberry Pi 4B
    SD Card: SanDisk Extreme 64GB
    Flashing software: Win32 DiskImager
    Board: HifiBerry Amp2
    Power supply: 18V/5A

    Solution is to update the config.txt which incldues the line dtoverlay=iqaudio-dacplus.
    Replace this line with your correct hardware, in my case dtoverlay=hifiberry-dacplus for a HifiBerry Amp2 and boot up works!

    Here you can find an overview: https://www.hifiberry.com/docs/software/configuring-linux-3-18-x/

    I’m happy about positive feedback – or also if it doesn’t work.

    By the way, OpenELEC is discontinued since 2017 😉

    Matthias

Viewing 26 posts - 1 through 26 (of 26 total)

You must be logged in to reply to this topic.

Register here