Bluetooth and OpenHab notifications doesn't play any sound

Max2Play Home 2016 (en) Forums Max2Play as Squeezebox (Player / Server) Bluetooth and OpenHab notifications doesn't play any sound

This topic contains 37 replies, has 3 voices, and was last updated by  Heiner Moderator 1 year, 5 months ago.

Viewing 8 posts - 31 through 38 (of 38 total)
  • 18. Dezember 2018 at 20:09 #42832

    Hi Heiner,
    I reinstalled the Bluetooth plugin and now it is not even starting.

    Thanks.

    Please see the error below:

    #### Bluetooth Installation ####

    #### Bluetooth Dongle ####
    hci1: Type: Primary Bus: UART
    BD Address: B8:27:EB:92:68:C6 ACL MTU: 1021:8 SCO MTU: 64:1
    UP RUNNING
    RX bytes:743 acl:0 sco:0 events:44 errors:0
    TX bytes:1029 acl:0 sco:0 commands:44 errors:0

    hci0: Type: Primary Bus: USB
    BD Address: 00:02:72:B0:00:26 ACL MTU: 192:8 SCO MTU: 64:8
    UP RUNNING
    RX bytes:1014 acl:0 sco:0 events:45 errors:0
    TX bytes:937 acl:0 sco:0 commands:45 errors:0

    #### BLUEALSA ERROR ####
    ● bluealsa.service – Start Bluealsa for Bluetooth on Alsa (not compatible with Pulseaudio)
    Loaded: loaded (/etc/systemd/system/bluealsa.service; enabled; vendor preset: enabled)
    Active: activating (start-pre) since Tue 2018-12-18 18:06:02 GMT; 50ms ago
    Process: 2570 ExecStart=/usr/bin/bluealsa -p a2dp-sink -p a2dp-source (code=exited, status=127)
    Main PID: 2570 (code=exited, status=127); Control PID: 2839 (sleep)
    CGroup: /system.slice/bluealsa.service
    └─control
    └─2839 /bin/sleep 2

    Dec 18 18:06:02 soundsystem systemd[1]: Starting Start Bluealsa for Bluetooth on Alsa (not compatible with Pulseaudio)…

    #### BLUEALSA RUNNING ####
    0

    #### BLUETOOTH SQUEEZEBOX SERVER AUTOSTART ####
    Logfile was modified.
    Reading last 10 lines of /var/log/daemon.log
    Logfile was modified.
    Reading last 10 lines of /var/log/daemon.log
    Logfile was modified.
    Reading last 10 lines of /var/log/daemon.log
    Logfile was modified.
    Reading last 10 lines of /var/log/daemon.log
    Logfile was modified.
    Reading last 10 l

    19. Dezember 2018 at 11:38 #42851

    So you have not tried a fresh image yet? Please make a backup of your current image, burn a fresh one and see if you can recreate the issue. If so, we might be able to fix your issue with a patch update.

    20. Dezember 2018 at 13:12 #42916

    Hi Heiner,
    I have done a fresh reinstall and am currently setting it up again.
    For some reason, I can only connect to the web interface through the IP (192.168.1.151) instead of through max2play/ (which gives a too long to respond error).

    I will keep you updated about the Bluetooth issue.

    Thanks,
    Josh

    20. Dezember 2018 at 13:34 #42924

    Again, Bluetooth does not work. LMS switches to wavin:bluetooth, however that only lasts for around 1 second (and no audio is played through it).

    Thanks

    The Max2Play Debug File
    #### Bluetooth Installation ####

    #### Bluetooth Dongle ####
    hci0: Type: Primary Bus: UART
    BD Address: B8:27:EB:92:68:C6 ACL MTU: 1021:8 SCO MTU: 64:1
    UP RUNNING
    RX bytes:7182 acl:76 sco:0 events:143 errors:0
    TX bytes:4794 acl:71 sco:0 commands:71 errors:0

    #### DEVICE Joshua Heng’s iPhone ####

    #### DEVICE [TV] Joshua’s Computer ####

    #### DEVICE 49-AE-B2-41-F6-51 ####
    [49:AE:B2:41:F6:51]
    Name: (null)
    Alias: (null) [rw]
    Address: (null)
    Icon: (null)
    Class: 0x0
    Paired: 0
    Trusted: 0 [rw]
    Blocked: 0 [rw]
    Connected: 0
    UUIDs: [

    #### DEVICE 47-F6-17-FF-72-33 ####
    [47:F6:17:FF:72:33]
    Name: (null)
    Alias: (null) [rw]
    Address: (null)
    Icon: (null)
    Class: 0x0
    Paired: 0
    Trusted: 0 [rw]
    Blocked: 0 [rw]
    Connected: 0
    UUIDs: [

    #### DEVICE 4F-E8-E0-EC-E8-2E ####
    [4F:E8:E0:EC:E8:2E]
    Name: (null)
    Alias: (null) [rw]
    Address: (null)
    Icon: (null)
    Class: 0x0
    Paired: 0
    Trusted: 0 [rw]
    Blocked: 0 [rw]
    Connected: 0
    UUIDs: [

    #### BLUEALSA RUNNING ####
    1

    #### BLUETOOTH SQUEEZEBOX SERVER AUTOSTART ####

    The Max2Play Log

    Search
    Refresh (50, 100, 500, 1000 lines) Download
    [18-12-20 11:01:02.2809] Slim::Control::Request::renderAsArray (2233) Backtrace:

    frame 0: Slim::Utils::Log::logBacktrace (/usr/share/perl5/Slim/Control/Request.pm line 2233)
    frame 1: Slim::Control::Request::renderAsArray (/usr/share/perl5/Slim/Plugin/CLI/Plugin.pm line 697)
    frame 2: Slim::Plugin::CLI::Plugin::cli_request_write (/usr/share/perl5/Slim/Plugin/CLI/Plugin.pm line 1010)
    frame 3: Slim::Plugin::CLI::Plugin::cli_subscribe_notification (/usr/share/perl5/Slim/Control/Request.pm line 2058)
    frame 4: (eval) (/usr/share/perl5/Slim/Control/Request.pm line 2058)
    frame 5: Slim::Control::Request::notify (/usr/share/perl5/Slim/Control/Request.pm line 859)
    frame 6: Slim::Control::Request::checkNotifications (/usr/sbin/squeezeboxserver line 708)
    frame 7: main::idle (/usr/sbin/squeezeboxserver line 677)
    frame 8: main::main (/usr/sbin/squeezeboxserver line 1213)

    [18-12-20 11:01:08.2947] Slim::Utils::SQLiteHelper::postConnect (374) Optimizing DB because of missing or empty sqlite_stat1 table
    [18-12-20 11:01:08.3212] Slim::Schema::forceCommit (2149) Warning: Trying to commit transactions before DB is initialized!
    2018-12-20 11:06:01 squeezeboxserver_safe stopped.
    2018-12-20 11:06:04 squeezeboxserver_safe started.
    [18-12-20 11:06:15.3157] main::init (387) Starting Logitech Media Server (v7.9.1, 1522157629, Fri Mar 30 12:27:11 CEST 2018) perl 5.024001 – arm-linux-gnueabihf-thread-multi-64int
    [18-12-20 11:06:17.8665] Slim::Utils::SQLiteHelper::postConnect (374) Optimizing DB because of missing or empty sqlite_stat1 table
    [18-12-20 11:06:17.9354] Slim::Schema::forceCommit (2149) Warning: Trying to commit transactions before DB is initialized!
    [18-12-20 11:06:18.6595] Slim::Utils::SQLiteHelper::postConnect (374) Optimizing DB because of missing or empty sqlite_stat1 table
    [18-12-20 11:06:18.7149] Slim::Schema::forceCommit (2149) Warning: Trying to commit transactions before DB is initialized!
    [18-12-20 11:06:21.6796] Slim::Utils::SQLiteHelper::postConnect (374) Optimizing DB because of missing or empty sqlite_stat1 table
    [18-12-20 11:06:21.7059] Slim::Schema::forceCommit (2149) Warning: Trying to commit transactions before DB is initialized!
    [18-12-20 11:06:22.4088] main::checkDataSource (1110) Warning: Schema updated or no media found in the database, initiating scan.
    [18-12-20 11:06:22.7668] Slim::Control::Request::renderAsArray (2233) Error: request should set useIxHashes in Slim::Control::Request->new()
    [18-12-20 11:06:22.7687] Slim::Control::Request::renderAsArray (2233) Backtrace:

    frame 0: Slim::Utils::Log::logBacktrace (/usr/share/perl5/Slim/Control/Request.pm line 2233)
    frame 1: Slim::Control::Request::renderAsArray (/usr/share/perl5/Slim/Plugin/CLI/Plugin.pm line 697)
    frame 2: Slim::Plugin::CLI::Plugin::cli_request_write (/usr/share/perl5/Slim/Plugin/CLI/Plugin.pm line 1010)
    frame 3: Slim::Plugin::CLI::Plugin::cli_subscribe_notification (/usr/share/perl5/Slim/Control/Request.pm line 2058)
    frame 4: (eval) (/usr/share/perl5/Slim/Control/Request.pm line 2058)
    frame 5: Slim::Control::Request::notify (/usr/share/perl5/Slim/Control/Request.pm line 859)
    frame 6: Slim::Control::Request::checkNotifications (/usr/sbin/squeezeboxserver line 708)
    frame 7: main::idle (/usr/sbin/squeezeboxserver line 677)
    frame 8: main::main (/usr/sbin/squeezeboxserver line 1213)

    [18-12-20 11:06:28.5758] Slim::Utils::SQLiteHelper::postConnect (374) Optimizing DB because of missing or empty sqlite_stat1 table
    [18-12-20 11:06:28.6020] Slim::Schema::forceCommit (2149) Warning: Trying to commit transactions before DB is initialized!
    [18-12-20 11:22:28.2262] Slim::Utils::SQLiteHelper::postConnect (374) Optimizing DB because of missing or empty sqlite_stat1 table
    [18-12-20 11:22:28.2615] Slim::Schema::forceCommit (2149) Warning: Trying to commit transactions before DB is initialized!
    [18-12-20 11:22:34.5238] Slim::Utils::SQLiteHelper::postConnect (374) Optimizing DB because of missing or empty sqlite_stat1 table
    [18-12-20 11:22:34.5503] Slim::Schema::forceCommit (2149) Warning: Trying to commit transactions before DB is initialized!
    [18-12-20 11:26:00.1021] Slim::Control::Request::execute (1888) Error: While trying to run function coderef [Slim::Plugin::Favorites::Plugin::cliAdd]: [Can’t call method „string“ on an undefined value at /usr/share/perl5/Slim/Plugin/Favorites/Plugin.pm line 869.
    ]
    [18-12-20 11:26:00.1060] Slim::Plugin::CLI::Plugin::cli_process (640) Request [favorites] failed with error: Bad dispatch!
    2018-12-20 11:26:01 squeezeboxserver_safe stopped.
    2018-12-20 11:26:03 squeezeboxserver_safe started.
    [18-12-20 11:26:11.4563] main::init (387) Starting Logitech Media Server (v7.9.1, 1522157629, Fri Mar 30 12:27:11 CEST 2018) perl 5.024001 – arm-linux-gnueabihf-thread-multi-64int
    [18-12-20 11:28:31.4911] Slim::Plugin::CLI::Plugin::cli_process (640) Request [playlist] failed with error: Bad params!

    Log image

    25. Dezember 2018 at 19:39 #42938

    Hi Heiner, have you got any recommendations of fixes that I could make?

    Thanks,
    Josh

    3. Januar 2019 at 11:30 #43048

    Hi Josh,

    Happy New Year!

    We will set up the same system here with a 3B+ and fresh image and see if we can recreate it, today. Thank you for your detailed reports.

    3. Mai 2019 at 18:35 #45253

    Was this issue ever reesolved?
    I find myself with whatr looks like the same situation.

    This is the first time set up with a brand new purchased bundle.

    I scan for bluetooth devices and find my phone.
    I try to connect via the M2P Bluetooth dashboard.
    The phones says connected to max2play.
    But the yellow box says;

    *****

    Attempting to pair with 50:BC:96:A0:E3:03
    Failed to pair: org.bluez.Error.AlreadyExists
    connect 50:BC:96:A0:E3:03
    Attempting to connect to 50:BC:96:A0:E3:03
    Device 50:BC:96:A0:E3:03 Connected: yes
    Connection successful
    quit
    Waiting to connect to bluetoothd…

    ******
    It hangs there forever and never connects or turns green.

    6. Mai 2019 at 11:47 #45273

    Hi Brian,

    Sorry about that, we indeed fixed this. There was a bug in the connection protocol that we added to the most current beta but should also be included in the new, proper 2.48 update.

    For anyone still affected by connection issues (version 2.47 and older), please do the following to fix your bluetooth:

    – Head to Settings/Reboot and click the Update Button
    – When the update is finished, head to Bluetooth and „Uninstall Bluetooth“
    – Refresh the Bluetooth menu if necessary and „Install Bluetooth“
    – Reboot after the installation is finished

    Your system should now be able to connect to any Bluetooth device again.

Viewing 8 posts - 31 through 38 (of 38 total)

You must be logged in to reply to this topic.

Register here