Bluetooth Add-on Raspberry Pi Zero

Max2Play Home 2016 (en) Forums Max2Play Add-ons Bluetooth Add-on Raspberry Pi Zero

This topic contains 7 replies, has 3 voices, and was last updated by  Heiner Moderator 2 months, 2 weeks ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • 9. December 2017 at 22:36 #32846

    I’m trying to setup Max2Play on a RaspberryPi Zero as a Bluetooth receiver for my Echo Dot. I want to stream the Bluetooth audio to the Squeezebox server running on the same device. When I install Bluetooth Streaming for Squeezebox Server I get a message that no Bluetooth Device is connected. The full output is below as is the output of hciconfig -a showing the Bluetooth address for the onboard device. Is there a step I’m missing for Max2Play to detect the onboard Bluetooth? I have already run apt-get update and upgrade.

    Install Bluetooth support for Squeezebox Server
    start X-Server
    Install Waveinput Plugin
    Archive: /opt/max2play/cache/
    inflating: /opt/max2play/cache/WaveInput/custom-convert.conf 
    inflating: /opt/max2play/cache/WaveInput/custom-convert.conf.eca 
    inflating: /opt/max2play/cache/WaveInput/custom-types.conf 
    inflating: /opt/max2play/cache/WaveInput/HTML/EN/plugins/WaveInput/settings/basic.html 
    inflating: /opt/max2play/cache/WaveInput/HTML/EN/plugins/WaveInput/html/images/waveinput.png 
    inflating: /opt/max2play/cache/WaveInput/install.xml 
    inflating: /opt/max2play/cache/WaveInput/ 
    inflating: /opt/max2play/cache/WaveInput/ 
    inflating: /opt/max2play/cache/WaveInput/strings.txt 
    inflating: /opt/max2play/cache/WaveInput/ 
    Add some magic...
    /opt/max2play/cache /var/www/max2play/public
    updating: WaveInput/custom-convert.conf (deflated 56%)
    updating: WaveInput/custom-convert.conf.eca (deflated 47%)
    updating: WaveInput/custom-types.conf (deflated 70%)
    updating: WaveInput/HTML/ (stored 0%)
    updating: WaveInput/HTML/EN/ (stored 0%)
    updating: WaveInput/HTML/EN/plugins/ (stored 0%)
    updating: WaveInput/HTML/EN/plugins/WaveInput/ (stored 0%)
    updating: WaveInput/HTML/EN/plugins/WaveInput/images/ (stored 0%)
    updating: WaveInput/HTML/EN/plugins/WaveInput/settings/ (stored 0%)
    updating: WaveInput/HTML/EN/plugins/WaveInput/settings/basic.html (deflated 40%)
    updating: WaveInput/HTML/EN/plugins/WaveInput/html/ (stored 0%)
    updating: WaveInput/HTML/EN/plugins/WaveInput/html/images/ (stored 0%)
    updating: WaveInput/HTML/EN/plugins/WaveInput/html/images/waveinput.png (deflated 1%)
    updating: WaveInput/install.xml (deflated 47%)
    updating: WaveInput/ (deflated 54%)
    updating: WaveInput/ (deflated 58%)
    updating: WaveInput/strings.txt (deflated 45%)
    updating: WaveInput/ (deflated 55%)
    adding: WaveInput/ (stored 0%)
    WaveInput installed
    No Bluetooth-Device is connected! Make sure to connect this first!
    Now: Choose Bluetooth from favorites in Squeezebox Server and click play OR enable Autostart Bluetooth-Streaming in Squeezebox Server on this page. After this, you can stream audio from your smartphone to your Squeezebox Server and multiple players.
    Restarting logitechmediaserver (via systemctl): logitechmediaserver.service.
    Update Configfile - existing Entry changed
    bluetooth successfully removed from autostart
    Update Configfile - existing Entry changed
    bluetooth successfully added to autostart
    No running X-Server found! Bluetooth needs Pulseaudio and a active X-Session to run! Please activate Autostart...

    hciconfig -a

    hci0:	Type: BR/EDR  Bus: UART
    	BD Address: B8:27:EB:66:43:CC  ACL MTU: 1021:8  SCO MTU: 64:1
    	RX bytes:1298 acl:0 sco:0 events:51 errors:0
    	TX bytes:1543 acl:0 sco:0 commands:51 errors:0
    	Features: 0xbf 0xfe 0xcf 0xfe 0xdb 0xff 0x7b 0x87
    	Packet type: DM1 DM3 DM5 DH1 DH3 DH5 HV1 HV2 HV3 
    	Link policy: RSWITCH SNIFF 
    	Link mode: SLAVE ACCEPT 
    	Name: 'Server-DiningRoom'
    	Class: 0x000000
    	Service Classes: Unspecified
    	Device Class: Miscellaneous, 
    	HCI Version: 4.1 (0x7)  Revision: 0x145
    	LMP Version: 4.1 (0x7)  Subversion: 0x2209
    	Manufacturer: Broadcom Corporation (15)
    • This topic was modified 3 months, 1 week ago by  ghoover.
    12. December 2017 at 12:45 #32889

    Hi ghoover,

    Bluetooth pairing should work from the first boot with Max2Play. What output do you get when searching for nearby devices? If you find your device and click connect, what’s the output?

    17. December 2017 at 4:24 #32992

    The max2play device does not appear when searching for nearby devices.

    18. December 2017 at 11:19 #33007

    Hi ghoover,

    If you are looking for BT input, please make sure your input device is in open pairing mode, then search for devices in the Max2Play web interface, click “connect” on your device of choice and afterwards it should turn from red to green in the list.

    24. December 2017 at 10:35 #33099

    I want to stream from my Echo to Squeezebox (ie. Squeeze box acts as the receiver). Typically pairing is initiated from the sender but I cannot see the RPi as a Bluetooth receiver. If I run sudo hciconfig hci0 piscan then the RPi shows up but it doesn’t successfully pair. Can you point me to a step by step on how pairing should work?

    2. January 2018 at 10:55 #33174

    Hi ghoover,

    With M2P’s BT plugin, pairing is initiated in Max2Play’s web interface. In BT menu, you should see the device after making a first scan. Then, as mentioned before, you need to click “Connect” which should prompt the pairing process.

    2. January 2018 at 11:00 #33177

    I post here because in my topic i have a never response after 6 days.

    I have exactly the same speaker as the one used in the tutorial:

    3 Audio Players in 1 Raspberry Pi With Bluetooth & Max2Play

    I would like to know if when i install Bluetooth Add-on does the speaker go to sleep alone?
    If yes, would you have a solution to avoid this?
    Because it would be compelling to have to turn it on again each time.

    I hope finally have a response 😉

    • This reply was modified 2 months, 2 weeks ago by  medapayne.
    2. January 2018 at 11:33 #33180

    Hi medapayne,

    As mentioned before, I was out of office during the holidays. Here is my response in your topic:

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.

Register here