Autostart Rotary Encoder Software

Max2Play Home 2016 (en) Forums Max2Play Add-ons Autostart Rotary Encoder Software

This topic contains 7 replies, has 3 voices, and was last updated by  MarioM Moderator 6 months, 2 weeks ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • 19. Januar 2021 at 21:30 #50623

    Hallo,

    ich betreibe folgende Konstellation:

    Raspberry Pi 3b
    NEW IQaudIO Pi-DigiAMP+
    Rotary Encoder
    Max2Play Version 2.53

    Alles aus dem Max2Play Shop.

    Installierte Plugins:
    Max2Play – IQaudIO Edition
    Hardwarecontrol Setup for Rotary Encoder and IR remotes
    Mediaplayer Squeezelite & Airplay

    Alle neueste Versionen.

    Der Rotary Encoder macht mir Kummer, besser gesagt die zugehörige Software. Obwohl der Haken bei Autostart gesetzt ist, startet die Software beim booten nicht und es wird folgende Meldung angezeigt:

    Rotary Encoder Software NOT Running!

    Die Lautstärke lässt sich auch nicht regeln.

    Nach Klick auf Neustarten funktioniert der Drehregler wie gewünscht.

    Auch im IQaudIO Plugin ist die Drehknopf-Encoder-Software installiert und steht auf Autostart.

    Selbst eine komplette Neuinstallation auf dem Pi der Max2Play Software brachte keine Abhilfe.

    Des Weiteren reagiert die Button-Funktion des Drehreglers nur sehr sporadisch auf den Play/Pause Befehl.

    Kann mir jemand weiterhelfen?

    Danke für jeden Tipp.

    • This topic was modified 8 months ago by  Carsten.
    • This topic was modified 8 months ago by  Carsten.
    22. Januar 2021 at 15:33 #50632

    Hallo Carsten,

    Unser Hardware Control Plugin ersetzt die entsprechenden Optionen im IQaudIO Plugin. Daher kann es vorkommen, wenn du den Rotary Encoder in beiden Plugins installiert hast, dass Fehler auftreten. Bitte erstelle nochmal ein neues Image und installiere ausschließlich das Hardware Control Plugin. Funktioniert der Autostart dann korrekt?

    22. Januar 2021 at 19:59 #50633

    Hallo Mario,

    vielen Dank für dein Feedback.

    Jetzt funktioniert alles korrekt, auch die Play/Pause Funktion.
    Danke für den Tipp!

    Das bedeutet dann also, dass man das IQaudIO Plugin selbst gar nicht installieren darf und die Audiokarte im Audioplayer-Plugin definieren muss, richtig?

    Gruß Carsten

    25. Januar 2021 at 16:22 #50642

    Hallo Carsten,

    das IQaudIO Plugin kannst du trotzdem installieren, nur nicht die Rotary Encoder Funktion. Die Soundkarte kannst du dann entweder über die Raspberry Einstellungen oder das IQaudIO Plugin auswählen.

    25. Januar 2021 at 22:20 #50656

    Hallo Mario,

    ich habe das jetzt mal getestet und das IQaudIO Plugin nachinstalliert, ohne Rotary Encoder Funktion und auch ohne den Haken bei Autostart im Plugin. Ab diesem Moment funktioniert der Autostart des Hardware Control Plugins nicht mehr. Das Inaktivieren des IQaudIO Plugins nützt dann auch nichts, da hilft wohl nur wieder ein neues Image zu brennen und das Plugin nicht zu installieren. Die zwei wollen sich wohl nicht so ganz miteinander vertragen.

    Gruß Carsten.

    27. Januar 2021 at 14:23 #50660

    Hallo Carsten,

    Danke für die Info und deinen Test. Ich werde das mal prüfen und an unseren Entwickler weitergeben. Dann bleibt dir erstmal leider nur ein erneutes Brennen der SD-Karte. Die Soundkarte kannst du wie gesagt auch ganz einfach in den Raspberry Einstellungen konfigurieren. Das IQaudIO Plugin ist damit sowieso praktisch überflüssig.

    4. März 2021 at 14:26 #50876

    Hallo,

    ich habe eine NEW IQaudIO Pi-DigiAMP+ auf einem Pi4 laufen und habe das gleiche Autostartproblem wie Carsten beschrieben hat. Die Installation ist ohne das IQaudiO Plugin aufgesetzt, trotzdem funktioniert der Autostart leider nicht.

    Gibt es hier einen Lösungsansatz?

    Danke!

    Gruß Reiner

    5. März 2021 at 15:14 #50880

    Hallo Reiner,

    unser Entwickler ist leider noch nicht dazu gekommen, einen Fix für das Problem zu implementieren. Vielleicht hilft der Lösungsansatz von HHit aus diesem Thread: https://www.max2play.com/en/forums/topic/max2play-hardware-control-plugin-we-need-your-feedback/page/3/#post-50563

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.

Register here