[ANNOUNCE] OpenHAB Server Plugin Beta

Max2Play Home 2016 (en) Forums Max2Play Add-ons [ANNOUNCE] OpenHAB Server Plugin Beta

This topic contains 12 replies, has 3 voices, and was last updated by  Heiner Moderator 1 week, 2 days ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • 5. September 2018 at 11:11 #37640

    Hi everyone, I wanted to let you know about our new beta openHAB plugin!

    It’s basically a one-click installer of the openHAB 2 server with some other neat features on our web interface menu, including:

    • edit field for webinterface port (in case you also want to run Squeezebox Server on the Pi)
    • Save and Restore Settings buttons to back up your preferences and restore them
    • Small guide on integrating Alexa (work in progress)
    • Uninstall button
    • Debug Information output

    We would appreciate any feedback from the community to make sure this integration becomes the best it can be.

    You can install the plugin in any running Max2Play system (free and premium) by copying the following link at the bottom of the Settings/Reboot menu:
    http://shop.max2play.com/media/downloadable/beta/openhab.tar

    Let me know what you think! :slight_smile:

    10. September 2018 at 16:10 #37748

    Hi, I really want to try this, but I can’t install openHab server.
    I installed the add-on, created an openhab user but when I click on the button to install I get this message

    WARNING: The following packages cannot be authenticated!
    libassuan0 libksba8 libpth20 dirmng

    And I think that the installation fails.

    10. September 2018 at 16:32 #37749

    Hi Gianpaolo,

    Thank you for contacting us with your issue.

    I just tested the installer on a new image with RPi3B and was not able to recreate the issue.
    The last three lines of yellow text in your webinterface should be:

    Processing triggers for fontconfig (2.11.0-6.7) ...
    Setting up gsfonts-x11 (0.24) ...
    Finished - please click here to reload Page to see Changes

    What is your exactly hardware setup?

    What user are you referring to? You should not be able to do anything in our plugin before installing the server.

    10. September 2018 at 17:03 #37753

    I have a Raspberry Pi3.
    The user I’m referring to is the one on the myopenhab service which is mandatory to connect Alexa with openhab, right?
    I tried again now to install openHAB server on my Raspberry but I got the same message again:

    OpenHAB (version 2) installation started
    Installazione iniziata – questo messaggio si aggiorna ogni 3 secondi per monitorare il processo di installazione. Se l´installazione é completata, questo messaggio sparisce.
    Reading state information…
    Reading package lists…
    Building dependency tree…
    Reading state information…
    The following extra packages will be installed:
    libassuan0 libksba8 libpth20
    The following NEW packages will be installed:
    dirmngr libassuan0 libksba8 libpth20
    0 upgraded, 4 newly installed, 0 to remove and 7 not upgraded.
    Need to get 419 kB of archives.
    After this operation, 975 kB of additional disk space will be used.
    WARNING: The following packages cannot be authenticated!
    libassuan0 libksba8 libpth20 dirmngr
    Executing: gpg –ignore-time-conflict –no-options –no-default-keyring –secret-keyring /tmp/tmp.BCMu4epUkt –trustdb-name /etc/apt//trustdb.gpg –keyring /etc/apt/trusted.gpg –primary-keyring /etc/apt/trusted.gpg –recv-key –keyserver keyserver.ubuntu.com EEA14886
    deb http://ppa.launchpad.net/webupd8team/java/ubuntu trusty main
    deb-src http://ppa.launchpad.net/webupd8team/java/ubuntu trusty main
    Reading package lists…
    Building dependency tree…
    Reading state information…
    Finished – please click here to reload Page to see Changes

    Let me know if and where I can get more info to debug it.

    10. September 2018 at 17:11 #37755

    I managed to install those unauthenticated packages via ssh, but now if I click on the Install openHAB button I get this message and nothing changes.

    OpenHAB (version 2) installation started
    Installazione iniziata – questo messaggio si aggiorna ogni 3 secondi per monitorare il processo di installazione. Se l´installazione é completata, questo messaggio sparisce.
    2018-09-10 17:08:05|
    OK
    Reading package lists…
    Building dependency tree…
    Reading state information…
    Reading package lists…
    Building dependency tree…
    Reading state information…
    dirmngr is already the newest version.
    0 upgraded, 0 newly installed, 0 to remove and 7 not upgraded.
    Executing: gpg –ignore-time-conflict –no-options –no-default-keyring –secret-keyring /tmp/tmp.RTovhmudlQ –trustdb-name /etc/apt//trustdb.gpg –keyring /etc/apt/trusted.gpg –primary-keyring /etc/apt/trusted.gpg –recv-key –keyserver keyserver.ubuntu.com EEA14886
    deb http://ppa.launchpad.net/webupd8team/java/ubuntu trusty main
    deb-src http://ppa.launchpad.net/webupd8team/java/ubuntu trusty main
    Reading package lists…
    Building dependency tree…
    Reading state information…
    Finished – please click here to reload Page to see Changes

    Should I try to reinstall the add On?

    10. September 2018 at 17:23 #37758

    Yes, manually adding packages might not be ideal.

    Please try uninstalling and reinstalling. During that, please wait ca. 1 minute after no new text shows up before rebooting.

    10. September 2018 at 19:23 #37761

    I tried that (btw, by uninstalling the plugin, you mean to put the openHAB plugin on the inactive list and then reboot?).
    I did it, reactivate the plugin, tried to install openHAB clicking the button but nothing changed. Same messages as before. Still no openHAB server active.

    Please let me know if I can try something else.
    My Max2Play installation is quite old, but I updated regularly and so I did today.

    10. September 2018 at 21:19 #37763

    Hello,

    Just to let you know i got exactly the same issue.

    OpenHAB (version 2) installation started
    Installation démarrée – Les messages seront actualisés toutes les 3 secondes pour montrer la progression de l’installation.Lorsque que c’est terminé le message disparaît.
    Reading state information…
    Reading package lists…
    Building dependency tree…
    Reading state information…
    The following extra packages will be installed:
    libassuan0 libksba8 libpth20
    The following NEW packages will be installed:
    dirmngr libassuan0 libksba8 libpth20
    0 upgraded, 4 newly installed, 0 to remove and 147 not upgraded.
    Need to get 354 kB of archives.
    After this operation, 817 kB of additional disk space will be used.
    WARNING: The following packages cannot be authenticated!
    libassuan0 libksba8 libpth20 dirmngr
    Executing: gpg –ignore-time-conflict –no-options –no-default-keyring –homedir /tmp/tmp.JJb5OJMktq –no-auto-check-trustdb –trust-model always –keyring /etc/apt/trusted.gpg –primary-keyring /etc/apt/trusted.gpg –recv-key –keyserver keyserver.ubuntu.com EEA14886
    deb http://ppa.launchpad.net/webupd8team/java/ubuntu trusty main
    deb-src http://ppa.launchpad.net/webupd8team/java/ubuntu trusty main
    Reading package lists…
    Building dependency tree…
    Reading state information…
    Finished – please click here to reload Page to see Changes

    Here is the log file.

    After clicking on the reload link. The page goes back to the previous state as if i never clicked on „install openHAB“ button

    Best regards,

    Jcmoa

    11. September 2018 at 9:54 #37777

    Hi guys,

    Please let me know which version of Raspbian your Max2Play is based on (Settings/Reboot debug info).

    With the newest image we offer, this would be the relevant output:

    #### LINUX-VERSION ####
    Distributor ID:	Raspbian
    Description:	Raspbian GNU/Linux 9.3 (stretch)
    Release:	9.3
    Codename:	stretch
    11. September 2018 at 10:45 #37789

    #### LOAD AVERAGE ####
    0.17 0.10 0.07 1/144 5950

    #### KERNEL ####
    Linux raspberry 4.1.19-v7+ #858 SMP Tue Mar 15 15:56:00 GMT 2016 armv7l GNU/Linux

    #### LINUX-VERSION ####
    Distributor ID: Debian
    Description: Debian GNU/Linux 7.11 (wheezy)
    Release: 7.11
    Codename: wheezy

    11. September 2018 at 11:40 #37795

    Hi gianpaolo,

    Thanks for the quick response.

    This is probably the reason for the issue, wheezy is a rather old version of Raspbian.

    We already went through Jessie lite and to the newest version Stretch during the last few years.

    First, you can try making an apt-get upgrade in the Raspberry Settings to update your packages.

    But if that does not solve the issue, please consider burning our newest image based on Raspbian Stretch.
    You can download it free from this website and follow the wiki on how to burn it.

    11. September 2018 at 12:15 #37796

    Thanks. I would assume that updating every now and then max2play could keep me up to date.
    I try what you suggest, but I’m rather sure I already did it yesterday.
    Is there a way to avoid losing all my settings? I know I can backup LMS configuration, but what about all the other settings?

    Bye

    11. September 2018 at 14:18 #37799

    Hi Gianpaolo,

    Indeed it does, however, the changes in Raspbian when they migrate to a new version can only be used with a new image. We’ve had to create a Stretch image right away when the Raspberry Pi 3B+ came out because it did not support the older versions‘ Kernels and would not even boot with wheezy or Jessie.
    It is likely that some kind of dependency is the cause of this issue for the installer and to be able to make the installer compatible with the newest models and version Max2Play, we have to focus on the newest.

    You can save LMS settings and create a backup img-file of your image or just burn it to a new card for a physical backup with our image burner plugin.

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.

Register here