24bit/192khz Playback issues

This topic contains 19 replies, has 2 voices, and was last updated by  Heiner Moderator 3 weeks, 3 days ago.

Viewing 20 posts - 1 through 20 (of 20 total)
  • 23. August 2018 at 14:25 #37209

    Hi there.

    I have a Raspberry Pi 3 running the Max2play distribution. Attached to the Pi is a Justboom Digi Hat. From the Digihat I have an optical cable going to a Definitive Sound W9 speaker. I can play native 16bit/44.1khz FLAC but for some reason I cannot play 24bit/192khz. If I connect the setup to a W7 speaker it works but the W9 doesn’t. I only seem to be able to play 24bit/192khz if I use their app and Play-Fi. I checked with Justboom and they said its a software issue and check out the forums here. Can you please help?

    Thank you.

    Ron

    23. August 2018 at 15:05 #37211

    Hi Ron,

    Please share the command line options of your Squeezelite player as well as the debug info.

    23. August 2018 at 15:37 #37214

    The command line options I am using are: 80:4::

    Here is the debug info:

    #### SQUEEZELITE VERSION ####
    Squeezelite Max2Play v1.0.3 based on v1.8.7-999, Copyright 2012-2015 Adrian Smith, 2015-2017 Ralph Irving.

    #### SQUEEZELITE BUILDOPTIONS ####
    Build options: LINUX ALSA EVENTFD RESAMPLE FFMPEG VISEXPORT IR GPIO DSD CONTROLSBS ALSASYNC BLUETOOTHSYNC

    #### AUDIOPLAYER CONFIG ####
    ### Configuration of Audioplayers
    SQUEEZELITE_PARAMETER=-o sysdefault:CARD=sndrpijustboomd -a 80:4::
    SQUEEZESLAVE_PARAMETER=-n plugequal
    SHAIRPORT_PARAMETER=-d sysdefault:CARD=sndrpijustboomd
    USE_USB_DAC=0
    USE_EQUALIZER=1
    SYSTEM_USER=pi
    YMPD_PARAMETER=–webport 8081

    #### SQUEEZELITE -l ####

    #### SHAIRPORT (SYNC) VERSION ####
    3.1.1-OpenSSL-Avahi-ALSA-soxr-sysconfdir:/usr/local/etc

    #### OUTPUT SOUND DETAILS CARD 0 ####
    closed

    #### OUTPUT SOUND DETAILS CARD 1 ####
    closed

    Thank you

    24. August 2018 at 9:18 #37255

    Hi Ron,

    Please try deactivating the build in audio, rebooting, selecting none in the JustBoom menu, rebooting and again selecting the JB Amp HAT and reboot. Afterwards, please check your playback again.

    24. August 2018 at 14:57 #37263

    I’ve actually done a complete re-install and still the same thing.
    Again it doesn’t happen with the W7 speakers of which I have 2 of.
    I’ve updated the firmware on the speakers themselves to the latest
    as well.

    24. August 2018 at 15:10 #37266

    If you are using the Equalizer, please deactivate it to rule it out as a possible source of error.

    Also, please remove the-a 80:4:: parameter from your command line options.

    24. August 2018 at 15:11 #37267

    I wasn’t using the EQ.

    24. August 2018 at 15:19 #37268

    Okay, I was referring to your output from the debug info: USE_EQUALIZER=1

    edit: also, the tips in this topic might help you along.

    • This reply was modified 3 weeks, 6 days ago by  Heiner.
    24. August 2018 at 15:46 #37270

    I didn’t re-enable that when I re-installed.

    24. August 2018 at 15:58 #37272

    Current debug from fresh install with justboom card installed:

    #### SQUEEZELITE VERSION ####
    Squeezelite Max2Play v1.0.2 based on v1.8.4-726, Copyright 2012-2015 Adrian Smith, 2015-2016 Ralph Irving.

    #### SQUEEZELITE BUILDOPTIONS ####
    Build options: LINUX ALSA EVENTFD RESAMPLE FFMPEG VISEXPORT IR GPIO DSD CONTROLSBS ALSASYNC BLUETOOTHSYNC

    #### AUDIOPLAYER CONFIG ####
    ### Configuration of Audioplayers
    SQUEEZELITE_PARAMETER=-o sysdefault:CARD=sndrpijustboomd -a 80:4::
    SQUEEZESLAVE_PARAMETER=-n plugequal
    SHAIRPORT_PARAMETER=-d sysdefault:CARD=sndrpijustboomd
    USE_USB_DAC=0
    USE_EQUALIZER=0
    SYSTEM_USER=pi
    YMPD_PARAMETER=–webport 8081

    #### SQUEEZELITE -l ####
    Output devices:
    null – Discard all samples (playback) or generate zero samples (capture)
    equal
    plugequal – Equalizer for plughw:0,0
    default:CARD=ALSA – bcm2835 ALSA, bcm2835 ALSA – Default Audio Device
    sysdefault:CARD=ALSA – bcm2835 ALSA, bcm2835 ALSA – Default Audio Device
    dmix:CARD=ALSA,DEV=0 – bcm2835 ALSA, bcm2835 ALSA – Direct sample mixing device
    dmix:CARD=ALSA,DEV=1 – bcm2835 ALSA, bcm2835 IEC958/HDMI – Direct sample mixing device
    dsnoop:CARD=ALSA,DEV=0 – bcm2835 ALSA, bcm2835 ALSA – Direct sample snooping device
    dsnoop:CARD=ALSA,DEV=1 – bcm2835 ALSA, bcm2835 IEC958/HDMI – Direct sample snooping device
    hw:CARD=ALSA,DEV=0 – bcm2835 ALSA, bcm2835 ALSA – Direct hardware device without any conversions
    hw:CARD=ALSA,DEV=1 – bcm2835 ALSA, bcm2835 IEC958/HDMI – Direct hardware device without any conversions
    plughw:CARD=ALSA,DEV=0 – bcm2835 ALSA, bcm2835 ALSA – Hardware device with all software conversions
    plughw:CARD=ALSA,DEV=1 – bcm2835 ALSA, bcm2835 IEC958/HDMI – Hardware device with all software conversions
    default:CARD=sndrpijustboomd – snd_rpi_justboom_digi, – Default Audio Device
    sysdefault:CARD=sndrpijustboomd – snd_rpi_justboom_digi, – Default Audio Device
    iec958:CARD=sndrpijustboomd,DEV=0 – snd_rpi_justboom_digi, – IEC958 (S/PDIF) Digital Audio Output
    dmix:CARD=sndrpijustboomd,DEV=0 – snd_rpi_justboom_digi, – Direct sample mixing device
    dsnoop:CARD=sndrpijustboomd,DEV=0 – snd_rpi_justboom_digi, – Direct sample snooping device
    hw:CARD=sndrpijustboomd,DEV=0 – snd_rpi_justboom_digi, – Direct hardware device without any conversions
    plughw:CARD=sndrpijustboomd,DEV=0 – snd_rpi_justboom_digi, – Hardware device with all software conversions

    #### SHAIRPORT (SYNC) VERSION ####
    3.1.1-OpenSSL-Avahi-ALSA-soxr-sysconfdir:/usr/local/etc

    #### OUTPUT SOUND DETAILS CARD 0 ####
    closed

    #### OUTPUT SOUND DETAILS CARD 1 ####
    access: MMAP_INTERLEAVED
    format: S24_LE
    subformat: STD
    channels: 2
    rate: 88200 (88200/1)
    period_size: 1764
    buffer_size: 7056

    25. August 2018 at 2:12 #37275

    Hi there.

    I contacted Definitive Sound and they suggested that I may have a bad optical input so I returned it and got a new W9 and still have the same issue where it doesn’t play 24bit/192khz. My W7’s do. Definitive Sound confirmed that they can accept 24bit/192khz through the optical input.

    Ron.

    25. August 2018 at 2:54 #37276

    I’m also having issues with playing back 24bit/96khz and 24bit/88.2khz. I can
    make it work if I transcode it. I turned off native for FLAC and turned on
    MP3. This is not ideal. Again the W7’s do this without transcoding.

    Thank you.

    27. August 2018 at 10:37 #37540

    Hi Ron,

    Have you tried the tips from the linked topic yet?

    27. August 2018 at 13:48 #37579

    linked topic? I’m not sure what you mean. I’ve exchanged the speaker for a new one. I’ve done a complete re-install of Max2play. All with the same results. The W7’s dont have this issue.

    27. August 2018 at 15:07 #37587

    How do you disable the built-in audio?

    27. August 2018 at 15:44 #37588

    I did: „deactivating the build in audio, rebooting, selecting none in the JustBoom menu, rebooting and again selecting the JB Amp HAT and reboot“

    but now the squeezelite player isn’t starting. I have the Digi Hat and not the Amp Hat.

    #### SQUEEZELITE VERSION ####
    Squeezelite Max2Play v1.0.3 based on v1.8.7-999, Copyright 2012-2015 Adrian Smith, 2015-2017 Ralph Irving.

    #### SQUEEZELITE BUILDOPTIONS ####
    Build options: LINUX ALSA EVENTFD RESAMPLE FFMPEG VISEXPORT IR GPIO DSD CONTROLSBS ALSASYNC BLUETOOTHSYNC

    #### AUDIOPLAYER CONFIG ####
    ### Configuration of Audioplayers
    SQUEEZELITE_PARAMETER=-o sysdefault:CARD=sndrpijustboomd -a 80:4:: -o hw:CARD=sndrpijustboomd -V Digital
    SQUEEZESLAVE_PARAMETER=-n plugequal
    SHAIRPORT_PARAMETER=-d sysdefault:CARD=sndrpijustboomd -t hardware -m hw:CARD=sndrpijustboomd -c Digital
    USE_USB_DAC=0
    USE_EQUALIZER=1
    SYSTEM_USER=pi
    YMPD_PARAMETER=–webport 8081

    #### SQUEEZELITE -l ####
    Output devices:
    null – Discard all samples (playback) or generate zero samples (capture)
    equal
    plugequal – Equalizer for plughw:0,0

    #### SHAIRPORT (SYNC) VERSION ####
    3.1.1-OpenSSL-Avahi-ALSA-soxr-sysconfdir:/usr/local/etc

    27. August 2018 at 15:55 #37589

    Sorry I meant the Digi, mixed up with another topic.

    Your EQ seems to be active again?

    27. August 2018 at 16:03 #37590

    I disabled it. Also, when it attempts to play I get a loud static snap and then nothing.

    #### SQUEEZELITE VERSION ####
    Squeezelite Max2Play v1.0.3 based on v1.8.7-999, Copyright 2012-2015 Adrian Smith, 2015-2017 Ralph Irving.

    #### SQUEEZELITE BUILDOPTIONS ####
    Build options: LINUX ALSA EVENTFD RESAMPLE FFMPEG VISEXPORT IR GPIO DSD CONTROLSBS ALSASYNC BLUETOOTHSYNC

    #### AUDIOPLAYER CONFIG ####
    ### Configuration of Audioplayers
    SQUEEZELITE_PARAMETER=-o sysdefault:CARD=sndrpijustboomd -a 80:4::
    SQUEEZESLAVE_PARAMETER=-n plugequal
    SHAIRPORT_PARAMETER=-d sysdefault:CARD=sndrpijustboomd
    USE_USB_DAC=0
    USE_EQUALIZER=0
    SYSTEM_USER=pi
    YMPD_PARAMETER=–webport 8081

    #### SQUEEZELITE -l ####
    Output devices:
    null – Discard all samples (playback) or generate zero samples (capture)
    equal
    plugequal – Equalizer for plughw:0,0
    default:CARD=sndrpijustboomd – snd_rpi_justboom_digi, – Default Audio Device
    sysdefault:CARD=sndrpijustboomd – snd_rpi_justboom_digi, – Default Audio Device
    iec958:CARD=sndrpijustboomd,DEV=0 – snd_rpi_justboom_digi, – IEC958 (S/PDIF) Digital Audio Output
    dmix:CARD=sndrpijustboomd,DEV=0 – snd_rpi_justboom_digi, – Direct sample mixing device
    dsnoop:CARD=sndrpijustboomd,DEV=0 – snd_rpi_justboom_digi, – Direct sample snooping device
    hw:CARD=sndrpijustboomd,DEV=0 – snd_rpi_justboom_digi, – Direct hardware device without any conversions
    plughw:CARD=sndrpijustboomd,DEV=0 – snd_rpi_justboom_digi, – Hardware device with all software conversions

    #### SHAIRPORT (SYNC) VERSION ####
    3.1.1-OpenSSL-Avahi-ALSA-soxr-sysconfdir:/usr/local/etc

    #### OUTPUT SOUND DETAILS CARD 0 ####
    access: MMAP_INTERLEAVED
    format: S24_LE
    subformat: STD
    channels: 2
    rate: 44100 (44100/1)
    period_size: 882
    buffer_size: 3528

    #### OUTPUT SOUND DETAILS CARD 1 ####

    If I transcode it to mp3 it works. Again this doesn’t happen with the w7s

    27. August 2018 at 17:10 #37592

    You could still add „hw:0 -C 5“ to the command line options to get rid of the snap.

    What have you tried from the topic thus far?

Viewing 20 posts - 1 through 20 (of 20 total)

You must be logged in to reply to this topic.

Register here