HD audio – 192kHz/24 not working on HifiBerry Digi+ Pro

Max2Play Home 2016 (en) Forums General Questions on Hardware and Max2Play Versions HD audio – 192kHz/24 not working on HifiBerry Digi+ Pro

This topic contains 16 replies, has 6 voices, and was last updated by  Heiner Moderator 1 month, 2 weeks ago.

Viewing 17 posts - 1 through 17 (of 17 total)
  • 15. April 2017 at 19:40 #28265

    Hello together,
    I have a problem with my HifiBerry Digi+ Pro.
    The audio signal is transmitted only in 44.1kHz. I can not activate the HD mode, max2play only reports that the kernel change is not possible.
    The music is in 192/24 on our NAS and both, the Chord-Dac and the Cambridge DacMagic, show a data stream with 44.1 kHz.

    Is there somewhere a detailed guidance to HD audio with max2play?

    I would be very thanful for your help,
    best regards,
    Carsten

    1. May 2017 at 14:17 #28637

    Hi Mohammed,
    I tried it, but the update breaks with the following error message:
    Kernel Change is not yet supported on Debian Jessie – we are working on this!
    Am I doing something wrong or is a solution known to the problem?
    We have now several players, very satisfied, under Max2Play run. Only this one, in the combination Pi3B with Hifiberry Digi + Pro, makes problems.

    Many thanks for your response,
    Carsten

    null

    4. May 2017 at 13:11 #28701

    Hello Whity,

    We have tested HifiBerry Digi+ Pro in our lab and it works well, but could you please check the following:

    1. You have the latest version of Max2Play, if not please download and burn new image.
    2. You do not have any plugin in the LMS that converts the audio file format.
    3. Make sure you are using the default settings in the audioplayer webpage, you can check the bitrate from the debug section in audioplayer page.

    When you are using the HDMI, the audio sample rate is limited to max 48 KHz. You can check the following website for testing:

    http://www.2l.no/hires/

    Best Regards,
    Mohammad Mbydeen

    12. May 2017 at 15:06 #28822

    Try using the Command Line Option “-u X” in the audio player advanced options. That is how I got my Hifiberry Amps to work

    31. May 2017 at 10:20 #29127

    Hi guys,

    Thanks Staudie for the tip, have you tried this yet, Carsten?

    26. July 2017 at 0:26 #30158

    Hi all,

    I hope I’m not jacking this thread but it seems to be pretty close to the issue I am having.

    I have a RPi3, HiFiBerry digi+ pro, max2play/squeezelite. The bits are sent to a Cambridge Audio 851D DAC via coax. The DAC also doubles as a simple pre-amp, which drives an Emotiva 300w/ch power amp, which drives my old school but high quality Magnat Deltas.

    Both RCA/coax and the DAC support up to 192.

    My goal with the RPi rig was to replace my laptop that I used to stream Tidal and play my ripped CDs with Media Monkey. If Windows 10 didn’t decide to do a system update/patch, the virus scanner decided it was time to check the hard drive.

    This little device plays great… I can stream tidal (I have the premium/HIFI membership), I can play my ripped CDs (from a thumb drive!!! Love it!), and even have access to Internet Radio, which I didn’t think I would ever care about (not sure yet that I do but it does open doors to new material).

    The issue I’m having is at most my DAC reports 48khz bit rate, and that’s only when I send a 24/192 or 24/96 flac into it. Anything else, Tidal and my ripped CDs are all playing at 44.1. The ripped CDs make sense… that is the resolution of the data files.

    It’s entirely possible Tidal is only presenting 44.1 data files… Though when playing Tidal through my laptop via HDMI (out) into TosLink I was running at 96k. I’m not sure how that happened either.

    But why do my “test” flacs at the higher resolutions play of 24/96 and 24/192 only play at 48k? I know the digi+ Pro has two clocks… 44.1 and 48… is it just a coincidence that those are the only two resolutions I can get?

    I’ve done the usual checks… upgraded SqueezeLite, max2play, linux kernel… which I believe were all current as this is a brand new installation.

    I’ve poked around every menu in the Squeezebox “Settings”… tried a few interesting switches, but so far nothing seems to have an impact (sorry for the vagueness… I don’t have access to the SB menus right now). Changes that had no impact got rolled back to the default setting after testing.

    I have not tried to use the TosLink… but the resolution of the optical is less than the coax.

    Since this is a headless unit, I reduced the graphics processing unit from 128M to 16M… no impact, but it was worth a try.

    As far as I can tell this little machine is barely working. CPU utilization is single digits… the 32GB SD card is 95 percent free space.

    I am steaming the music over a wireless connection; the RPi is not hard wired into the LAN. That doesn’t seem to be a factor since I seldom (not always) get a pause in the audio as the download needs to catch up.

    In general this system sounds great… I’m just not 100 percent sure I have everything 100 percent correct.

    Thanks in advance for any suggestions!
    Dave

    26. July 2017 at 13:55 #30166

    Hi Dave,

    What audio output do you have selected in Audioplayer menu?

    Also, common issues you can avoid:
    – Deactivate Bluetooth if running and built-in audio. According to HiFiBerry, it might interfere with their cards.
    – Check out our tips for sound optimization: https://www.max2play.com/en/wiki/optimizing-squeezelites-volume-control/
    – Try using LAN instead of WiFi, it sometimes decreases the sound quality: https://www.max2play.com/forums/topic/higher-bitrate-songs-freezing-lms/#post-26113

    26. July 2017 at 17:18 #30175

    What audio output do you have selected in Audioplayer menu?

    It is set to Default: (Use HDMI if plugged). My assumption, which may very well be incorrect, is that this only applies to the RPi onboard output options, hdmi vs 3mm phone jack. I also assume this should not have any impact if the digi+ is processing the output. What is the “correct” setting?

    Disabling bluetooth and Build-in audio were both tried without success. I’ll disable them again, since for all practical purposes I will probably never need either. It’s possible I tested them one at a time; perhaps the combo of them will matter.

    Your pointers to the sound optimiztion links lead me to a whole new world of info on amixer/alsamixer, etc.

    One of the gems out there is /var/lib/alsa/asound.state.

    Here’s the config for the hifiberry… does it look reasonable. To me it looks rather uninteresting, state.IQaudIODAC has 16 controls.

    state.sndrpihifiberry {
    control.1 {
    iface MIXER
    name ‘Tx Source’
    value AIF
    comment {
    access ‘read write’
    type ENUMERATED
    count 1
    item.0 ‘S/PDIF RX’
    item.1 AIF
    }
    }
    }

    I can test using a hard connection to the lan, but I’ll need to get a 40′ patch cord. Then deal with the wife.

    I guess this is how one learns…

    Thanks,

    26. July 2017 at 21:45 #30176

    Problem solved. Root cause unknown…

    For some reason I lost all audio output when all I changed (or so I thought) was disabled bluetooth and build-in audio at the same time.

    After numerous attempts to recover I ended up re-imaging max2play from scratch. Now my 192k flacs play at 192; 96 flac plays at 96; and tidal plays at 44.1. This is what I expected.

    I need to save a copy of this config before making any new changes.

    Sorry for not having a better solution than this.

    I will say it is much easier to config this the second time around than the first.

    I have fairly detailed notes, included screen captures…

    thanks,

    27. July 2017 at 6:20 #30191

    Too bad you can not define the solution exactly.
    I have plugged in my Hifiberry DAC + Pro yesterday again, but it still plays maximum 48kHz.
    The updates have not changed anything.
    Carsten

    27. July 2017 at 12:52 #30202

    Hi Titanium and Carsten,

    First of all, thanks to Titanium for the detailed follow-up. We would really appreciate your detailed notes and screenshots here. If you have problems with sharing images, here let me know and I’ll post them for you.

    @Carsten: Have you tried the aforementioned tips that I listed above?

    27. July 2017 at 16:47 #30220

    Thanks Heiner, My “notes” are in MS OneNote, but I can “print” it to just about any format including PDF/word. What format(s) would work best and where should I send it?

    Unrelated… I have had very little luck searching through these forums. In fact the only way I’ve been able to find this post is through the email chain. Is there a post somewhere in these forums that can give me pointers on how to search and locate “favorited” posts?

    Thanks,

    31. July 2017 at 12:24 #30248

    Hi Titanium,

    Just send them to [email protected] and I will make a post here to share your notes with Whity and the rest of the community.

    Regarding searching the forums, your best bet is the word search that you can find here: https://www.max2play.com/en/topics/

    It displays all results for your keywords chronologically, so if you make your search terms more specific, you will find your desired results more quickly. We do not have any favorited posts, yet. However, we do make topics sticky if they are relevant to the whole community.

    4. August 2017 at 19:33 #30442

    I think Heiner (or possibly someone on the HiFi Berry site) may have suggested that the root cause for this could be a corrupted SD card.

    That would be a good explanation since after doing a complete reload everything worked as it should.

    After the reload I’ve made it a point to create a backup image of my SD card and saved it on an external drive. If the SD card gets corrupted again (probably happens very easily if the OS is not shutdown before disconnecting power) I should be able to just reload the image from the backup.

    7. August 2017 at 11:24 #30466

    Hi Titanium,

    Indeed I could not detect anything problematic about the steps you have taken and your configuration.

    While it does not happen very often or easily, the corruption of an SD card can occur. I am happy to hear you were able to mitigate the situation. If anything comes up again, just post in this topic and I’ll be able to respond asap.

    31. August 2017 at 16:54 #31048

    Hi,
    my Hifiberry Digi+Pro (+RPi3) does not work with Max2Play.
    I am sure, I use wrong settings.
    Can anybody tell me the right settings for this combination?
    Volumio works fine.
    Many Thanks

    1. September 2017 at 16:23 #31068

    Hi jani,

    With a freshly burnt image, connect to our web interface (“max2play/” in any browser), select “HiFiBerry” in the first start screen, select “HiFiBerry Digi/Digi+” in the dropdown on the HiFiBerry menu, reboot.

Viewing 17 posts - 1 through 17 (of 17 total)

You must be logged in to reply to this topic.

Register here