themetman

Forum Replies Created

Viewing 7 posts - 1 through 7 (of 7 total)
  • Posted in:
  • 5. Juni 2020 at 8:50 #48945

    Thank you @mariom I have done a fresh install.
    Setup the HiFiBery Card with „sysdefault … hifiberrydacplusadc …“
    Upgraded to Beta-200602.
    Installed Squeezebox Server and installed the WaveInput from the SB Server Page in the Max2Play Interface
    Added the „wavin:plughw:1“ to my favourites.
    Then set it to play on my other Pi, and guess what??????

    It Worked!!!!

    So we now have a method for anyone else out there with the same problem. Bit of a saga, but got there in the end.
    Regards

    4. Juni 2020 at 10:37 #48940

    OK, @mariom, so I have Version Beta-200602 installed now, I have uninstalled the WaveImput Plugin and reinstalled it, kept the same wavin:plughw:1 in the Squeezbox Server and plughw in the AudioPlayer – Advanced Options – Soundcard, but still just white noise.
    Please do not worry about this. I have it working fine in PiCorePlayer.
    I know it would be nice to get it working for the sake of anyone else having the same problem, which is why I have been persisting with this.
    Regards

    31. Mai 2020 at 11:45 #48886

    Thank you, @mariom once again. I am running version m2p_buster_rpi-v250.img of the Max2Play OS. Is there another one I should be using?
    I do no have Bluetooth activated at all in the Settings/Reboot Section.
    I have removed the Plugin in the Squeezebox Server Interface.
    I have restarted the Squeezebox Server, and even Rebooted the device.
    I have tried at least 4 times to install the WaveInput Plugin like so:
    1. Check the WaveInput item near the bottom of the page, and click ‚Apply‘
    2. Wait until the ‚restart Now, restart later‘ Dialog box appears. and click ‚Restart Now‘
    3. wait for it to reappear

    It stubbornly refuses to install, so I installed version 104_7.6 manually from here to here /usr/share/squeezeboxserver/Plugins and restarted the Squeezebox Server and it showed up.

    I left the setting as this wavin:plughw:1 from before, and all I get is still white noise over speach or sound.

    I would like to use your Wave Input Fix on our Squeezebox Server page in the Max2Play webinterface but I cannot see it. It is not listed in the ‚Install special Plugins for Squeezebox Server‘ so I am stuck once again.

    22. Mai 2020 at 16:37 #48835

    @mariom, I have done as you say above. I do not have any other service running, not even SAMBA.
    The Squeezbox Server is running on the Raspberry Pi 4 with the DAC+ ADC on it.
    All I get is white noise with the hint of speech in the background.
    I get nothing if I change to wavin:plughw:0 in the URL of the Plugin.
    So looks like a non starter for me for some reason. Very odd.
    here is the debug Output:

    2020-05-22 15:31:48 squeezeboxserver_safe started.
    [20-05-22 15:31:52.3935] main::init (387) Starting Logitech Media Server (v7.9.2, 1578996832, Tue Jan 14 12:16:57 CET 2020) perl 5.028001 - arm-linux-gnueabihf-thread-multi-64int
    [20-05-22 15:31:52.8331] Slim::Utils::IPDetect::_init (138) Warning: Couldn't call connect() - falling back to 127.0.0.1
    [20-05-22 15:31:52.9306] Slim::Utils::SQLiteHelper::postConnect (377) Optimizing DB because of missing or empty sqlite_stat1 table
    [20-05-22 15:31:53.0040] Slim::Schema::forceCommit (2143) Warning: Trying to commit transactions before DB is initialized!
    [20-05-22 15:31:53.2417] Slim::Utils::SQLiteHelper::postConnect (377) Optimizing DB because of missing or empty sqlite_stat1 table
    [20-05-22 15:31:53.3202] Slim::Schema::forceCommit (2143) Warning: Trying to commit transactions before DB is initialized!
    [20-05-22 15:31:54.1787] Slim::Utils::SQLiteHelper::postConnect (377) Optimizing DB because of missing or empty sqlite_stat1 table
    [20-05-22 15:31:54.1975] Slim::Schema::forceCommit (2143) Warning: Trying to commit transactions before DB is initialized!
    [20-05-22 15:31:54.4827] main::checkDataSource (1107) Warning: Schema updated or no media found in the database, initiating scan.
    [20-05-22 15:31:56.6871] Slim::Utils::SQLiteHelper::postConnect (377) Optimizing DB because of missing or empty sqlite_stat1 table
    [20-05-22 15:31:56.7069] Slim::Schema::forceCommit (2143) Warning: Trying to commit transactions before DB is initialized!
    

    Not very helpful, and nothing more in the system logs when I ssh into the server.

    21. Mai 2020 at 9:40 #48830

    @mariom thank you for taking the time to test this for me. I still cannot get it to work.
    I have setup the Server in the LivingRoom and I have the Player in the Cottage.
    In the LivingRoom:
    From arecord -l

    **** List of CAPTURE Hardware Devices ****
    card 1: sndrpihifiberry [snd_rpi_hifiberry_dacplusadc], device 0: HiFiBerry ADCDAC+ Pro HiFi multicodec-0 []
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    

    In AudioPlayer – Advanced Options there ate three entries starting plughw, two refer to the bcm2835 on the Pi one as Card=ALSA,DEV=0 and the other as Card=ALSA,DEV=0 the other refers to the HiFiBerry Cars as Card=hifiberrydacplusadc,DEV=0
    I have also added this -b 176400:176400 to the Command Line Options, without this I get nothing at all.
    I have selected the last of these and in the Squeezebox Server I have tried this wavin:plughw:0 and this wavin:plughw:1 but no sound from the other device.
    Also Squeezebox will only run for a very brief few seconds and stops.
    Then I changed the AudioPlayer – Advanced Options to default – snd_rpi_hifiberry_dacplusadc and in the Squeezebod server wavin:default did not play, so tried wavin:default:0 the same, then wavin:default:1 did play but just white noise.
    I do have it working perfectly in piCorePlayer by the way which I tried when I could not get Max2Play working. I am only pursuing this in case others are in a fix.

    15. Mai 2020 at 15:05 #48795

    @mariom thanks for the quick response.
    I have selected the HiFiBerry Tab – Installed Card = DAC+ ADC and rebooted.
    Then the AudioPlayer Squeezbox Advanced Options - Soundcard = sysdefault - snd_rpi_hifiberry_dacplusadc so it should work.
    The tail end of my /boot/config.txt file is as follows

    [pi4]
    # Enable DRM VC4 V3D driver on top of the dispmanx display stack
    dtoverlay=vc4-fkms-v3d
    max_framebuffers=2
    
    [all]
    #dtoverlay=vc4-fkms-v3d
    gpu_mem=128
    dtoverlay=hifiberry-dacplusadc
    disable_overscan=1

    So the Correct card should be loaded.
    Now I open the Logitechmediaserver and select the Line In which is configured to use this
    wavin:sysdefault which matches the setting above. I have the other HiFiBerry device as the Player and still no sound.
    If I play sound from my Music server using the Logitechmediaserver on there, I can get the music synchronised out of both my Pi Devices, so they are working, but not for the Line In.
    For my setup it is essential that the Line In works.
    Any more ideas?

    15. Mai 2020 at 11:25 #48788

    Problem with Audio Out as I see it:

    HiFiBerry Tab – Installed Card = DAC+ ADC

    AudioPlayer Tab – Audio Output on Raspberry Pi = Default (use HDMI if Plugged)

    Raspberry Settings – Choose the DAC/AMP = none This cannot be correct

    So change as follows:

    Setting the DAC+ ADC is not possible in the Raspberry Settings it is missing, so if you choose the DAC+ Pro

    Raspberry Settings – Choose the DAC/AMP = DAC+ Pro

    HiFiBerry Tab – Installed Card = DAC+ Pro is chosen automatically which is not correct

    Reboot still no sound out to Cottage

    I think the problem lies in the DAC+ ADC not showing in the Raspberry Settings – Choose the DAC/AMP

    How can I make this show up?

Viewing 7 posts - 1 through 7 (of 7 total)