peterng

Forum Replies Created

Viewing 1 post (of 1 total)
  • 23. März 2017 at 7:35 #27836

    @treedweller: after the first pairing from the Max2Play web interface (device is trusted and paired), the bluetooth device should be connected and also available for further connections on your smartphone, even if the connection drops. Can you check your smartphone and initiate the connection from your smartphone (open bluetooth settings and connect to Max2Play). When using the web interface to connect, it will trust & pair ( & maybe connect) -> disconnect -> connect again. When reloading the bluetooth page with the reload button on the web interface the connection should be indicated as green.

    Hi flysurfer.

    I am having a similar issue but with a different device

    If you connected Bluetooth Speakers, make sure to set the soundcard of your audioplayers to PULSE (advanced settings Squeezelite) to get them to play with Bluetooth!
    If you connected a Smartphone to stream to Squeezebox Server, NO further setting to your soundcard is needed (do NOT set your soundcard to pulse)!
    User pi is Set
    Device 88:C6:26:55:FF:02 UE ROLL
    Device 00:1C:97:11:8D:97 clipsal0
    trust 00:1C:97:11:8D:97
    Changing 00:1C:97:11:8D:97 trust succeeded
    pair 00:1C:97:11:8D:97
    Attempting to pair with 00:1C:97:11:8D:97
    Device 00:1C:97:11:8D:97 Connected: yes
    Failed to pair: org.bluez.Error.AuthenticationFailed
    Device 00:1C:97:11:8D:97 Connected: no
    connect 00:1C:97:11:8D:97
    Attempting to connect to 00:1C:97:11:8D:97
    Device 00:1C:97:11:8D:97 Connected: yes
    Failed to connect: org.bluez.Error.Failed
    Device 00:1C:97:11:8D:97 Connected: no
    Device 00:1C:97:11:8D:97 Connected: yes
    quit
    Name: clipsal0
    Address: 00:1C:97:11:8D:97
    Icon: audio-card
    Class: 0x24c400
    Paired: 0
    Connected: 1
    
    Update Configfile - existing Entry changed

    I am able to pair with a different set of speakers but I am wondering what may be causing this particular set of speakers to not function correctly.

    EDIT: I have followed other guides and used SSH to initiate commands manually but with the same result. There is nothing that indicates I need to enter a PIN and I even tried removing the pin entirely from the device but it still will not authenticate.

    EDIT2: Would you believe that I posted that question after around 8 hours of fiddling and 15 minutes after posting I’ve managed to fix it. I had to SSH into the Pi and use bluetooth control with a -a option. This popped up the pin request prompt and I was able to enter it. Without using the -a option I don’t get a prompt at all

    so in summary the command was
    sudo bluetoothctl -a

    • This reply was modified 7 years, 4 months ago by peterng.
    • This reply was modified 7 years, 4 months ago by peterng.
Viewing 1 post (of 1 total)