mrmanuel

Forum Replies Created

Viewing 6 posts - 1 through 6 (of 6 total)
  • Posted in:
  • 4. Juni 2018 at 19:41 #36079

    Hi Heiner,

    thanks a lot. Missed this information :/ sorry for wasting your time!

    2. Juni 2018 at 11:17 #36020

    I disabled the build in audio and nothing happened. When I check the alsamixer no sound card is displayed anymore. Maybe I forgot a important detail. I have the HiFiBerry DAC+ RTC.

    In my opinion there is a bug somewhere, because the Linux OS do not recognize the sound card with the „hifiberry-dacplus“ in /boot/config.txt but with „hifiberry-dac“.

    If you want I can give you direct access to the raspberry.

    31. Mai 2018 at 14:02 #35995

    I did a fresh install to be sure that nothing else was changed. After fresh install I changed nothing except the sound card.

    30. Mai 2018 at 15:54 #35980

    Hi Heiner,

    I had setup the HiFiBerry DAC+ and below I started the „Advanced: A real multiroom audio player that integrates in a Squeezebox environment with powerful options for high-quality audio and a lot of features.“ setup, but I have still no sound and the sound card is not recognized. As written in my first post the sound card is not recognized from the system, maybe the driver is not loaded correctly?

    Very strange for me is, that it only happens to me and not other users, as I have a standard setup.

    30. Mai 2018 at 14:27 #35975

    Hi Heiner,

    thanks for your reply, but unfortunately this do not work. In the web interface -> HiFi Berry I can’t find a button/link with advanced. If I go to Audioplayer -> Squeezelite -> Edit Advanced Options I see no soundcard available. I tried the same on different Raspberry Pi 3B with different HiFiBerry DAC+ on fresh installed max2play installations.

    28. Mai 2018 at 22:49 #35939

    Hi,

    I have the exact same problem. When I select the „HiFi Berry DAC+ (PI 2/3)“ I see no soundcard in the Alsamixer. When I select the „HiFi Berry DAC (PI A/B)“ I see the soundcard in the Alsamixer and have sound.

    With the „HiFi Berry DAC+ (PI 2/3)“ selected I get following error with dmesg | grep hifiberry

    [    3.588122] snd-rpi-hifiberry-dacplus soc:sound: ASoC: CODEC DAI pcm512x-hifi not registered - will retry
    [    3.642450] pcm512x 1-004d: Failed to reset device: -121
    [    3.642930] pcm512x: probe of 1-004d failed with error -121
    [    3.749829] snd-rpi-hifiberry-dacplus soc:sound: ASoC: CODEC DAI pcm512x-hifi not registered - will retry
    [    3.757893] snd-rpi-hifiberry-dacplus soc:sound: ASoC: CODEC DAI pcm512x-hifi not registered - will retry

    I already tried this: https://www.hifiberry.com/build/documentation/configuring-linux-3-18-x/

    I have a fresh install of m2p_stretch_rpi_245.img.zip. Already tried also with a fresh install of m2p_rpi_default_244_wps_ap_expand.img.zip. I have also tried differend Rasperry Pi 3B v1.2

    What can I do?

    P.S. Sorry I’m a Linux newbee, so if some informations are missing tell me how and I will give you the informations needed 🙂

    Thanks!

    • This reply was modified 2 years, 9 months ago by  mrmanuel.
Viewing 6 posts - 1 through 6 (of 6 total)