Bruce

Forum Replies Created

Viewing 6 posts - 1 through 6 (of 6 total)
  • Posted in:
  • 28. Dezember 2018 at 19:27 #42966

    And yet another test after flashing volumio:

    [ 10.299146] snd-rpi-iqaudio-dac soc:sound: ASoC: CPU DAI (null) not registered – will retry
    [ 10.306816] snd-rpi-iqaudio-dac soc:sound: ASoC: CODEC DAI pcm512x-hifi not registered – will retry
    [ 10.523600] snd-rpi-iqaudio-dac soc:sound: ASoC: CODEC DAI pcm512x-hifi not registered – will retry
    [ 10.537586] snd-rpi-iqaudio-dac soc:sound: ASoC: CODEC DAI pcm512x-hifi not registered – will retry
    [ 10.708736] pcm512x 1-004c: Failed to reset device: -121
    [ 10.709166] pcm512x: probe of 1-004c failed with error -121

    Same error…. Ok, the basic settings are quite the same in /boot/config.txt f.i. (after configuring via Web UI)

    28. Dezember 2018 at 17:24 #42965

    The card is the following:
    https://shop.max2play.com/en/iqaudio-pi-dac-pro-new.html

    I set ‚I2S Enable I2S-MMAP (Mixerdevice for Soundcards)‘ to disabled… Same result.

    If I have some time left I will make a backup image and try if Volumio/RUne whatever will work. In principle the card should work from what I have read googling around.

    28. Dezember 2018 at 12:28 #42963

    Just reading the trouble-shooting section in
    http://www.iqaudio.com/downloads/IQaudIO.pdf

    Running dmesg has the following errors on the snd card:

    [ 3.509569] snd-rpi-iqaudio-dac soc:sound: ASoC: CODEC DAI pcm512x-hifi not registered – will retry
    [ 3.709710] snd-rpi-iqaudio-dac soc:sound: ASoC: CODEC DAI pcm512x-hifi not registered – will retry
    [ 3.730279] snd-rpi-iqaudio-dac soc:sound: ASoC: CODEC DAI pcm512x-hifi not registered – will retry
    [ 4.045982] pcm512x 1-004c: Failed to reset device: -121
    [ 4.046527] pcm512x: probe of 1-004c failed with error -121

    But googling for the errors did not give me a helping hint so far.

    28. Dezember 2018 at 11:39 #42962

    Hi Peter,
    did not help.:-/
    I think I will disassemble everything and try again from scratch or try something like Volumio.
    Thanks!
    Dirk

    27. Dezember 2018 at 11:07 #42954

    Hi Peter,
    thanks for your help. I double-checked that I have selected the soundcard in the Raspberry Settings. The settings are aligned with the IQAudiO settings automagically.
    In Audioplayer/Mediaplayer Squeezelite & Airplay…/Edit Advanced Options/ I can not select any IQAudiO soundcard, only ‚equal – equal‘ and ‚plugequal – Equalizer for plughw:0,0,

    Does this help to debug?
    Dirk

    26. Dezember 2018 at 15:46 #42949

    Ok, installed putty. Something more I can provide for debugging? The green LED on the
    PI-DAC-PRO is shining.

    When I ssh to the pi, I get the following:

    [email protected]:~ $ aplay -l
    aplay: device_list:270: no soundcards found…

    [email protected]:~ $ lsmod | grep snd
    snd_soc_pcm512x_i2c 16384 0
    snd_soc_pcm512x 32768 1 snd_soc_pcm512x_i2c
    snd_soc_iqaudio_dac 16384 0
    snd_soc_bcm2835_i2s 16384 0
    snd_soc_core 188416 3 snd_soc_pcm512x,snd_soc_iqaudio_dac,snd_soc_bcm2835_i2s
    snd_compress 20480 1 snd_soc_core
    snd_pcm_dmaengine 16384 1 snd_soc_core
    snd_pcm 98304 4 snd_soc_pcm512x,snd_pcm_dmaengine,snd_soc_bcm2835_i2s,snd_soc_core
    snd_timer 32768 1 snd_pcm
    snd 69632 4 snd_compress,snd_timer,snd_soc_core,snd_pcm

    The last uncommented lines from /boot/config.txt
    # Enable audio (loads snd_bcm2835)
    dtparam=audio=off
    gpu_mem=128
    disable_overscan=1
    dtoverlay=iqaudio-dacplus

Viewing 6 posts - 1 through 6 (of 6 total)