Aufschlagzuender

Forum Replies Created

Viewing 4 posts - 1 through 4 (of 4 total)
  • Posted in:
  • 3. Dezember 2017 at 19:51 #32762

    Jetzt funktioniert es auch unter Windows.
    Habe heute das Spotty Update auf Version 1.99.0 installiert und nun erscheint der Eintrag „Spotty Spotify für Squeezebox“ im Player Menü!

    Abspielen auf einer Squeezebox funktioniert so weit auch, allerdings verliert die Spotify App immer wieder die Verbindung zum ausgewählten Gerät. Das hat dann zur Folge das der nächste Titel den man auswählt wieder auf dem Handy wiedergegeben wird. Es sei denn man verbindet die App vorher erneut mit der Squeezebox.

    Bin mal gespannt ob der Fehler mit den nächsten Updates verschwindet.

    Auf jeden Fall schon mal ein großes Danke an die Entwickler. Die Funktion wertet die Squeezeboxen erheblich auf!

    Gruß
    Aufschlagzuender

    20. November 2017 at 3:37 #32544

    @heiner Noch mal zu Spotify Connect über das Spotty Plugin.

    Mein Squeezebox Server läuft unter Windows. Kann es damit zusammenhängen das ich im Player Menü keinen Eintrag finde um Spotify Connect für den jeweiligen Player zu aktivieren?

    Ich habe noch einen Squeezebox Server zu Testzwecken auf einem weiteren Windows Rechner installiert und auch da ist der Eintrag nicht zu sehen.
    Daraufhin habe ich dann noch einen Server auf einem Raspberry (Max2Play) installiert. Und siehe da, dort ist der Eintrag zu sehen.

    Funktioniert Spotify Connect also nicht wenn der Server unter Windows läuft?

    Gruß
    Aufschlagzuender

    15. Oktober 2017 at 3:04 #31899

    Hallo,
    erst Mal vielen Dank für die Antwort. Leider habe ich wenig Zeit und konnte erst jetzt wieder weiter probieren.

    Ich bin nun noch mal komplett von vorne angefangen und wie folgt vorgegangen.

    -Max2Play Image neu runtergeladen (Version 2.44) und auf SD-Karte kopiert
    -Mail Adresse zum aktivieren eingetragen
    -Sprache auf Deutsch/Deutschland geändert
    -Spotify Connect Plugin heruntergeladen und installiert
    -Haken bei Autostart gesetzt
    – Zugangsdaten für Spotify eingetragen
    -Im Menü Audioplayer die Autostart Haken bei Squeezelite und Shairport entfernt
    -Im Menü WLAN & LAN den Haken bei Aktiviere WPS beim Booten entfernt
    -Spotify Plugin gestartet (läuft)
    -Auf die USB- Soundkarte habe ich erst mal verzichtet um diese als Fehlerquelle aus zu schließen.

    -Neustart über Menü Einstellungen/Reboot
    -Spotify Connect Service läuft
    -Neustart über Menü Einstellungen/Reboot
    -Spotify Connect Service läuft
    -Neustart über Menü Einstellungen/Reboot
    -Spotify Connect Service läuft
    -Neustart über Menü Einstellungen/Reboot
    -Spotify Connect Service läuft
    -Neustart über Menü Einstellungen/Reboot
    -Spotify Connect Service läuft NICHT!!!
    -Neustart über Menü Einstellungen/Reboot
    -Spotify Connect Service läuft
    -Neustart über Menü Einstellungen/Reboot
    -Spotify Connect Service läuft
    -Neustart über Menü Einstellungen/Reboot
    -Spotify Connect Service läuft
    -Neustart über Menü Einstellungen/Reboot
    -Spotify Connect Service läuft
    -Neustart über Menü Einstellungen/Reboot
    -Spotify Connect Service läuft
    -Neustart durch Trennung der Stromversorgung
    -Spotify Connect Service läuft NICHT!!!
    -Neustart durch Trennung der Stromversorgung
    -Spotify Connect Service läuft NICHT!!!
    -Neustart durch Trennung der Stromversorgung
    -Spotify Connect Service läuft NICHT!!!
    -Neustart durch Trennung der Stromversorgung
    -Spotify Connect Service läuft NICHT!!!
    -Neustart durch Trennung der Stromversorgung
    -Spotify Connect Service läuft NICHT!!!
    -Neustart durch Trennung der Stromversorgung
    -Spotify Connect Service läuft NICHT!!!
    -Neustart über Menü Einstellungen/Reboot
    -Spotify Connect Service läuft
    -Neustart über Menü Einstellungen/Reboot
    -Spotify Connect Service läuft
    -Neustart durch Trennung der Stromversorgung
    -Spotify Connect Service läuft NICHT!!!

    Sieht also so aus als würde das Problem hauptsächlich auftreten, wenn man die Stromversorgung trennt. Allerdings meine ich das, bevor ich das Image neu aufgespielt habe, der Service hin und wieder auch gestartet ist obwohl der Raspberry vorher stromlos war.

    Hier noch mal die DEBUG Info:

    #### Librespot Output ####
    INFO:librespot: librespot cc9dba8 (2017-03-26). Built on 2017-07-17. Build ID: 8zQE3Bpb
    WARN:librespot::apresolve: Failed to resolve Access Point: HTTP error
    WARN:librespot::apresolve: Using fallback „ap.spotify.com:80“
    INFO:librespot::session: Connecting to AP „ap.spotify.com:80“
    thread ‚main‘ panicked at ‚called Result::unwrap() on an Err value: Error { repr: Custom(Custom { kind: Other, error: StringError(„failed to lookup address information: Name or service not known“) }) }‘, /checkout/src/libcore/result.rs:859
    note: Run with RUST_BACKTRACE=1 for a backtrace.

    #### Librespot Command Line Options ####
    error: Required option ’name‘ missing.
    Usage: /opt/spotifyconnect/librespot [options]

    Options:
    -c, –cache CACHE Path to a directory where files will be cached.
    –disable-audio-cache
    Disable caching of the audio data.
    -n, –name NAME Device name
    -b, –bitrate BITRATE
    Bitrate (96, 160 or 320). Defaults to 160
    –onstart PROGRAM
    Run PROGRAM when playback is about to begin.
    –onstop PROGRAM
    Run PROGRAM when playback has ended.
    -v, –verbose Enable verbose output
    -u, –username USERNAME
    Username to sign in with
    -p, –password PASSWORD
    Password
    –disable-discovery
    Disable discovery mode
    –backend BACKEND
    Audio backend to use. Use ‚?‘ to list options
    –device DEVICE Audio device to use. Use ‚?‘ to list options
    –mixer MIXER Mixer to use

    Das Spotty Plugin habe ich schon auf meinem Squeezebox Server laufen.
    Ich bekomme es allerdings nicht hin das dieses Plugin in der Spotify App als „verfügbares Gerät“ angezeigt wird.
    In dem link von dir steht ja:

    „you can set the checkmark for Spotify Connect in the Squeezebox Server settings under “Spotty Spotify for Squeezebox” in the “player” tab“

    Mit „Player Tab“ ist wohl eher „Plugin Tab“ gemeint, oder nicht?
    Dort kann ich aber nirgends einen Haken für Spotify Connect setzen. Ich habe Version 1.9.4 installiert. Ist das noch die aktuelle Version?

    Mein Ziel ist es in meiner Gartenhütte einen Raspberry zu installieren mit dem ich sowohl auf den Squeezebox Server als auch auf Spotify zugreifen kann. Spotify würde ich gerne via Spotify Connect über die original App bedienen.

    Gruß
    Aufschlagzuender

    3. Oktober 2017 at 21:11 #31668

    Hallo,
    erst mal sorry das ich auf Deutsch schreibe, mein englisch ist nicht so gut, ich hoffe das ist ok.

    Ich habe im Grunde dasselbe Problem wie „theonlyfoz“.

    Mal startet Spotify Connect automatisch, mal nicht. Dies scheint völlig willkürlich zu passieren.
    Alle anderen Player (Shairport, Squeezelite) habe ich inzwischen zu Testzwecken aus dem Autostart herausgenommen. Den Spotify Connect Service habe ich re-installiert, sollte also auf dem neuesten Stand sein.
    Von Hand kann ich Spotify immer problemlos starten.

    Max2Play 2.44
    Raspberry Pi B
    USB Soundkarte (Creative Sound Blaster Play)
    Angeschlossen via LAN Kabel
    Sprache/Zeitzone: Deutsch/Deutschland – Europe/Berlin

    Hier mal die DEBUG Infos von Spotify wenn der Autostart geklappt hat und wenn nicht. Vielleicht könnt ihr ja mehr damit anfangen als ich.

    —–AUTOSTART OK—–

    #### Librespot Output ####
    INFO:librespot: librespot cc9dba8 (2017-03-26). Built on 2017-07-17. Build ID: 8zQE3Bpb
    INFO:librespot::session: Connecting to AP „lon3-accesspoint-a65.ap.spotify.com:4070“
    INFO:librespot::session: Authenticated as „XXXXXXXXXXXXXX“ !
    INFO:librespot::session: Country: „DE“
    INFO:librespot::audio_backend::alsa: Using alsa sink

    #### Librespot Command Line Options ####
    error: Required option ’name‘ missing.
    Usage: /opt/spotifyconnect/librespot [options]

    Options:
    -c, –cache CACHE Path to a directory where files will be cached.
    –disable-audio-cache
    Disable caching of the audio data.
    -n, –name NAME Device name
    -b, –bitrate BITRATE
    Bitrate (96, 160 or 320). Defaults to 160
    –onstart PROGRAM
    Run PROGRAM when playback is about to begin.
    –onstop PROGRAM
    Run PROGRAM when playback has ended.
    -v, –verbose Enable verbose output
    -u, –username USERNAME
    Username to sign in with
    -p, –password PASSWORD
    Password
    –disable-discovery
    Disable discovery mode
    –backend BACKEND
    Audio backend to use. Use ‚?‘ to list options
    –device DEVICE Audio device to use. Use ‚?‘ to list options
    –mixer MIXER Mixer to use

    —-AUTOSTART NICHT OK—-

    #### Librespot Output ####
    INFO:librespot: librespot cc9dba8 (2017-03-26). Built on 2017-07-17. Build ID: 8zQE3Bpb
    WARN:librespot::apresolve: Failed to resolve Access Point: HTTP error
    WARN:librespot::apresolve: Using fallback „ap.spotify.com:80“
    INFO:librespot::session: Connecting to AP „ap.spotify.com:80“
    thread ‚main‘ panicked at ‚called Result::unwrap() on an Err value: Error { repr: Custom(Custom { kind: Other, error: StringError(„failed to lookup address information: Name or service not known“) }) }‘, /checkout/src/libcore/result.rs:859
    note: Run with RUST_BACKTRACE=1 for a backtrace.

    #### Librespot Command Line Options ####
    error: Required option ’name‘ missing.
    Usage: /opt/spotifyconnect/librespot [options]

    Options:
    -c, –cache CACHE Path to a directory where files will be cached.
    –disable-audio-cache
    Disable caching of the audio data.
    -n, –name NAME Device name
    -b, –bitrate BITRATE
    Bitrate (96, 160 or 320). Defaults to 160
    –onstart PROGRAM
    Run PROGRAM when playback is about to begin.
    –onstop PROGRAM
    Run PROGRAM when playback has ended.
    -v, –verbose Enable verbose output
    -u, –username USERNAME
    Username to sign in with
    -p, –password PASSWORD
    Password
    –disable-discovery
    Disable discovery mode
    –backend BACKEND
    Audio backend to use. Use ‚?‘ to list options
    –device DEVICE Audio device to use. Use ‚?‘ to list options
    –mixer MIXER Mixer to use

Viewing 4 posts - 1 through 4 (of 4 total)