[SOLVED] Y-248 DAC streaming issues

This topic contains 0 replies, has 1 voice, and was last updated by  DeusUrb 1 year, 2 months ago.

Viewing 1 post (of 1 total)
  • 19. August 2019 at 15:30 #46798

    Good Day

    This is a solution to a long standing problem I’ve had. Just felt like I’d post it here for anyone encountering the same issue.
    So in quick summary the Unitek USB Type-C to Stereo Audio Converter Y-248 is by far the best DAC I’ve owned and for cheap(I’ve tested around 8 cheapo usb DACS).
    Just some rewiring from the usb type C to standard USB (there are 5 wires (2 ground)), so there’s no issue there.
    There is however an issue that I’ve had for a good amount of time, whilst using it with raspberry pi (3B, 3B+ and zero W) when selecting a new song to play, about roughly the 5th selection (device dependent, zero W is around 2-3), the audio would either become crackly and very distorted, and not play at all. Only solution at the time was to reboot the device (restarting any service will not work). Note if you had a playlist, then all the songs would play normally, it only happens on the selection step.
    Solution:
    I was too lazy to figure out the exact size capacitor needed, but soldering a capacitor of 2200uf (100-330uf won’t work) across the positive and negative of the DAC provided the solution(perfect because you had to do re-wiring anyways), sorry I don’t know how to solder the capacitor in without getting rid of the casing.
    Also you need to ensure that the DAC has a power supply that is not fed through the Pi itself (it can still be fed through the pi, jsut needs that backup).
    I believe it has something to do with the crossfade, but disabling it didn’t seem to provide the solution. Also to my knowledge there were no errors in the logs.

    • This topic was modified 1 year, 2 months ago by  DeusUrb.
    • This topic was modified 1 year, 1 month ago by  Heiner.
Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.

Register here