xmc/kodi not starting after update to isengard

Max2Play Home 2016 (en) Forums Max2Play on ODROID U3/C1 xmc/kodi not starting after update to isengard

This topic contains 6 replies, has 2 voices, and was last updated by  Heiner premium 1 year, 3 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • 27. August 2015 at 12:18 #15460

    I can’t start kodi from the webinterface anymore after updating to Isengard with the link provided at this website: https://www.max2play.com/download/15362/

    Here is the detailed info:

    Trying to launch … NOT successful Click here to show detailed information
    sudo: unable to resolve host MAXSQUEZZZ
    Use Interface eth0 with -m e2:d9:03:fb:56:f7
    Stopping Squeezelite
    Stopping Shairport
    /sbin/start-stop-daemon: warning: failed to kill 2797: No such process
    /usr/local/lib/kodi/kodi.bin: error while loading shared libraries: libGLESv2.so: cannot open shared object file: No such file or directory

    Here is what happened: I tried to update M2P through the webinterface, but that sort of hung and I could not access the webinterface anymore.
    Because I am running Vnc server also and that still worked I used that and the software updater on Lubuntu to update everything.
    After that everything worked: LMS VNC except XBMC which was back to version 12 (I had 13, from this website). So through the webinterface I installed Isengard and I got the errormessage described as above.
    If I try to start Kodi through VNC it also does not work.

    I guess it has to do with this shared libraries.
    Any ideas on how to fix this?
    I don’t mind using terminal through VNC if I am provided with the right commands.

    Thanks

    27. August 2015 at 17:23 #15461

    Hi janssen,
    Since you try to upgrade to Isengard, I suppose you have a U3 as your Max2Play device since that is they only device currently supporting the update. What you can try to fix it is upgrade to the current beta and then click the normal update to return to the current version. If that does not help, please burn the image anew.

    27. August 2015 at 18:50 #15463

    Hi Heiner,

    Thanks for the reply. I tried it, but it did not work.
    So I installed version 13.2 Xbmc through the webinterface.
    I could start and stop XBMC through the webinterface, but the screen goes completely black.
    Is there maybe a fix for that, other than burning a new image, which is about the last thing I wonna do, because I have to reinstall all the xbmc plugins, which will be quite a hassle.
    The reason I choose for Odroid and Max2Play was the no hassle (no terminal) filosophy.
    Hope somebody can provide a tip.

    Danny

    29. August 2015 at 12:23 #15482

    Update:

    After installing VLC through VNC and rebooting a couple of times, Xbmc is working again!!
    I have no idea if VLC had any impact on XBMC working again, maybe some video lib?
    By the way, VLC is not showing any movie.

    Anyway, back to normal again.
    Just one more question: so it seems not a good idea to update the Lubuntu system through the software updater? That sort of screws up the M2P image?

    1. September 2015 at 15:35 #15539

    Yes, the Lubuntu system should not be updated manually by the user since there can be kernel updates or other changes that might influence the system. We will try to bring out Max2Play updates to accommodate the Lubuntu changes.

    1. September 2015 at 20:26 #15566

    Thnx, nice to know: that is why I screwed up XBMC in the first place I think.
    I will never do it again.

    7. September 2015 at 14:01 #15635

    No problem, after all you can always burn the image anew in just a few minutes. If you encounter any other problems, feel free to post in the forums again.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.

Register here