WLan disconnect/reconnect

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI WLan disconnect/reconnect

This topic contains 6 replies, has 4 voices, and was last updated by  luke premium 4 months, 3 weeks ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • 28. May 2016 at 11:54 #20392

    Hi, ich habe das Problem das meine 4 Raspberry 3 nach 1 Tag sich aus dem WLan abmelden (manchmal auch eher) und auch kein reconnect stattfindet! Verstärkt seit dem Update auf 2.31. Vorher hat es länger gehalten…kam aber auch vor.
    Ich vergebe meine IP’s dynamisch über DHCP Fritzbox. Alle Geräte, die ich sonst noch so habe (Tablet, Handy etc.), zeigen dieses Verhalten im WLan nicht.
    Ich nutze das Raspberry PI Image für Version 2-3 wobei ich nur den Audioplayer Squeezeplug nutze.

    Folgende Einstellungen sind gepflegt:
    WLan/Lan: WLan Interface laden -> Ja
    Netzwerkname/Netzwerkschlüssel korrekt eingetragen (Funktioniert ja auch)
    Lan Konfiguration MAC Adresse nichts eingetragen
    Setze feste WLan-IP -> deaktiviert.
    Activate WPS on Boot -> deaktiviert.

    In den Einstellungen für Raspberry PI habe ich IPv6 deaktiviert.

    In meiner Fritzbox Übersicht kann ich sehen das alle 4 Geräte eine unterschiedliche MAC-Adresse haben wenn sie denn eingeloggt sind.
    Hier mal ein Debug-Info von einem der Geräte:

    eth0 Link encap:Ethernet HWaddr b8:27:eb:14:5a:f3
    UP BROADCAST MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    UP LOOPBACK RUNNING MTU:65536 Metric:1
    RX packets:4 errors:0 dropped:0 overruns:0 frame:0
    TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:200 (200.0 B) TX bytes:200 (200.0 B)

    wlan0 Link encap:Ethernet HWaddr b8:27:eb:41:0f:a6
    inet addr:192.168.123.34 Bcast:192.168.123.255 Mask:255.255.255.0
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:3581 errors:0 dropped:12 overruns:0 frame:0
    TX packets:806 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:559554 (546.4 KiB) TX bytes:149221 (145.7 KiB)

    Alle Raspis sind sowohl vom Image als auch vom Max2Play auf dem neusten Stand gebracht worden.
    Ich weiss nicht mehr wo ich da noch nach Problemen schauen soll.
    Weiss von euch jemand Rat ?

    [EDIT] Jetzt wirds ganz verrückt! Ich dachte ich vergebe jetzt mal feste IP-Adressen. Also haken rein bei setze feste WLan-IP und eine freie Adresse ausgesucht…gespeichert….ok. In der Fritzbox kann ich sehen das besagter Raspberry alle Minute eine neue IP Adresse bekommt! Immer im wechsel zwischen fester und automatisch vergebener IP-Adresse. Was geht da vor ???

    • This topic was modified 6 months, 1 week ago by  Joker971.
    28. May 2016 at 19:19 #20395

    I have issue with wifi connection. I’m trying to set wlan, sometime IP appears, but after rebooting trying to have wifi connection the same problem. Have to plug LAN again..

    Tab:
    WiFi & Network configuration
    No networks found
    Status: WiFi USB adapter status is active. WiFi connection status is active (IP: NO IP! No connection!)
    (Only WPA/WPA2-Encryption possible)

    Do you have idea how stabilise RPI3?

    30. May 2016 at 15:23 #20410

    Hi guys,
    Firstly, the option “set static IP address” does not give you the possibility to set an IP address of your choice but just to continously set the assigned IP that is already displayed. Please do not change this IP manually. Secondly, the LAN connection can impede on the WiFi connection. Please make sure disconnect the LAN cable once the WiFi connection is set up and you click “reboot”.

    30. May 2016 at 17:22 #20412

    Meine Rasberrys sind alle nur über WLan verbunden! Ich hatte da nie Lan-Kabel drann.
    Ich habe sie jetzt wieder so eingestellt das sie die IP-Adressen dynamisch über DHCP beziehen.
    Ich frage mich nur warum sie trotz eines guten WLan Netzes sich nicht von selbst verbinden ? Laut Changelog müsste das doch schon implementiert sein ? Heute wieder…ich komme nach hause und alle Raspi’s sind offline. Warum kein reconnect ?

    • This reply was modified 6 months, 1 week ago by  Joker971.
    14. July 2016 at 9:36 #21528

    Is there any fix yet? Same issue here. But it’s not working anymore since I installed squeezebox-server.
    From the beginning. This raspi has a pitft and was just a player. Now I am using it as a Logitech Media Server. If I get up in the morning or are gone for a while, it’s up and running but no wifi connection. I do a restart, everything works fine. This was no issue before. I have checked, power-management is off. I used DHCP and now fixed IP. No difference.

    14. July 2016 at 14:08 #21532

    Hi luke,
    Have you updated to the newest version 2.33, yet?

    14. July 2016 at 19:54 #21542

    Yes, I have.
    So I actually found a fix. I didn’t use your wpa_supplicant.conf but edited /etc/network/interfaces to:

    allow-hotplug wlan0
    auto wlan0
    iface wlan0 inet dhcp
    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
    iface default inet dhcp

    then I edited the wpa_supplicant.conf with all of my network data like it’s mentioned here

    The issue before was that if I unplug my router and plug it back in, the raspi would not reconnect to the wifi by itself. Now it works flawlessly.

    • This reply was modified 4 months, 3 weeks ago by  luke.
Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.

Register here