WiFi adapter active, connection active, (IP:No IP!, No connection!) on 2.35

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI WiFi adapter active, connection active, (IP:No IP!, No connection!) on 2.35

This topic contains 11 replies, has 3 voices, and was last updated by  gapmedia premium 2 months, 2 weeks ago.

Viewing 12 posts - 1 through 12 (of 12 total)
  • 13. September 2016 at 16:19 #22997

    I purchased a bundle with RPi3 and iQ card. I am using an Apple Airport Express router which supports both WPA and WPA2.

    I started by following the “Getting Started” steps exactly but could not establish a wifi IP address/connection. Reading this forum for others with similar problems, I found the suggestion to unplug ethernet during reboot after manually setting the wifi connection. My steps and results are listed below.

    I started again with a fresh download image. Activated account, expanded file system, reboot, updated to 2.35, reboot, all successful.

    From wifi page—– scanned wifi networks, selected my local network, typed in password, ticked “Load wifi interface”, Saved settings.

    Reboot and unplug ethernet during reboot. After some time to allow complete reboot, typed device name into browser, “no server found”. I went to my computer to see wifi connections. Found my router and my phone, both WPA2 connections, but no Pi wifi.

    Reconnected by ethernet and have this wifi page shows the same error, “adapter active, connection active, (IP:No IP!, No connection!)

    I have confirmed that I am using the correct network password.

    Help please. The Pi bundle is useless without wifi.

    Jac

    15. September 2016 at 15:16 #23042

    A Little More Information

    Just for clarity. I have tried all of the suggestions in the FAQ and on the Forum relating to this problem. That includes using the reboot command and disconnecting the LAN cable during reboot. Also, using the shutdown command, disconnecting the LAN cable when powered down, then booting up. Each time, I use my computer to scan for the Pi wifi signal and no signal is available. Each time, I try to connect in the browser to the Pi computer name.

    This appears to be a long time problem and a problem over a large range of M2P releases. Is there a solution or a solution coming soon? I am anxious to make this work.

    Jac

    15. September 2016 at 15:44 #23045

    I am having a very similar problem.

    All has been working very well with Max2Play, Wolfson/Cirrus, and Rpi 2 and RPi 3.

    After I upgraded my router from a NETGEAR WNR2000 to Linksys EA6300 AC1200, due to Airplay streaming problems, I now cannot get an IP address for the RPi 3 setup, the RPi2 setup still work okay! Even an RPi3 that was already setup and working okay with the Netgear router will not work when tried with the Linksys.

    Setup goes okay with with all steps and reboots up until after the Wolfson/Cirrus card is installed. After rebooting at this stage neither LAN nor Wireless works again until a full reinstall. I noticed that the router is assigning the RPi3 a IPv6 address, but not an IP address. I switched off IPv6 in Max2Play, but the router still assigns the RPi3 a IPv6 but no IP. I also switched off IPv6 in the router setup, but an IP address is still not assigned after the Wolfson/Cirrus card is installed. Have tried setup 5 times now on RPi3 with same result each time straight after the Wolfson card is installed.

    I am installing 2.34, then upgrading to 2.35 in setup. The already setup RPi 3 that would not work with the Linksys was at 2.35 already.

    Simon

    • This reply was modified 2 months, 2 weeks ago by  gapmedia.
    15. September 2016 at 16:30 #23048

    Simon,

    Thanks for the reply. I am sure that both of your routers supported both WPA and WPA2 so the problem is deeper than that. The IPv6 issue seems to be on the M2P side. The download image is still 2.34. I will try a fresh load of 2.34 and not upgrade to 2.35. It will be interesting to see if I can get an IP address.

    Jac

    15. September 2016 at 17:34 #23053

    Another failed experiment. I loaded a fresh image of 2.34 and did not update to 2.35. Same result, no IP address.

    One interesting thing I hadn’t noticed before. I am using Mac as a computer. In my Finder window, the previous and current names for the RPi3 are listed under shared devices, but I can’t connect to them. On the Airport Express router, it reports connections to all wifi devices in the house, but no RPi3. It seems that the error message is correct. The wifi adapter and connection are active, but there is no connection because there is no IP.

    Jac

    16. September 2016 at 2:39 #23062

    Hello Jac,

    Am I correct in reading that you are never able to get an IP address for your RPi3?

    If so, your problem is a little different to mine. I can setup my RPi3 wirelessly using WPS from the start up until the stage when I ‘install’ my audio card (Wolfson/Cirrus card). It doesn’t matter what order I attempt to setup Max2Play as all goes well until I ‘install’ the audio card. The next time I reboot the RPi3 no IP address is assigned to it, and it no longer joins the network. I cannot even reconnect using LAN. It appears that all wireless and LAN devices on the RPi3 have been disabled.

    Simon

    16. September 2016 at 14:48 #23068

    Hello Simon,

    That is correct. I have never been able to get an IP address for the RPi3. I agree that your issue is a little different.

    I am interested to hear that you can establish an IP using WPS. I have been manually setting up the wifi connection because the Apple router makes WPS difficult to impossible. Given that you have had success with WPS, I will dig in deeper and see if I can get the router to cooperate. Thank you for your help.

    Jac

    16. September 2016 at 17:23 #23069

    A Big thank you to Simon. For others having this issue with RPi3, it looks like making a connection with WPS is the answer. Apparently, something is missing with the manual setup, at least for certain routers.

    For those of you with Apple Air Play routers (and who are at a low knowledge level like me), it is possible to set up a WPS connection by adding it as a WPS Printer. Note that Apple likes to hide things and you will need to look at Air Play help or Apple support in order to get to that option. It is normally not available.

    Simon,

    IF you haven’t already, I suggest that you open a new topic on your sound card/connection issue. I tried working within an existing thread, but had more success with a new topic.

    Jac

    16. September 2016 at 20:53 #23072

    Hi,

    @gapmedia: once you change the Kernel on the Max2Play Image to support the Wolfson/Cirrus card, it won’t run anymore because the Kernelchange was only working with the older “debian wheezy” based Max2Play version (you may still download this version on our page). I also removed this option in the newest version from the Raspberry Pi Settings Addon.

    @Jac: The WPS connection is just a way to do it more simple on startup for people who do not want to connect a LAN cable and have a router with WPS. In your first screen, do you find your wifi network in the list after you click “start scan”? If yes, after selecting your network and adding your password, does it show that you are connected or does it show any errors?

    Regarding IPv6: you may disable this in the Raspberry Pi Settings Addon. If your Router supports IPv6 your Raspberry will also get an IPv6 address besides IPv4 and the URL in your Browser may change on a reboot of Max2Play… If you have problems, either disable IPv6 or enter the IPv4 Address instead of the name (e.g. “http://max2play”) in your browser. As IPv6 gets more popular I will try to get everything working with IPv6.

    Stefan

    16. September 2016 at 21:22 #23073

    Hello Stefan,

    Thank you for your reply.

    I did the complete manual setup. Scan for network, select network, add password, tick load interface, save settings, shut down, disconnect ethernet cable, reboot. Using the manual setup, I always get the error as listed in the topic title above. That is, no IP, on connection.

    I was only able to make a connection by using the WPS approach.

    I also have confirmed the password with another device.

    Jac

    17. September 2016 at 5:03 #23074

    Hello Stefan,

    Thanks for your reply.

    If I understand correctly, you are saying that the Wolfson/Cirrus card no longer works on RPi3 and M2P? I can still see the Wolfson/Cirrus option under Raspberry Settings on 2.36.

    I have had 2x RPi3’s with M2P 2.34/2.35 and the Wolfson/Cirrus card running successfully for months.

    My issue started when I replaced my older NETGEAR N300 WNR2000 wireless router with a Linksys EA6300 AC1200 wireless router, due to Airplay stuttering streaming problems. My Rpi2 setup continues to work, and now streams perfectly from an IOS device using Airplayer, but I can no longer get my RPi3 setup to connect to the network. I thought something may have corrupted on my RPi3 setup, so I reinstalled trying 2.34, 2.35 and even 2.36 yesterday, but everytime I select the Wolfson/cirrus card, save the setting and reboot the networking functions of the RPi3 appear to be switched off. From then on I cannot connect to the RPi3 wirelessly or using LAN. Everything works perfectly wireless and LAN wise during installation until the Wolfson/Cirrus card is selected.

    I will try replacing my new router with the old one to see if the issue goes away.

    Stefan, I am not pointing my finger at M2P as the RPi3 worked beautifully up until I replaced my router. It seems to be an incompatibility issue that occurs between router and RPi3 after the Wolfson/Cirrus card’s software is introduced. I am not having this issue with any other device in my network and my new router though.

    Simon

    • This reply was modified 2 months, 2 weeks ago by  gapmedia.
    • This reply was modified 2 months, 2 weeks ago by  gapmedia.
    18. September 2016 at 13:29 #23086

    UPDATE.

    Stefan,

    If I install from M2P 2.31 I am able to get the RPi3 and Wolfson/Cirrus card working and updated to 2.36. Is this because I do not change the Kernel installing this way?

    Maybe this was the way I originally setup my RPi3 systems, M2P 2.31, and why were working on 2.35. I certainly cannot setup the RPi3 and Wolfson/Cirrus card using M2P 2.34.

    I have noticed that the RED light on the Wolfson/Cirrus card no longer remains on permanently, which I think it used to. I believe the RED light has something to do with indicating whether the WM8804 digital interface chip is working in software or hardware mode? Not sure what it means under M2P.

    Simon

    • This reply was modified 2 months, 2 weeks ago by  gapmedia.
    • This reply was modified 2 months, 2 weeks ago by  gapmedia.
    • This reply was modified 2 months, 2 weeks ago by  gapmedia.
Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.

Register here