Which download file for RPi 3 + HiFiBerry DAC+ Standard

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Which download file for RPi 3 + HiFiBerry DAC+ Standard

This topic contains 8 replies, has 3 voices, and was last updated by  Heiner Moderator 9 months, 2 weeks ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • 24. December 2016 at 20:18 #25218

    I am about to upgrade my RPi 2B + Behringer UCA222 to an RPi 3 + HiFiBerry DAC+ Standard.

    This is used solely as a platform to run Squeezeplug Logitech Media Server (LMS) which feds my whole house sound system. The main reason for the change is that I want to be able to stream music from my Windows 10 PC or my Samsung Galaxy phone to LMS. I do not need to have LMS send to bluetooth speakers because I do not have any.

    Can somebody please tell me which image I should download. I know I need and image with Jessie so than bluetooth to LMS will work.

    There seem to be multiple images and I wish to make sure I get the right one installed.

    The new hardware is still out in the postal cloud somewhere so this is just preparation.

    Thanks for your help.

    24. December 2016 at 21:56 #25220

    Hi

    The image for HifiBerry is this one:

    https://www.max2play.com/download/15184/

    To listen to music from the Android and PC you can activate in Max2Play under “Audioplayer” the “gmediarenderer”
    On the galaxy you install “BubbleUPNP”, which shows you then all SqueezePlayers and DLNA-Players (for example AV-Receiver etc) existing in the network. For playing music from the PC you can mount your music folder on the PC in the SqueezeboxServer

    Edit: Audio playback of video streams with bluetooth (Youtube etc) does not work good because of delays

    • This reply was modified 9 months, 3 weeks ago by  std.
    • This reply was modified 9 months, 3 weeks ago by  std.
    • This reply was modified 9 months, 3 weeks ago by  std.
    25. December 2016 at 3:37 #25224

    Thank you. When my new hardware arrives I shall install that image.

    Edit: Thanks, I shall only be using this for music streaming.

    Edit2: Is this release Jessie for the Raspberry Pi? Apparently this is needed to stream bluetooth to (not from) the Squeezebox Server. This why I am doing all this. I tried to install this on Wheezy and it told me I needed Jessie to support it.

    • This reply was modified 9 months, 3 weeks ago by  rederikus.
    25. December 2016 at 10:35 #25226

    I do’t know which download version that is. But at leat after an upate it would be Jessie
    I´d installed this Image.

    #### LINUX-VERSION ####
    Distributor ID:	Raspbian
    Description:	Raspbian GNU/Linux 8.0 (jessie)
    Release:	8.0
    Codename:	jessie

    Why do you absolutely insist on using bluetooth? I think bluetooth is always beta. My Galaxy S5, and also my iPhone5, cant find the RasPi. So its not possible to use the Pi as audio device for the phone
    DLNA works absolutely reliably

    BTW: the RasPi find all my BT-Devices.BT-Headset, Phones

    25. December 2016 at 19:00 #25234

    Bluetooth gives horrible audio quality and I really only think it suitable for hands free phone calls in my car.

    However it is very simple for anybody to use.

    I have several sound systems here. I have a very nice one in my home studio that I use as a reference. I the lounge I have a 1959 Rogers HG88 MkIII valve (tube) amplifier that I rebuilt to new standard a few years back. I use this for playing my ancient vinyl collection.

    Then I have the whole house system which is single zone and powered by a QSC 300 Watt (RMS into 8 Ohms) rack mount amp. This is connected to a Raspberry Pi That will be the HiFiBerry DAC device. The Logitech Media Server (squeezeplug) is currently a Pi 2B moving to a Pi 3. Mainly this is used for playing Pandora station.

    Occasionally and, this is where the bluetooth comes in, I would like to stream music from my phone. My grandchildren also would just love to use there phones to blast us with whatever they currently fancy.

    There you go. That’s why bluetooth. Sorry it took a while but, you did ask :).

    Merry Christmas and thanks for your help. I have no doubt I shall be back…

    27. December 2016 at 19:47 #25264

    I got my RPi3 and I installed the image. OMG: It always boots to x-Windows. I cannot stop it. I went through raspi-config, changed the root passwd. Whenever I stop typing for a while it flops back to this horrible grey screen windows. I absolutely do not want this.

    What I need is a command line prompt at every boot and to run only squeezeplug. If it is going to do this I will just stick with my old working squeezeplug. What have you done to this system. It used to work beautifully. Now???

    27. December 2016 at 19:58 #25265

    Hi

    I don’t understand what you mean with ” It always boots to x-Windows”
    The Pi boots if you see the jivelite surface on TV (per HDMI)
    Then you can enter the M2P webinterface and do your settings
    If i remember correctly in basic settings only Squeezelite runs on the Raspi

    27. December 2016 at 20:31 #25268

    This Pi is never going to be viewed except by SSD (Putty). It just sits in a closet headless running Squeezeplug and Logitech Media Server. It has run like this for 3 years and works perfectly. I access Pandora and my music via either Squeeze Ctrl on my phone or via the LMS web page on my PC. It does everything I want.

    That said, how can I get the new version of Max2Play to run command line Linux from boot every time? Please.

    My only motivation for upgrading was to get bluetooth capability.

    The only reason I plugged in a monitor was to set it up and edit the /etc/network/interfaces file to give me a static IP address, to install the nightly LMS, etc.. It was at this point I saw X-Windows and could not easily get rid of it. I do not need the CPU overhead of any extra tasks.

    • This reply was modified 9 months, 3 weeks ago by  rederikus.
    • This reply was modified 9 months, 3 weeks ago by  rederikus.
    5. January 2017 at 15:42 #25566

    Hi rederikus,

    Sorry about the late response. You can find the option “Autostart Desktop” in the Settings/Reboot menu. Remove the tick there.

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.

Register here