When using squeezelite & bluetoothspeaker get "No such device"

Max2Play Home 2016 (en) Forums Max2Play as Squeezebox (Player / Server) When using squeezelite & bluetoothspeaker get "No such device"

This topic contains 1 reply, has 2 voices, and was last updated by  Mbydeen Moderator 1 month, 2 weeks ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • 6. May 2017 at 12:19 #28732

    root@Raspi:/dev# /opt/squeezelite/squeezelite -n ‘Living Room (Amp)’ -m b8:27:eb:51:f6:fa -o bluetoothspeaker
    [12:17:47.024956] test_open:294 playback open error: No such device or address
    [12:17:47.025508] output_init_common:381 unable to open output device

    #### SQUEEZELITE VERSION ####
    Squeezelite v1.8, Copyright 2012-2015 Adrian Smith.

    #### SQUEEZELITE BUILDOPTIONS ####
    Build options: LINUX ALSA EVENTFD RESAMPLE FFMPEG VISEXPORT DSD

    #### AUDIOPLAYER CONFIG ####
    ### Configuration of Audioplayers
    SQUEEZELITE_PARAMETER=-o bluetoothspeaker -a 80:4::
    SHAIRPORT_PARAMETER=-d plug:plugequal
    USE_USB_DAC=0
    USE_EQUALIZER=1
    SYSTEM_USER=pi
    GMEDIARENDER_ALSA_DEVICE=sysdefault:CARD=sndrpihifiberry

    #### SQUEEZELITE -l ####
    Output devices:
    null – Discard all samples (playback) or generate zero samples (capture)
    plugequal – Equalizer for plughw:0,0
    bluetoothspeaker – Max2Play bluetooth speaker
    sysdefault:CARD=sndrpihifiberry – snd_rpi_hifiberry_digi, – Default Audio Device
    sysdefault:CARD=ALSA – bcm2835 ALSA, bcm2835 ALSA – Default Audio Device

    #### SHAIRPORT VERSION ####
    2.2.4-openssl-Avahi-ALSA-soxr

    #### OUTPUT SOUND DETAILS CARD 0 ####
    closed

    #### OUTPUT SOUND DETAILS CARD 1 ####
    closed

    #### Bluetooth Installation ####

    #### Bluetooth Dongle ####
    hci0: Type: BR/EDR Bus: USB
    BD Address: 5C:F3:70:7D:8E:51 ACL MTU: 1021:8 SCO MTU: 64:1
    UP RUNNING
    RX bytes:2442 acl:22 sco:0 events:107 errors:0
    TX bytes:1723 acl:18 sco:0 commands:88 errors:0

    #### DEVICE Echo-U0W ####
    [50:F5:DA:BB:B8:D0]
    Name: Echo-U0W
    Alias: Echo-U0W [rw]
    Address: 50:F5:DA:BB:B8:D0
    Icon: audio-card
    Class: 0xc0414
    Paired: 1
    Trusted: 1 [rw]
    Blocked: 0 [rw]
    Connected: 1
    UUIDs: [AudioSource, AudioSink, AVRemoteControl, PnPInformation, 4e72b490-1d0f-bf92-0e47-a84e01000000]

    8. May 2017 at 12:39 #28745

    Hi skazer,

    After installing Bluetooth you have to assign the soundcard Bluetoothspeaker or Pulse to your audioplayers. You can configure this on the Audioplayer page in advanced settings.To make sure your Speakers are reconnecting automatically on reboot, first start this device and then switch on your Bluetooth speakers.

    Important: the Bluetooth speakers should connect automatically after the first pairing, if the speakers are active. You should always enable Autostart! This sets the correct sound-output for the speakers after they are connected. When your BT-Speakers are immediately disconnecting on first setup, try to switch OFF the BT-Speakers, wait for 10 seconds and Power ON again. This should automatically connect them.

    Best Regards,
    Mohammad Mbydeen

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.

Register here