When using bluetooth speaker the "reconnect" button is not visible

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI When using bluetooth speaker the "reconnect" button is not visible

This topic contains 19 replies, has 2 voices, and was last updated by  ari69 premium 2 months, 2 weeks ago.

Viewing 20 posts - 1 through 20 (of 20 total)
  • 17. June 2017 at 15:02 #29580

    I am very pleased with using max2play, I am using the multisqueeze now with USB, Hifiberry and Bluetooth.

    However when disconnecting the Bluetooth speaker the connection is lost and I need to connect it again via the website. The option as explained on the site with the “reconnect” is just not visible in my situation, so the speaker is connected and playing, but now button available.

    Is someone familiar with this situation?

    Thanks in advance.

    Arjan

    19. June 2017 at 11:38 #29601

    Hi Arjan,

    Have you tried removing the device from your list and re-establishing the connection?

    20. June 2017 at 20:27 #29662

    Hello Heiner,

    Thanks for your reply. I just removed all connections with the bluetooth speakers and connected one speaker again.
    Speaker is working again on bluetooth, however the “reconnect” button is still not visible.
    I also tried it with a Bose speaker, but there was no diference.

    Any other suggestions?

    Kind regards,

    Arjan

    Debug info:
    #### Bluetooth Installation ####

    #### Bluetooth Dongle ####
    hci0: Type: BR/EDR Bus: UART
    BD Address: B8:27:EB:72:AA:85 ACL MTU: 1021:8 SCO MTU: 64:1
    UP RUNNING
    RX bytes:9960120 acl:365 sco:0 events:1243284 errors:0
    TX bytes:2131400580 acl:2485830 sco:0 commands:215 errors:0

    #### DEVICE Iriver IBA-50 ####
    [A0:E9:DB:04:50:B8]
    Name: Iriver IBA-50
    Alias: Iriver IBA-50 [rw]
    Address: A0:E9:DB:04:50:B8
    Icon: audio-card
    Class: 0x240404
    Paired: 1
    Trusted: 1 [rw]
    Blocked: 0 [rw]
    Connected: 1
    UUIDs: [Headset, AudioSink, Handsfree]

    #### PACMD LIST | grep active ####
    active port: <analog-output>
    active port: <analog-output>
    active port: <analog-output-speaker>
    active port: <headset-output>
    active port: <analog-input-mic>
    active profile: <output:analog-stereo>
    active profile: <output:analog-stereo>
    active profile: <output:analog-stereo+input:analog-mono>
    active profile: <a2dp>

    #### PACMD LIST | grep sink ####
    Default sink name: bluez_sink.A0_E9_DB_04_50_B8
    name: <module-null-sink>
    module.description = “When a bluetooth sink or source is added, load module-loopback”
    module.description = “Automatically restore the default sink and source”
    name: <module-always-sink>
    module.description = “When a sink/source is idle for too long, suspend it”
    module.description = “Load filter sinks automatically when needed”
    module.description = “BlueZ 5 Bluetooth audio sink and source”
    5 sink(s) available.
    driver: <module-null-sink.c>
    name: <bluez_sink.A0_E9_DB_04_50_B8>
    bluetooth.protocol = “a2dp_sink”
    driver: <module-null-sink.c>
    name: <bluez_sink.A0_E9_DB_04_50_B8.monitor>
    sinks:
    sinks:
    sinks:
    sinks:
    bluez_sink.A0_E9_DB_04_50_B8/#12: Iriver IBA-50
    bluez_sink.A0_E9_DB_04_50_B8.monitor/#14: Monitor of Iriver IBA-50
    1 sink input(s) available.
    sink: 6 <alsa_output.usb-C-Media_INC._USB_Sound_Device-00-MicroII.analog-stereo>
    module-stream-restore.id = “sink-input-by-application-name:ALSA plug-in [squeezelite]”

    #### X-SERVER RUNNING ####
    1

    #### PULSEAUDIO RUNNING ####
    1 S 1000 21688 1 1 80 0 – 51454 – ? 00:58:38 pulseaudio

    #### PACMD LIST-CARDS | DEBUG COMPLETE ####
    4 card(s) available.
    index: 0
    name: <alsa_card.0>
    driver: <module-alsa-card.c>
    owner module: 7
    properties:
    alsa.card = “0”
    alsa.card_name = “bcm2835 ALSA”
    alsa.long_card_name = “bcm2835 ALSA”
    device.bus_path = “/devices/virtual/sound/card0”
    sysfs.path = “/devices/virtual/sound/card0”
    device.string = “0”
    device.description = “bcm2835 ALSA”
    module-udev-detect.discovered = “1”
    device.icon_name = “audio-card”
    profiles:
    output:analog-mono: Analoog mono Output (priority 100, available: unknown)
    output:analog-stereo: Analoog stereo Output (priority 6000, available: unknown)
    off: Uit (priority 0, available: unknown)
    active profile: <output:analog-stereo>
    sinks:
    alsa_output.0.analog-stereo/#1: bcm2835 ALSA Analoog stereo
    sources:
    alsa_output.0.analog-stereo.monitor/#1: Monitor of bcm2835 ALSA Analoog stereo
    ports:
    analog-output: Analoge output (priority 9900, latency offset 0 usec, available: unknown)
    properties:

    index: 5
    name: <alsa_card.usb-C-Media_INC._USB_Sound_Device-00-MicroII>
    driver: <module-alsa-card.c>
    owner module: 31
    properties:
    alsa.card = “1”
    alsa.card_name = “Audio Advantage MicroII”
    alsa.long_card_name = “C-Media INC. Audio Advantage MicroII at usb-3f980000.usb-1.3.1, full speed”
    alsa.driver_name = “snd_usb_audio”
    device.bus_path = “platform-3f980000.usb-usb-0:1.3.1:1.0”
    sysfs.path = “/devices/platform/soc/3f980000.usb/usb1/1-1/1-1.3/1-1.3.1/1-1.3.1:1.0/sound/card1”
    udev.id = “usb-C-Media_INC._USB_Sound_Device-00-MicroII”
    device.bus = “usb”
    device.vendor.id = “0d8c”
    device.vendor.name = “C-Media Electronics, Inc.”
    device.product.id = “0103”
    device.product.name = “CM102-A+/102S+ Audio Controller”
    device.serial = “C-Media_INC._USB_Sound_Device”
    device.string = “1”
    device.description = “CM102-A+/102S+ Audio Controller”
    module-udev-detect.discovered = “1”
    device.icon_name = “audio-card-usb”
    profiles:
    output:analog-stereo: Analoog stereo Output (priority 6000, available: unknown)
    off: Uit (priority 0, available: unknown)
    active profile: <output:analog-stereo>
    sinks:
    alsa_output.usb-C-Media_INC._USB_Sound_Device-00-MicroII.analog-stereo/#6: CM102-A+/102S+ Audio Controller Analoog stereo
    sources:
    alsa_output.usb-C-Media_INC._USB_Sound_Device-00-MicroII.analog-stereo.monitor/#6: Monitor of CM102-A+/102S+ Audio Controller Analoog stereo
    ports:
    analog-output: Analoge output (priority 9900, latency offset 0 usec, available: unknown)
    properties:

    index: 9
    name: <alsa_card.usb-C-Media_Electronics_Inc._USB_PnP_Sound_Device-00-Device>
    driver: <module-alsa-card.c>
    owner module: 36
    properties:
    alsa.card = “3”
    alsa.card_name = “USB PnP Sound Device”
    alsa.long_card_name = “C-Media Electronics Inc. USB PnP Sound Device at usb-3f980000.usb-1.4, full spe”
    alsa.driver_name = “snd_usb_audio”
    device.bus_path = “platform-3f980000.usb-usb-0:1.4:1.0”
    sysfs.path = “/devices/platform/soc/3f980000.usb/usb1/1-1/1-1.4/1-1.4:1.0/sound/card3”
    udev.id = “usb-C-Media_Electronics_Inc._USB_PnP_Sound_Device-00-Device”
    device.bus = “usb”
    device.vendor.id = “0ccd”
    device.vendor.name = “TerraTec Electronic GmbH”
    device.product.id = “0077”
    device.product.name = “Aureon Dual USB”
    device.serial = “C-Media_Electronics_Inc._USB_PnP_Sound_Device”
    device.string = “3”
    device.description = “Aureon Dual USB”
    module-udev-detect.discovered = “1”
    device.icon_name = “audio-card-usb”
    profiles:
    input:analog-mono: Analoog mono Input (priority 1, available: unknown)
    output:analog-stereo: Analoog stereo Output (priority 6000, available: unknown)
    output:analog-stereo+input:analog-mono: Analoog stereo Output + Analoog mono Input (priority 6001, available: unknown)
    off: Uit (priority 0, available: unknown)
    active profile: <output:analog-stereo+input:analog-mono>
    sinks:
    alsa_output.usb-C-Media_Electronics_Inc._USB_PnP_Sound_Device-00-Device.analog-stereo/#10: Aureon Dual USB Analoog stereo
    sources:
    alsa_output.usb-C-Media_Electronics_Inc._USB_PnP_Sound_Device-00-Device.analog-stereo.monitor/#11: Monitor of Aureon Dual USB Analoog stereo
    alsa_input.usb-C-Media_Electronics_Inc._USB_PnP_Sound_Device-00-Device.analog-mono/#12: Aureon Dual USB Analoog mono
    ports:
    analog-input-mic: Microfoon (priority 8700, latency offset 0 usec, available: unknown)
    properties:
    device.icon_name = “audio-input-microphone”
    analog-output-speaker: Speakers (priority 10000, latency offset 0 usec, available: unknown)
    properties:
    device.icon_name = “audio-speakers”
    index: 11
    name: <bluez_card.A0_E9_DB_04_50_B8>
    driver: <module-bluez5-device.c>
    owner module: 40
    properties:
    device.description = “Iriver IBA-50”
    device.string = “A0:E9:DB:04:50:B8”
    device.api = “bluez”
    device.class = “sound”
    device.bus = “bluetooth”
    device.form_factor = “headset”
    bluez.path = “/org/bluez/hci0/dev_A0_E9_DB_04_50_B8”
    bluez.class = “0x240404”
    bluez.alias = “Iriver IBA-50”
    device.icon_name = “audio-headset-bluetooth”
    device.intended_roles = “phone”
    profiles:
    a2dp: High Fidelity Playback (A2DP Sink) (priority 10, available: unknown)
    off: Uit (priority 0, available: yes)
    active profile: <a2dp>
    sinks:
    bluez_sink.A0_E9_DB_04_50_B8/#12: Iriver IBA-50
    sources:
    bluez_sink.A0_E9_DB_04_50_B8.monitor/#14: Monitor of Iriver IBA-50
    ports:
    headset-output: Headset (priority 0, latency offset 0 usec, available: unknown)
    properties:

    headset-input: Headset (priority 0, latency offset 0 usec, available: no)
    properties:

    22. June 2017 at 12:28 #29678

    Hi Arjan,

    We renamed the “reconnect” button to “connect”. Please use this one, it will work as well.

    22. June 2017 at 20:23 #29684

    Hello Heiner,

    Unfortunately I do not notice any difference.
    If I press the “connect” button, the connection even gets lost, after connecting again it is active again. As soon as I switch of the power from the speaker and activate it again, i need to put it in pairing mode to be able to establish a connection again.

    Pressing disconnect and connect again seems to work, but for actually disconnecting the speaker by switching of the power does not seem to work.

    Kind regards,

    Arjan

    26. June 2017 at 10:59 #29717

    Hi Arjan,

    Have you tried any other BT device to rule out this source of error?

    26. June 2017 at 20:49 #29728

    Hello Heiner,

    I have already tried it with a Bose speaker as well, but could not see any difference.

    Kind regards,

    Arjan

    28. June 2017 at 15:22 #29748

    Hi Arjan,

    If you use the device via LAN, you can try deactivating the WiFi to free up workload and the BT antenna.

    28. June 2017 at 19:17 #29760

    Hello Heiner,

    Some more news:
    The Wifi was already deactivated, since on Wifi the sound to the BT speaker starts to stutter.

    But…I saw on the example pictures on your website that a JBL (Go) speaker was pictured. I just borrowed one from a friend and yes this seams to work. I did not even have to select the connect button again (better not because it then disconnects!) to be able to get the PI and speaker connected again after both were powered off.

    What information (log files) do you need to be able to identify a solution to get other speakers working as well.

    I now used:
    – A bose soundlink speaker (NOK)
    – A Iriver IBA-50 speaker (NOK)
    – JBL GO speaker (OK)

    Thanks in advance.

    Kind regards,

    Arjan

    5. July 2017 at 12:20 #29806

    Hello Heiner,

    I was wondering whether you would have some more tips etc., to get the other Bluetooth speakers connected as well.
    I temporary borrowed the JBL from a friend, so if I can be of any help to give you further information, please let me know.

    Right now, I still cannot use the Bluetooth with my own speaker the way I would like to (stay connected).

    Thanks in advance.

    kind regards,

    Arjan

    5. July 2017 at 12:44 #29808

    Hi Arjan,

    You can contact the manufacturer of your own speakers and inquire, what their Bluetooth protocol is and whether they have had any similar problems with Pi’s of the same kind.

    Also, if you have not yet, make sure your Max2Play version is the newest one.

    7. July 2017 at 15:01 #29850

    Hello Heiner,

    I have not yet had a reaction from the manufacturer and I wonder whether I will receive one.

    For you information, I tested my iphone with the Iriver speaker and they reconnect automatically after the power is switched of and on again.
    Is that not the same kind of procedure as to be used between the Iriver and Max2play?

    And what would you suggest to be the next step if I do not receive any information from the manufacturer?

    Kind regards,

    Arjan

    7. July 2017 at 15:55 #29851

    Hello Heiner,

    I just had a reaction from Bose:
    “The protocols used by the Bose SoundLink speakers to be able to work together are: A2DP, AVRCP & HFP.
    Please note that your Raspberry Pi 3 Bluetooth adapter must be an adapter that has A2DP and a Bluetooth version 2.1 or higher.”

    To remember the connection with the speaker, seems like something that has to be taken care of within the RPI-3.

    I hope this might help to get to a solution.

    Waiting for your respons,

    Kind regards,

    Arjan

    10. July 2017 at 17:44 #29873

    Hi Arjan,

    As mentioned before, it is difficult to isolate the specific error that causes your connectivity issue.

    However, I would recommend you try using a fresh image, update to the newest version and install the BT plugin anew to see whether this creates the same issue.

    10. July 2017 at 20:37 #29884

    Hello Heiner,

    I tried what you suggested, but no difference. The “reconnect” button is still not visible and of course the automatich pairing does not work.

    Would it be usefull to send you both logfiles?

    Kind regards,

    Arjan

    19. July 2017 at 17:09 #29979

    Hi Arjan,

    I do not think so. You should be able to at least see the whole of the web interface. Especially with a freshly burnt image.

    You could try reinstalling the plugin itself with the uninstall button on the Bluetooth web interface.

    25. July 2017 at 20:15 #30152

    Hello Heiner,

    Tried this as well but no difference.

    Is this functionality tested with other speakers than JBL as well?
    Any other suggestions?

    Kind regards,

    Arjan

    1. August 2017 at 11:43 #30281

    Hi Arjan,

    We tested the feature with various devices including speakers and headsets.

    Have you updated your system to the latest version of Max2Play yet? Also, does the device turn green now, once you click connect again?

    1. August 2017 at 19:28 #30293

    Hello Heiner,

    Actual situation:
    After the speaker is connected the first time, the name from the speaker turns green.
    When the speaker is connected and the button “connect” is pressed again the text changes to red when the speaker is not in pairing mode. When the speaker is in pairing mode, it stays green.

    After switching off and on the power of the speaker, the speaker is not automatically connected again.

    After installing last version:
    Color of the text is the same as above. However I noticed, that after the speaker is disconnected and switched on again, it is not automatically connected again. So far the same as it was, however I can connect to the speaker by pressing the “connect” button without putting the speaker in pairing mode.
    Maybe this was already the situation with the previous version, but at least not noticed by me earlier.

    So it looks it needs a trigger to be found again.

    I hope this helps you, up to the next step:).

    Kind regards and thanks so far.

    Arjan Raaijmakers

    1. August 2017 at 20:26 #30295

    Hello Heiner,

    More news. It seems that I can get it working, but not yet in the preferred way.
    After switching the speaker off and on again, it does not yet work (tried to stop/start music etc.) but now it seems that after I refresh the page with the bluetooth settings in front (only pressing F5) it starts again.

    Seems like the trigger needed.

    This is not applicable at another page.

    Kind regards,

    Arjan Raaijmakers

Viewing 20 posts - 1 through 20 (of 20 total)

You must be logged in to reply to this topic.

Register here