Webinterface not reachable after (re-)installation (write protect problem?)

Max2Play Home 2016 (en) Forums SD-Card Imaging and getting started Webinterface not reachable after (re-)installation (write protect problem?)

This topic contains 3 replies, has 2 voices, and was last updated by  Heiner Moderator 2 months, 2 weeks ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • 23. April 2019 at 12:58 #45114

    Dear friends,

    I have been running M2P on various Raspi at my household all served from an LMS-server installed on a synology NAS. It worked for 2 years with only minor problems (some clients always get lost and are only rescanned after a reboot). But recently, one client, a pi zero with DAC+ Zero 1.0.1 lost contact and could not be brought back to live with a reboot.

    First I could connect to the web interface which informed me that
    a) there was no license for M2P
    b) the right DAC has not been chosen and
    c) that there is an M2P update to 2.4.7. available.

    I tried entering the license (I have full 5 years license) and also tried changing the DAC but both failed. After reboot the system still did not know about the license nor did it accept the selected DAC. The device had full access to the internet, verified with ssh and ping from the device.

    Hence I thought I start with the update to 2.4.7 and then debug the other problems. Hence back to reinstall:

    1. Removed SDcard
    2. reformatted SDcard
    3. Downloaded new 2.4.7 M2P image
    4. Burned image to SD card
    5. Activated WPS (required for WLAN scan)
    6. Rebooted pi with prepared SDcard

    Result:

    – pi is connected to network and accessible via ssh
    – but Web interface is not available. Scanning the logs it seems, that the system is inable to write to the SDcard. There is no write protect plugin enabled, its a fresh install.

    Hence now I am a bit clueless. Might that be a defective SDcard which only shows the problem once the system boots? But fsck does not hint to any problem:

    sudo fsck
    fsck from util-linux 2.25.2
    e2fsck 1.42.12 (29-Aug-2014)
    /dev/mmcblk0p2: sauber, 93062/448224 Dateien, 563505/1893296 Blöcke
    fsck.fat 3.0.27 (2014-11-12)
    /dev/mmcblk0p1: 185 files, 2739/7673 clusters

    Here is the log from apache etc:

    [email protected]:~ $ sudo systemctl status -l apache2.service
    ● apache2.service – LSB: Apache2 web server
    Loaded: loaded (/etc/init.d/apache2)
    Drop-In: /lib/systemd/system/apache2.service.d
    └─forking.conf
    Active: failed (Result: exit-code) since Fr 2018-06-29 11:24:28 CEST; 1min 52s ago
    Process: 1248 ExecStart=/etc/init.d/apache2 start (code=exited, status=1/FAILURE)

    Jun 29 11:24:28 Kitchen-Music apache2[1248]: Starting web server: apache2mktemp: konnte die Datei nicht mittels Schablone „/tmp/tmp.XXXXXXXXXX“ erstellen: Das Dateisystem ist nur lesbar
    Jun 29 11:24:28 Kitchen-Music apache2[1248]: /etc/init.d/apache2: 91: /etc/init.d/apache2: cannot create : Directory nonexistent
    Jun 29 11:24:28 Kitchen-Music apache2[1248]: failed!
    Jun 29 11:24:28 Kitchen-Music apache2[1248]: The apache2 configtest failed. … (warning).
    Jun 29 11:24:28 Kitchen-Music systemd[1]: apache2.service: control process exited, code=exited status=1
    Jun 29 11:24:28 Kitchen-Music systemd[1]: Failed to start LSB: Apache2 web server.
    Jun 29 11:24:28 Kitchen-Music systemd[1]: Unit apache2.service entered failed state.

    23. April 2019 at 13:22 #45116

    Hi Marc,

    Thanks for sharing this detailed post, I will see if anything special could be done. For now, though please try another microSD if you have any, to rule out a likely faulty SD card as source of error.

    27. April 2019 at 17:03 #45160

    Dear Heiner,

    I tried a new SDcard and it works again. I know its not a big deal but the faulty SDcard has been purchased with a pre-installed m2p from your shop last year, 22.5.2018. It is a Samsung 8GB. I couldn’t find any information about warranty but I guess since it is not even one year it should be covered. Any chance of a replacement?

    best

    Marc

    30. April 2019 at 12:20 #45180

    Sure, contact us via email with your order no. and we will be able process your request.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

Register here