web access problems

This topic contains 5 replies, has 3 voices, and was last updated by  MarioM Moderator 1 month, 1 week ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • 3. Dezember 2019 at 21:49 #47667

    Hi,
    I have a raspberry pi 3 and use max2play with the squeezebox server and the spotty app. It has been working ace for more than a year but recently accessing the squeezebox server from mobile devices (android phone and iPad, and both through a browser and through the squeezer app) started to be a bit of a lottery: Most of the time it doesn’t work, sometimes it works right after booting for a while and then it looses connection. From my laptop (also through wifi) it however still works. My mobile devices still work fine (accessing internet and other devices in the network). I am a bit puzzled and don’t know where to start trouble shooting. Any advice?
    Thanks
    Florian

    6. Dezember 2019 at 12:26 #47694

    Hi Florian,

    First see if the health checker in Settings/Reboot is affected by access from any apps.

    Then, check the debug info on the Squeezebox Server menu to make sure the server is not having any issues during access.

    If you have another SD card, you can also try copying your image with our image burner plugin to another card to make sure yours is not corrupted in any way.

    26. Juni 2020 at 23:48 #49099

    Hi, I have not picked up on it in December, but now with LockDown in UK I found some time to look at it again. I believed I had solved the problem by fixing the IP address but then I restarted everything having it switched off for a while and the erratic behaviour is back: When I start/reboot the raspberry pie I can access the web interface for a short while from the browser of my phone or iPad but after approximately a minute I cannot access it anymore. From a laptop (Mac or Windows) it still works fine. This is now without the squeezebox server running. Any help appreciated.
    Best
    Florian

    30. Juni 2020 at 14:11 #49124

    Hi Florian,

    Which Max2Play version do you use? Please update to the latest version 2.52, maybe your problem has already been solved.

    1. Juli 2020 at 22:45 #49172

    Hi, thanks for the reply. I have successfully updated to 2.52. It is really crazy. Everytime I change something it works fine until I switch max2play of. Could it be something in the router settings that is incompatible? At first I forced fixed IP addresses of my raspberry pis. Through that it worked fine for the rest of the day, but the next day it didn’t work again. Then I noticed that some of devices are on 2.4GHz and some on 5Ghz, so I put everything on 5GHz and it worked again for a day. Now I am trying to mess with the channels of my router. So far, no luck. Really frustrating. …
    Cheers
    Florian

    3. Juli 2020 at 14:40 #49177

    Hi Florian,

    We generally recommend not assigning fixed IP addresses, as this can lead to network problems. The router still assigns a „fixed“ IP address via DHCP when the device connects for the first time. Do you have the possibility to test the whole thing over LAN? If the problem then persists, the images or SD cards may be defective. Otherwise, I suspect that some special router settings are causing the problems.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.

Register here