Waveshare 4.3 display disabling wifi

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Waveshare 4.3 display disabling wifi

This topic contains 6 replies, has 2 voices, and was last updated by  MarioM Moderator 4 months, 3 weeks ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • 5. Mai 2020 at 18:27 #48706

    Hi there

    I just added a waveshare 4,3″ touch display to a PI3B+ over DSI.
    Now i can’t get wifi to work anymore, ethernet is working.

    I got this message when booting up „a start job is running for raise network interface“ and it’s working for some time then the pi boots and i get „No sessions for pid XXX“ messages randomly.

    I can use jivelite and ethernet but wifi just doesn’t work.

    Disconnecting the display resumes normal operations with working wifi.

    I searched the forums and googled for hours but i can’t find any solution.
    I’ve no idea how to fix that.

    Could anyone help? 🙂

    Thanks

    6. Mai 2020 at 13:55 #48711

    Hi Emile,

    which Max2Play version runs on your system?

    6. Mai 2020 at 14:01 #48712

    Hi Mario

    I’m running the stretch v249.
    I tried with a clean install and i tried as well to update and upgrade everything but none of these solutions worked.

    6. Mai 2020 at 14:13 #48715

    Hi Emile,

    Alright, I will ask our chief developer about this and I will contact you as soon as we have a solution.

    6. Mai 2020 at 14:54 #48716

    Thanks a lot

    6. Mai 2020 at 18:46 #48720

    I just tried with the Buster release 250, at first it didn’t worked (it didn’t built the access point) then i plugged the ethernet cable and finaly got it to connect to my network.
    I then successfully linked the pi with my Wifi but this only worked with the 5Ghz network, no chance to connect to the 2.4Ghz network which might be the reason why max2play couldn’t built an access point.

    I tried with a raspbian buster image, clean install, and got the same troubles. I was only able to connect to the 5Ghz network.
    So it might be that the waveshare screen is jamming the 2.4Ghz network in some ways.

    Anyway, i’m going to stick with this setup for the time, seems to work well.

    27. Mai 2020 at 15:51 #48869

    Hi Emile,

    That’s really weird. Maybe connecting the display is not the problem at all, but the display itself is interfering with the wifi signal. The WiFi chip of the Pi 3 is located directly on the board and is therefore vulnerable to signal attenuation by cases or displays. Maybe that’s why the 5Ghz connection works, because it has a higher frequency and can get past the display. You could still try to use a WiFi dongle (but then switch off integrated WiFi in the Raspberry settings). Maybe this will improve the connection. However, we cannot rule out that the installer of the Waveshare Display installs something strange, which may interfere with the WiFi connection too. But I suspect it is due to the size and proximity of the display to the Pi.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.

Register here