[SOLVED] Volume lowered after setting via rotary controller (IQaudio AMP+, RasPi 3)

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI [SOLVED] Volume lowered after setting via rotary controller (IQaudio AMP+, RasPi 3)

This topic contains 5 replies, has 2 voices, and was last updated by  Ajax premium 10 months, 2 weeks ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • 5. November 2017 at 17:57 #32288

    Hello together,

    I have set up a Raspberry Pi 3 with an IQaudio AMP+, a 7″ touchdisplay and a rotary controller running Squeezelite, Jivelite and IQ_rot.

    All works as expected but one weird effect is there, making the rotary almost useless:
    When setting volume louder with the rotary, 1 second later volume is decreased by a margin. Without touching the rotary volume remains stable until the next use of the rotary to increase volume.
    Adjusting the volume channel Digital via alsamixer shows the same behaviour: On increasing volume will be a decrease of 3 to 7 after about a second.
    Suqeezelite is started as:
    pi 657 1.9 1.6 52288 15612 ? Sl 16:46 0:03 /opt/squeezelite/squeezelite -m b8 27 xx xx xx xx -o hw:CARD=IQaudIODAC -V Digital -Q -n IQAudioAMP -P /run/squeezelite/squeezelite.pid -v -r 192000
    PID for monit and -v for having VU-meter.
    Jivelite:
    root 1696 0.0 0.3 7424 3312 ? S 16:46 0:00 sudo -u pi -H /opt/jivelite/jivelite/bin/jivelite
    pi 1701 3.2 2.3 43728 22612 ? Sl 16:46 0:06 \_ /opt/jivelite/jivelite/bin/jivelite

    Killing pulseaudio doesn’t help. Any other ideas are appreciated!

    Martin

    PS:
    Setting volume vie Jivelite and LMS works fine. Maybe there is a synchronization error?

    • This topic was modified 10 months, 2 weeks ago by  Ajax.
    • This topic was modified 10 months, 2 weeks ago by  Ajax. Reason: Typo
    • This topic was modified 10 months, 2 weeks ago by  Heiner.
    5. November 2017 at 22:15 #32297

    Some additional info:
    Raspi is connected via wire, IPv6 is active. Maybe this is the trigger? EDIT: No, IPv4 only still shows the same.
    Serverversion is:
    Logitech Media Server Version: 7.9.1 – 1505480690 @ Fri Sep 15 20:21:59 UTC 2017

    • This reply was modified 10 months, 2 weeks ago by  Ajax.
    7. November 2017 at 17:04 #32328

    Hi Ajax,

    Thanks for the detailed report. I will try to recreate this issue.

    Meanwhile, please try:
    – Running the system in a dry environment. We have had one instance of a rotary encoder not working properly due to humidity.
    – Deactivating built-in audio in the Raspberry Settings

    8. November 2017 at 10:11 #32341

    Hallo Heiner,

    humidity is not the problem: Around 20°C and 50% rel. in this room. Internal Audio was disabled already as is I2S-MMAP.
    The rotary is working without a hassle as is IQ_rot. I tried several different steps using the source code and alsamixer is showing exactly the chosen steps for one tick. Since changing the volume in alsamixer without using the rotary is also reseted , it is an action done by squeezelite. I suppose squeezelite is not monitoring volume settings done directly in alsa and then sets this arbitrary offset.

    I have another setup with Raspi 3, 7″ Touchdisplay and IQaudio DAC (not plus) instead of AMP+ without a rotary downstairs. I will try if setting volume in alsamixer will be changed there also like the system with AMP+. Then the cause is definitely not related to the rotary but within the interaction between ALSA and squeezelite.

    Ciao,

    Martin

    8. November 2017 at 16:24 #32356

    Hi Martin,

    I think we were able to find the issue you might have encountered.

    There should be no parameters in the command line options after „-Q“. Please move all other parameters to the front or remove them temporarily to check whether this fixes the problem.

    8. November 2017 at 21:32 #32368

    Hallo Heiner,

    yep, this fixes the problem. Volume setting via rotary and alsamixer is now working.

    Thank You very much,

    Martin

    PS: Parameter position; AAARGH!
    PPS: Should be appended to Command line parameters for Squeezelite

    • This reply was modified 10 months, 2 weeks ago by  Ajax.
Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.

Register here