Video streaming to a beamer via a 2nd m2p raspberry pi HDMI port?

Max2Play Home 2016 (en) Forums General Questions on Hardware and Max2Play Versions Video streaming to a beamer via a 2nd m2p raspberry pi HDMI port?

This topic contains 9 replies, has 2 voices, and was last updated by  Heiner Moderator 2 weeks, 1 day ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • 21. October 2017 at 23:56 #32033

    Hi,

    my first original Max2Play squeezeserver/jivelite/7inch PI touch is working perfectly, connected wired to my amplifier.
    Youtube videos I can watch on my Ipad and playing the audio on my Max2Play Pi via sharepoint.

    However, I‘m looking now to stream also the video signal wireless from my ipad to an external beamer, but the audio playing seperated as used via the first max2play pi…

    Ho to do this? Any possibility via e.g. a 2nd max2play pi, HDMI port -> external beamer?

    Of course audio and video need to be synchron.

    • This topic was modified 1 month ago by  lemuba.
    24. October 2017 at 12:35 #32057

    Hi lemuba,

    Should work with Kodi -> System -> Service Settings -> enable DLNA or AirPlay -> stream video stuff

    I just tested with RPi3, Kodi 17.4 and UPnP/DLNA via Android using AllConnect, should work the same with AirPlay, your device shows up as “max2play (kodi)”

    24. October 2017 at 15:04 #32074

    Hello Heiner,

    thank you! I will test asap and report back.

    25. October 2017 at 15:22 #32105

    Hi lemuba,

    Just to clarify, you need to connect one Pi via HDMI to the beamer AND the sound card on the same Pi to your speakers. Then, you can select the audio output for your sound card in Kodi and have the HDMI output be to the beamer. That should allow your setup to work with just one Raspberry Pi.

    25. October 2017 at 21:12 #32111

    Hello Heiner, then it will unfortunately not work for me.
    Sound needs to come from PI 1, Video via HDMI from PI 2.

    My plan was to mount a budget LED beamer together with Pi2 to the living room ceiling and to stream wireless e.g. youtube video to it. But the sound needs to come from the Pi1 which is connected already to my 1980th amplifier and the sound output to two speakers mounted in the same ceiling.
    Defacto I need an extended Multiroom Video and Audio Solution…

    27. October 2017 at 9:01 #32142

    Hi lemuba,

    For that you could try pairing your device to play youtube on with the bluetooth plugin for the audio Pi and stream the same procedure as mentioned above for the second Pi with video.

    31. October 2017 at 9:32 #32219

    I got it now – I reanimated my old AppleTV2 with direct video output via HDMI to the TV or Beamer and updated it to the latest firmware. It the AppleTv menue its possible to select again external AppleTV speakers — in my case Max2Play via sharepoint. Video streaming from our IOS devices via airplay is now working almost perfectly — with almost I mean:

    — The Video/Audio sync is almost perfect — the audio signal slightly delayed, but almost not recognizeable…maybe approximate 0,1 seconds.
    — I miss a working volume slider on the IOS device — the volume of the streamed video content can currently only be adjusted manually on the amplifier. On the AppleTv I set up one times the external airplay speakers volume (Max2Play) to maximum. But according to my knowledge yet, it is not possible to adjust the volume during streaming on the IOS device…tbc, to be optimized…

    • This reply was modified 3 weeks, 1 day ago by  lemuba.
    • This reply was modified 3 weeks, 1 day ago by  lemuba.
    • This reply was modified 3 weeks, 1 day ago by  lemuba.
    • This reply was modified 3 weeks, 1 day ago by  lemuba.
    • This reply was modified 3 weeks, 1 day ago by  lemuba.
    1. November 2017 at 17:10 #32234

    Hi lemuba,

    Firstly, congrats on finding your own solution.

    Secondly, if you have not yet, you can add hardware volume control for shairport which is exactly what should fix your volume issue:

    Optimizing Shairport’s Volume Control

    5. November 2017 at 18:03 #32290

    Hello Heiner,

    the hardware volume control is not working yet – I believe it´s a mixer related issue – any idea how to fix?
    My soundcard is from your bundle (7# touch display, PI 3 and IQaudIO PI-DAC+)

    I used following command line in the extended shairport options:

    -t hardware -m hw:0 -c Digital

    Error Message:
    Versucht zu starten … NICHT Erfolgreich Hier klicken für weitere Informationen
    The alsa backend -t option is deprecated and has been ignored. FYI, using the -c option automatically chooses a hardware mixer.
    Failed to find mixer element

    amixer output:

    [email protected]:/etc/pulse $ amixer
    Simple mixer control ‘Master’,0
    Capabilities: pvolume pswitch pswitch-joined
    Playback channels: Front Left – Front Right
    Limits: Playback 0 – 65536
    Mono:
    Front Left: Playback 58409 [89%] [on]
    Front Right: Playback 58409 [89%] [on]
    Simple mixer control ‘Capture’,0
    Capabilities: cvolume cswitch cswitch-joined
    Capture channels: Front Left – Front Right
    Limits: Capture 0 – 65536
    Front Left: Capture 65536 [100%] [on]
    Front Right: Capture 65536 [100%] [on]

    • This reply was modified 2 weeks, 3 days ago by  lemuba.
    • This reply was modified 2 weeks, 3 days ago by  lemuba.
    7. November 2017 at 15:43 #32325

    Hi lemuba,

    Since you have an IQaudIo Pi-DAC, the shairport player should automatically be set to ideal hw volume control when selecting the sound card and rebooting. Please try selecting none as a sound card, rebooting and selecting the Pi-DAC again and rebooting.

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.

Register here