Verbindung zum Squeezeserver nicht möglich

Max2Play Home 2016 (en) Forums Max2Play Add-ons Verbindung zum Squeezeserver nicht möglich

This topic contains 7 replies, has 3 voices, and was last updated by  Heiner Moderator 9 months ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • 21. December 2016 at 10:11 #25098

    Hallo,

    nachdem ich nun erstmal nur mit dem Squeezeclient probiert habe, habe ich nun den SqueezeServer installiert, da ich gerne in Verbindung mit Bluetooth meine Musik vom Echo dot und Handy streamen möchte. Bisher war der LMS auf meiner Synology installiert. Konnte mich mit der Android App “Squeezer” auch dorthin connecten und die Musik auf dem MAX2Play abspielen. Mit dem SqueezBoxServer ( Nightly 7.9) findet aber keine Verbindung statt. Habe aus dem PlayStore noch eine andere App ausprobiert. Im Squeezer wird der Server zwar sofort angezeigt, aber mehr nicht. Es bleibt beim “Connecting to 192.xxxx) einfach hängen. Testweise habe ich unter /etc/defaults/logitechmediaserver den user auf “root” gestellt. Keine Veränderung. Im Log finde ich folgendes.

    [16-12-20 23:53:10.5789] Plugins::ShairTunes2::Plugin::revoke_publishPlayer (204) Send TERM sig to old publish player services. pids: 15955
    2016-12-20 23:53:10 squeezeboxserver_safe started.
    [16-12-20 23:53:19.0545] main::init (384) Starting Logitech Media Server (v7.9.0, 1482214309, Tue Dec 20 06:50:33 UTC 2016) perl 5.020002 - arm-linux-gnueabihf-thread-multi-64int
    [16-12-20 23:53:19.0830] main::changeEffectiveUserAndGroup (1001) Warning: Logitech Media Server must not be run as root!  Trying user squeezeboxserver instead.
    [16-12-20 23:53:23.3916] Slim::Plugin::CLI::Plugin::cli_socket_open (163) Can't setup the listening port 9090: Die Adresse wird bereits verwendet
    [16-12-20 23:53:23.3941] Slim::Utils::PluginManager::load (385) Warning: Couldn't call Slim::Plugin::CLI::Plugin->initPlugin: Can't setup the listening port 9090: Die Adresse wird bereits verwendet at /usr/share/squeezeboxserver/lib/Log/Log4perl/Logger.pm line 900
    [16-12-20 23:53:25.7131] Plugins::ShairTunes2::Plugin::publishPlayer (222) start avahi-publish-service "max2play"
    [16-12-21 00:01:17.3681] Plugins::ShairTunes2::Plugin::handleSocketConnect (292) New connection from ::ffff:192.168.178.44
    [16-12-21 00:01:17.6067] Plugins::ShairTunes2::Plugin::conn_handle_request (503) shairport_helper: VERSION: 0.2
    [16-12-21 00:01:17.6097] Plugins::ShairTunes2::Plugin::conn_handle_request (520) launched decoder: 18695 on ports: 6000/6001/8000
    [16-12-21 00:01:26.5304] Plugins::ShairTunes2::Plugin::conn_handle_request (569) Decoder error: bye!
    [16-12-21 00:01:26.5442] Plugins::ShairTunes2::Plugin::handleSocketConnect (292) New connection from ::ffff:192.168.178.44
    [16-12-21 00:01:26.7364] Plugins::ShairTunes2::Plugin::conn_handle_request (503) shairport_helper: VERSION: 0.2
    [16-12-21 00:01:26.7418] Plugins::ShairTunes2::Plugin::conn_handle_request (520) launched decoder: 18698 on ports: 6000/6001/8000
    [16-12-21 00:02:05.0925] Plugins::ShairTunes2::Plugin::conn_handle_request (569) Decoder error: buffer_get_frame: missing frame
    [16-12-21 00:02:05.0951] Plugins::ShairTunes2::Plugin::conn_handle_request (569) Decoder error: buffer_get_frame: missing frame
    [16-12-21 00:02:05.0968] Plugins::ShairTunes2::Plugin::conn_handle_request (569) Decoder error: buffer_get_frame: missing frame
    [16-12-21 00:02:05.0994] Plugins::ShairTunes2::Plugin::conn_handle_request (569) Decoder error: HTTP send() unexpected response: -1 (data=1408): Connection reset by peer
    [16-12-21 00:02:05.1018] Plugins::ShairTunes2::Plugin::conn_handle_request (569) Decoder error: buffer_get_frame: missing frame
    [16-12-21 00:02:05.1036] Plugins::ShairTunes2::Plugin::conn_handle_request (569) Decoder error: HTTP send() unexpected response: -1 (data=1408): Connection reset by peer
    [16-12-21 00:02:05.1054] Plugins::ShairTunes2::Plugin::conn_handle_request (569) Decoder error: bye!
    [16-12-21 00:02:05.1174] Plugins::ShairTunes2::Plugin::handleSocketConnect (292) New connection from ::ffff:192.168.178.44
    [16-12-21 00:02:05.3065] Plugins::ShairTunes2::Plugin::conn_handle_request (503) shairport_helper: VERSION: 0.2
    [16-12-21 00:02:05.3097] Plugins::ShairTunes2::Plugin::conn_handle_request (520) launched decoder: 18874 on ports: 6000/6001/8001
     
    
    #### PERL VERSION ####
    v5.20.2 
    
    	

    Auch streamen per Bluetooth an MAX2Play funktioniert nicht mit dem Echo dot. Zwar konnte ich die Bluetooth Verbindung herstellen, aber es findet keine Soundausgabe statt.

    Woran kann es liegen? Habe zusätzlich Kodi laufen in Kombination mit SqueezeLite. Ohne Server und mit externem LMS funktioniert das gut soweit. Da mir aber die Bluetoothstreamingfunktion wichtig ist, kann ich auf den SqueezeBoxServer auf dem MAX2Play nicht verzichten.

    Grüße, Heinzelrumpel

    21. December 2016 at 11:27 #25102
    
    [email protected]:/opt/max2play# netstat -ant
    Aktive Internetverbindungen (Server und stehende Verbindungen)
    Proto Recv-Q Send-Q Local Address           Foreign Address         State
    tcp        0      0 0.0.0.0:9000            0.0.0.0:*               LISTEN
    tcp        0      0 0.0.0.0:139             0.0.0.0:*               LISTEN
    tcp        0      0 0.0.0.0:8080            0.0.0.0:*               LISTEN
    tcp        0      0 0.0.0.0:8081            0.0.0.0:*               LISTEN
    tcp        0      0 127.0.0.1:52307         0.0.0.0:*               LISTEN
    tcp        0      0 127.0.0.1:3350          0.0.0.0:*               LISTEN
    tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN
    tcp        0      0 0.0.0.0:36666           0.0.0.0:*               LISTEN
    tcp        0      0 0.0.0.0:1786            0.0.0.0:*               LISTEN
    tcp        0      0 0.0.0.0:3483            0.0.0.0:*               LISTEN
    tcp        0      0 0.0.0.0:35517           0.0.0.0:*               LISTEN
    tcp        0      0 0.0.0.0:445             0.0.0.0:*               LISTEN
    tcp        0      0 0.0.0.0:3389            0.0.0.0:*               LISTEN
    tcp        0      0 192.168.178.48:42682    192.168.178.48:3483     VERBUNDEN
    tcp        0    272 192.168.178.48:22       192.168.178.222:9483    VERBUNDEN
    tcp        0      0 192.168.178.48:44862    192.168.178.222:5000    TIME_WAIT
    tcp        0      0 192.168.178.48:44864    192.168.178.222:5000    TIME_WAIT
    tcp        0      0 192.168.178.48:41634    192.168.178.222:445     VERBUNDEN
    tcp        0      0 192.168.178.48:44866    192.168.178.222:5000    VERBUNDEN
    tcp        0      0 192.168.178.48:3483     192.168.178.48:42682    VERBUNDEN
    tcp        0      0 127.0.0.1:34160         127.0.0.1:6600          VERBUNDEN
    tcp6       0      0 :::42688                :::*                    LISTEN
    tcp6       0      0 :::9090                 :::*                    LISTEN
    tcp6       0      0 :::6600                 :::*                    LISTEN
    tcp6       0      0 :::139                  :::*                    LISTEN
    tcp6       0      0 :::8080                 :::*                    LISTEN
    tcp6       0      0 :::80                   :::*                    LISTEN
    tcp6       0      0 :::22                   :::*                    LISTEN
    tcp6       0      0 :::36666                :::*                    LISTEN
    tcp6       0      0 :::36667                :::*                    LISTEN
    tcp6       0      0 :::445                  :::*                    LISTEN
    tcp6       0      0 127.0.0.1:6600          127.0.0.1:34160         VERBUNDEN
    
    21. December 2016 at 18:42 #25125

    Hi,

    hab mir jetzt erst einmal so geholfen,dass ich den squeezeboxserver auf Port 9091 laufen lasse. Aber irgendwie wird nach dem scannen von Bluetooth Geräten nichts außer einer einzigen MAC Adresse angezeigt. Sehe den Zusammenhang da gerade nicht. Mit dem anderen Port geht ja erstmal,aber es soll keine Dauerlösung sein.Der Fehler sollte ja irgendwie behebbar sein.

    Gruß, heinzelrumpel

    22. December 2016 at 15:02 #25154

    Ich habe ein ähnliches Problem. Habe V2.39, und die gerade per Menüpunkt auf die Grundkonfiguratino zurückgesetzt. LMS (V7.9) läuft, jedoch liefert netstat -ant:

    [email protected]:~ $ netstat -ant
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State
    tcp 0 0 0.0.0.0:445 0.0.0.0:* LISTEN
    tcp 0 0 0.0.0.0:3389 0.0.0.0:* LISTEN
    tcp 0 0 0.0.0.0:4200 0.0.0.0:* LISTEN
    tcp 0 0 0.0.0.0:139 0.0.0.0:* LISTEN
    tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN
    tcp 0 0 127.0.0.1:3350 0.0.0.0:* LISTEN
    tcp 0 453 192.168.178.24:4200 192.168.178.37:52342 ESTABLISHED
    tcp 0 261 192.168.178.24:4200 192.168.178.37:52344 ESTABLISHED
    tcp 0 0 192.168.178.24:4200 192.168.178.37:52343 ESTABLISHED
    tcp6 0 0 :::445 :::* LISTEN
    tcp6 0 0 :::6600 :::* LISTEN
    tcp6 0 0 :::139 :::* LISTEN
    tcp6 0 0 :::80 :::* LISTEN
    tcp6 0 0 :::22 :::* LISTEN
    tcp6 0 0 192.168.178.24:80 192.168.178.37:52341 TIME_WAIT
    tcp6 0 0 192.168.178.24:80 192.168.178.37:52335 TIME_WAIT
    [email protected]:~ $

    Demnach wird gar nicht auf 9000 gehorcht. Hatte das Zurücksetzen auf Werkseinstellungen gewählt, weil Port 9000 nicht erreichbar war. Firewall ist nicht aktiv und ssh-Fernbedienung über Port 4200 funktioniert auch.

    wie bekomme ich port 9000 zum Leben und kann endlich wieder Verbindung zum LMS herstellen?

    22. December 2016 at 17:15 #25165

    Habe den Schuldigen jetzt ausfindig gemacht. Es liegt an Kodi, dass der Squeezeboxserver sich nicht an Port 9090 binden kann. Komisch bei der Sache ist nur, dass Kodi für sich nur tcp6:9090 beansprucht, der squeezeboxserver aber, wenn er denn dann läuft, nur tcp4:9090 benutzt. Habe per Webmenü tcp6 ausgeschaltet, schein für kodi aber kein Grund zu sein. Jetzt muss ich nur mal schauen, wie ich es hinbekomme, dass der squeezeboxsserver vor kodi gestartet wird. So geht es nämlich. Hat jemand eine Idee, wie man unter Jessie die Startreihenfolge ändert?

    • This reply was modified 9 months, 4 weeks ago by  heinzelrumpel.
    3. January 2017 at 16:15 #25411

    Hi heinzelrumpel,
    You can find the boot configuration under “boot/config.txt”

    3. January 2017 at 18:15 #25418

    And this is the answer to what question? Sorry, but I cannot see any relation to the start order of squeezeboxserver and kodi.

    13. January 2017 at 14:59 #25853

    You could use it to edit the boot sequence. You can also use this way: https://www.raspberrypi.org/documentation/linux/usage/rc-local.md
    Or a cron job: https://www.raspberrypi.org/documentation/linux/usage/cron.md

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.

Register here