Using Wifi channel above 11 (12 or 13)

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Using Wifi channel above 11 (12 or 13)

This topic contains 5 replies, has 2 voices, and was last updated by  Heiner premium 3 days ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • 16. November 2016 at 20:59 #23929

    Hello, I have a RPI 3 and I need to use the channel 12 to connet to the wifi router. I applied the following steps to have Access to this channel:

    sudo apt-get update
    
    sudo apt-get upgrade
    
    sudo apt-get dist-upgrade
    
    sudo rpi-update
    
    [reboot]
    
    sudo branch=next rpi-update
    
    [reboot]
    
    sudo iw reg set ES
    

    Two question:

    1.- I’ll have problems in the future doing this updates outside your “versi├│n”?
    2.- On each reboot I need to configure the country code on the wifi (sudo iw reg set ES
    ), Can I do this change permanent?

    Maybe doing only the Country Code for the Wifi is enough for your current rasbian version.

    Thanks for your support
    Bull

    • This topic was modified 2 weeks, 3 days ago by  Bull.
    29. November 2016 at 12:46 #24303

    Hi Bull,
    Could you please try using the web interface to connect to Wifi and then tell us the error message you would receive.

    29. November 2016 at 13:10 #24317

    Hello Heiner, thanks for your answer.

    That I could see, is that for default the wifi region, is configured in a country where those channels aren’t operative (maybe GB, I think so), so by default if you have your own wifi channel above 11 you cannot see the Wifi, so you can’t connect.

    After change the region to Spain in my case, doing “sudo iw reg set ES”, I can see my wifi, so the problem is that the region would by to default state after reboot and again I cannot see the wifi.

    My question is, How I can do this change in the wifi region permanent?.

    Many thanks
    Bull

    PS. I’m a noob on raspbian ­čÖü

    29. November 2016 at 13:14 #24320

    Hi Bull,
    Please set the language and the time zone in the Settings/Reboot to your region. This should fix it.

    29. November 2016 at 13:22 #24326

    Hi Heiner,

    The language and time zone all ready changed to Spain, but not fixed the problem. so, It would be possible that the wifi region is independent of language region selected? I’m not sure of that.

    Thanks
    bull

    1. December 2016 at 13:37 #24436

    Hi Bull,
    The system should generally automatically detect and use the right channel. Please try using a freshly burnt image and connecting to the network normally via the web interface using the scan feature.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.

Register here