Using Max2play as LMS with SSD HD

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Using Max2play as LMS with SSD HD

This topic contains 6 replies, has 2 voices, and was last updated by  MarioM Moderator 4 months, 1 week ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • 2. Februar 2021 at 2:00 #50704

    I have used Max2play with a Raspberry Pi for many years. My current set up is a stand alone Logitech Media Server on a Raspberry Pi 4 8 GB unit. I have always used a USB HD for the storage of my music files.

    However I was recently able to buy a new 2 TB SSD portable drive that will be used for all of my music. I would like to be able to get the maximum speed from this and would ask if you have done any work on enabling ‚Trim‘ in Buster to offer the best possible speeds .

    2. Februar 2021 at 18:23 #50719

    Hi Bencat,

    We haven’t integrated trim into our image yet. So you still have to install it manually at the moment.

    3. Februar 2021 at 14:44 #50725

    This is so frustrating I have added the new Crucial CX8 TB SSD HD to my Raspberry Pi 4 8GB which is acting as my stand alone LMS . Unlike when I started with Max2play which found and allowed a USB drive to be found and located under Media in LMS your current version finds the Crucial Drive but states it is unmounted.

    Once I mount it and it found by LMS it will allow a scan . However I currently rip my files to a 4 TB drive attached to my PC then via WINSCP copy the newly added files over to the USB connected to the Raspberry Pi . Now this is not possible because when I try it says it give the following and says the operation failed .

    scp: /mnt/extdrive/Andrews Music/Music Files/Tribute To Ndiouga Dieng/Folder.jpg: set times: Operation not permitted

    Why have you changed what was a perfectly easy system that worked for many years and created something that just stops me doing a very simple operation ? Is there a simple solution to this ? Please do not suggest Samba as I have never been able to get this to work with my PC ever , this is probably down to my lack of technical ability and Windows 10 but nothing I have done has worked. Is there anyhting I can change in Max2play on the raspberry Pi that will allow me access to the HD with read and write and delete permissions so i can just go back to what i have been doing for all this time ? If I put the old USB HD back that lets me access but I have no idea what is different about that drive .

    3. Februar 2021 at 16:26 #50726

    Apologies for the sour tone to the above lock down fever has got to me a bit this time and i do find the slightest thing gets me wound up . My main reason for wanting to sort this out is because using this SSD HD has made the music sound better and in particular it has made poor recordings easier and more enjoyable to listen to . So given this I am not going to give in and go back to the USB HD . I have to find a way to solve this and get things back to working how they were . Any help offered please can you be very clear and step by step with what to do . I regret that my abilities on Max2play and the Pi is limited to simple stuff that I have got from videos and other more advanced users .

    4. Februar 2021 at 15:38 #50736

    Hi Bencat,

    Hard disks connected to the Max2Play device are not automatically mounted. The path to the USB storage device must first be saved manually in the Filesystem/Mount plugin. Then the hard drive will be mounted to the same path even after a restart.

    The best way to access the connected hard drive with a Windows PC is to use a network share via Samba. If the hard disk has been mounted, a path, mount point, type and furhter options are shown at the top of the Filesystem/Mount plugin. We need the mount point for creating a Samba share. It’s probably called „/mnt/extdrive“. To create a Samba share we enter the following in the plugin under „Sambashares on Max2Play“:

    1. Input field: Name of the USB share, e.g. „musicdrive“
    2. Input field: The mount point „/mnt/extdrive“
    3. Input field: can be left blank
    4. Input field: „yes“
    5. Input field: „0777“

    Then we click on Save. After successfully adding the Samba share, we change the username and password of the Samba access below and click on Save there too.

    On our Windows PC we now go to „This PC“. In the top bar we find the option „Map network drive“. When we click on it, a new window will open. Here we now enter a network drive letter for our share that has not yet been assigned. We now need the IP address of the Max2Play device. We find this e.g. in the network settings of our router. Then we enter the following after „Folder:“: \\IP address\name of the USB share. In our case this is something like: „\\192.168.178.xxx\musicdrive“. Before we click on „Finish“, we tick „Reconnect at sign-in“ and „Connect using different credentials“. Now we should be asked for the login data. Here we enter the username and password that we set for the Samba access. We should now have access to the hard drive.

    Please let me know if this was helpful, even though you actually didn’t want to create a samba share.

    Another way would be to access the Pi via WinSCP. The IP of the Pi and the login data for SSH access (user: pi, password: max2play) are required there.

    4. Februar 2021 at 18:10 #50741

    Hi Mario

    As always thank you for your help and advice I have been using the WinSCP method for years but it is this that has stopped working and when you fix moount the HD it does not give you read / write / delete permissions to the drive so I am not able to copy one file to the other.

    I have gone through the set up you suggested and have got this to work now which will be fine . One small point for others doing it in the Windows set up just ticking the boxes for Reconnect at sign -in and Connect using different credentials does not bring up any log in boxes when you then click on finish . Instead you need to clink on the link in blue at the bottom which opens another window and put the details in that and then it lets you add your sign in and when completed it adds a link in your networks you can then cancel the original box you describe and everything works . This may well be a new thing in the current upgrade to Windows 10 .

    5. Februar 2021 at 17:13 #50742

    Hi Bencat,

    Thanks for the clarification. That will surely help others with a similar problem.

    I’ll ask our developer if he can solve the problem with write permissions. Maybe he can integrate a fix into our current beta image. Normally, the login via the user „pi“ and password „max2play“ should provide write access.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.

Register here