use Behringer UCA-202 with Pi2 and M2P

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI use Behringer UCA-202 with Pi2 and M2P

This topic contains 5 replies, has 2 voices, and was last updated by  waterdrinkingman premium 1 year, 2 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • 13. September 2015 at 15:17 #15661

    I just purchased the M2P so I can key in the advanced RasPi settings. In the section “Choose Soundcard to load on boot (device tree overlay)” I chose “USB Soundcards (Northstar Essensio, Hiface and others)”.

    When restarting I see the soundcard is detected as usual (works fine with all linux/win versions that I know). In the very end of the dmesg output I read:

    Error: could not insert module /opt/max2play/snd-usb–hiface-3.18.11/Pi_B/snd-usb-hiface.ko Invalid module format
    [FAIL] startpar: service(s) returned failure: rc.local … failed!

    In the M2P webinterface I can still force the output to the headphone jack and listen to music when playing from the squeezeplayer, but even when choosing “default”, unplugging the HDMI and rebooting no sound will come through the UCA202.

    questions:
    1) In case M2P would properly detect the soundcard, would it show up as a fourth entry in the “Set Audio Output on Raspberry PI” menu?
    2) Is the above module insert error the reason for the problem I am facing?

    13. September 2015 at 18:31 #15664

    correction: I am not using a Pi2, it is a B+.

    14. September 2015 at 16:59 #15670

    Hi waterdrinkingman,
    Yes, unfortunately your sound card does not seem to be properly detected by the system.

    14. September 2015 at 20:51 #15671

    Hm.
    Further up in the boot log, the linux system as such identifies it correctly as conencted to the USB port and treats it as “USB Audio codec”, more exaclty it lists says:

    usb 1-1.3: new full-speed USB device number 4 using dwc/otg
    usb 1-1.3: New USB device found, idVendor=o8bb, idProduct=2902
    usb 1-1.3: Product: USB Audio Code
    usb 1-1.3: Manufacturer: Burr-Brown from TI
    input: Burr-Brwon from TI USB Audio codec as /devices/platform/bcm2708_usb/usb1/1-1/1-1.3/1-1.3:1.3
    hid-generic 0003:08BB:2902.0001: input.hidraw0: USB HID v1.00 Device [Burr-Brown from TI

    As mentioned before, the standard linux cores identify this USB device properly, how can I make it work with the M2P image?

    15. September 2015 at 22:50 #15704

    When I look at the dmesg after plugging in the soundcard into an Ubuntu14.04LTS driven machine, this is what I get:

    [56603.296195] usb 5-1: new full-speed USB device number 2 using uhci_hcd
    [56603.826101] usb 5-1: New USB device found, idVendor=08bb, idProduct=2902
    [56603.826110] usb 5-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
    [56603.826115] usb 5-1: Product: USB Audio CODEC
    [56603.826120] usb 5-1: Manufacturer: Burr-Brown from TI
    [56603.832177] input: Burr-Brown from TI USB Audio CODEC as /devices/pci0000:00/0000:00:1d.0/usb5/5-1/5-1:1.3/input/input13
    [56603.832469] hid-generic 0003:08BB:2902.0003: input,hidraw2: USB HID v1.00 Device [Burr-Brown from TI USB Audio CODEC ] on usb-0000:00:1d.0-1/input3
    [56604.785386] usbcore: registered new interface driver snd-usb-audio

    When I do the same to the Max2play/RaspBi driven Pi B+ (with the soundcard to load on boot set to ‘none’) I get:
    [ 684.946788] usb 1-1.3: new full-speed USB device number 5 using dwc_otg
    [ 685.070370] usb 1-1.3: New USB device found, idVendor=08bb, idProduct=2902
    [ 685.070413] usb 1-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=0
    [ 685.070433] usb 1-1.3: Product: USB Audio CODEC
    [ 685.070451] usb 1-1.3: Manufacturer: Burr-Brown from TI
    [ 685.090896] input: Burr-Brown from TI USB Audio CODEC as /devices/platform/bcm2708_usb/usb1/1-1/1-1.3/1-1.3:1.3/0003:08BB:2902.0002/input/input1
    [ 685.092347] hid-generic 0003:08BB:2902.0002: input,hidraw0: USB HID v1.00 Device [Burr-Brown from TI USB Audio CODEC ] on usb-bcm2708_usb-1.3/input3

    Is the trouble that it is not “registering” the new driver? How can I make ALSA on max2play use the “snd-usb-audio” driver?

    16. September 2015 at 0:50 #15705

    After reading on the ALSA site (http://www.alsa-project.org/main/index.php/Download#alsa-driver) I learned that there is ALSA support (no surprise).
    There is a HowTo on enabling the usb audio support, too: http://www.alsa-project.org/main/index.php/Matrix:Module-usb-audio

    A modprobe won’t work:

    [email protected]:/etc# modprobe snd-usb-audio
    libkmod: ERROR ../libkmod/libkmod-module.c:174 kmod_module_parse_depline: ctx=0xb7f8a008 path=/lib/modules/3.18.7+/kernel/sound/usb/snd-usbmidi-lib.ko error=No such file or directory
    libkmod: ERROR ../libkmod/libkmod-module.c:174 kmod_module_parse_depline: ctx=0xb7f8a008 path=/lib/modules/3.18.7+/kernel/sound/usb/snd-usbmidi-lib.ko error=No such file or directory
    ERROR: could not insert ‘snd_usb_audio’: Unknown symbol in module, or unknown parameter (see dmesg)

    Even the soundcore module is not installed:

    [email protected]:/etc# modinfo soundcore
    ERROR: Module soundcore not found.

    Downloading the latest “old” driver (according to ALSA it should be contained in the kernel), which is 1.0.25 and trying to compile, I receive the following output:

    [email protected]:/usr/src/alsa/alsa-driver-1.0.25# ./configure –with-cards=usb-audio –with-sequencer=yes ; make ; make install
    checking for gcc… gcc
    checking whether the C compiler works… yes
    checking for C compiler default output file name… a.out
    checking for suffix of executables…
    checking whether we are cross compiling… configure: error: in `/usr/src/alsa/alsa-driver-1.0.25′:
    configure: error: cannot run C compiled programs.
    If you meant to cross compile, use `–host’.
    See `config.log’ for more details

    ANY HINTS?!

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.

Register here