USB HD changing the read / write for USB HD Mounted in Filesystem Mount

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI USB HD changing the read / write for USB HD Mounted in Filesystem Mount

This topic contains 5 replies, has 3 voices, and was last updated by  MarioM Moderator 2 years, 3 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • 8. August 2020 at 14:34 #49514

    I have an issue after I changed to a Raspberry Pi 4 8gb which I use as a stand alone Logitech Media Server while the Seagate 2TB USB HD unit I connect is found it says it is unmounted. In the past left like that in LMS under either mnt or media it would be found as usb or usb0 . I would then rip music to a 4TB HD connected to my PC and then use WINSCP to copy the music over to the USB HD connected to the Pi . This would mean I alwasy have a back up of the music and while it is a little extra work I am fine with that.

    However on installing the Pi 8 gb while it will identify the USB HD is connected and offer the device number LMS does not register it under mnt or media there is nothing found. However if I use the fixed mount option the device is found and I amk able to load my Library as normal . However now when I use WINSCP and try to copy files across to the USB HD it says that access is denied. I am quite happy to leave the fixed mount in place but how can i change the read / write options for the drive so that i can again use WINSCP to add things ?

    11. August 2020 at 12:33 #49526

    Hi Bencat,

    When you create the Samba Share for your usb drive, enter 0777 instead of 666 in the last input field to get full read and write permissions.

    11. August 2020 at 15:27 #49540

    Hi Mario

    I do not use Samba or create a share . In the past I have never needed it all I had to do was use WINSCP and then copy from the USB drive on my PC to the USB Drive on my Raspberry Pi . I have not done anything different but set the USB HD as Mounted on the File Settings page .

    this is what the mounted drive looks like (not able to cut and paste to this message )

    Path : UUID=1F02-2848/ Mountpoint: /mnt/extdrive: Type : vfat Options : defaults,nofail,iocharset=utf8

    Is there anything I can add to this that will enable me to access this ext drive and read / write ?

    12. August 2020 at 14:24 #49552

    Hi Bencat,

    We have not yet had the opportunity to test Max2Play with the Pi 4 8GB. Therefore it can be that the 8GB still causes problems. I have now tested the whole thing with another Pi 4 and was able to access the file system via winscp with the user „pi“ and copy files to the mounted hard drive. If you cannot access the Pi via winscp in general, try changing the password for the user pi or root in the Password Protection Plugin, if necessary.

    20. August 2020 at 21:47 #49568

    Sorry for hijacking this thread. Does MAX2play SAMBAshares support SMBv1 ?

    • This reply was modified 2 years, 3 months ago by  sfraser.
    • This reply was modified 2 years, 3 months ago by  sfraser.
    • This reply was modified 2 years, 3 months ago by  sfraser.
    2. September 2020 at 12:28 #49599

    Hi sfraser,

    SMB v1 is supported by Max2Play. To enter the correct parameters, please follow the instructions on the Filesystem/mount plugin page.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.

Register here