USB-Automount (FAT) / error while writing file with special characters

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI USB-Automount (FAT) / error while writing file with special characters

This topic contains 2 replies, has 2 voices, and was last updated by  zerbes premium 1 year ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • 7. November 2015 at 21:21 #16805

    Hi,

    trying to write files with special characters (like german umlauts ä, ö, ü) on auto-mounted USB to /media/usb0 leads to errors.

    The USB-stick is formatted with fat32.

    What Do I have to change to be able to write these files to the USB-stick?

    Thank you in advance,

    zerbes

    EDIT: I tried with NTFS-formatted stick and it worked perfect.

    • This topic was modified 1 year ago by  zerbes.
    • This topic was modified 1 year ago by  zerbes.
    10. November 2015 at 18:39 #16837

    Hi Zerbes,

    to use special letters in FAT32 you need to add the iocharset parameter to the usbmount configuration. This is done in file /etc/usbmount/usbmount.conf and the edited line looks like this:

    FS_MOUNTOPTIONS="-fstype=vfat,gid=users,uid=pi,iocharset=iso8859-1 \

    11. November 2015 at 22:59 #16863

    Thank you for your support!

    Using NTFS-formatted stick it worked perfectly, maybe the mentioned parameters could be added in a future max2play-update to also be able to use FAT32-formatted-sticks from scratch? I don’t need it anymore, maybe others need it.

    Kind regards

    zerbes

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.

Register here