Updating Logitech Media Server to latest 8.1 version

Max2Play Home 2016 (en) Forums Max2Play as Squeezebox (Player / Server) Updating Logitech Media Server to latest 8.1 version

This topic contains 19 replies, has 6 voices, and was last updated by  MarioM Moderator 2 months, 1 week ago.

Viewing 20 posts - 1 through 20 (of 20 total)
  • 9. Januar 2021 at 12:08 #50569

    I am using a Raspberry Pi4 8GB model as a stand alone Logitech Media Server with USB HD attached . I use the Beta version of Max2play so that I could update the LMS version to 8.0 . However I have noticed that the current LMS Version is 8.1 (with 8.2 a Beta version) . Over the last few weeks every other day my LMS will advise there is an newer version of LMS to download but the only 8.0 version offered is logitechmediaserver_8.0.1~1608617100_arm.deb which was from 22/12/2020 . Is it possible to update the LMS version to 8.1 ? Can I just copy the latest 8.1 Arm deb and insert it ? Will I need to do this each time or will you be offering the 8.1 version as an addition to the nightly updates ?

    Regards

    Andrew

    9. Januar 2021 at 23:36 #50572

    Hi,
    try this for Logitech Media Server Version: 8.1.1 – 1610082237 @ Fri Jan 8 06:39:21 CET 2021

    wget http://downloads.slimdevices.com/nightly/8.1/lms/98acac6cd971638c99480294729ae455ce25629c/logitechmediaserver_8.1.1~1610082237_all.deb -O /var/lib/squeezeboxserver/cache/updates/logitechmediaserver_8.1.1.deb
    dpkg -i /var/lib/squeezeboxserver/cache/updates/logitechmediaserver_8.1.1.deb

    or Logitech Media Server Version: 8.2.0 – 1610082250 @ Fri Jan 8 07:26:02 CET 2021
    wget http://downloads.slimdevices.com/nightly/8.2/lms/ec606488cbb6bfb69df52537f9fe494efabcfb3f/logitechmediaserver_8.2.0~1610082250_all.deb -O /var/lib/squeezeboxserver/cache/updates/logitechmediaserver_8.2.0.deb
    dpkg -i /var/lib/squeezeboxserver/cache/updates/logitechmediaserver_8.2.0.deb

    • This reply was modified 6 months, 2 weeks ago by  Shino.
    10. Januar 2021 at 14:33 #50574

    Thanks for that I was able to cut and paste this in to the update version bar on Max2play . Will I need to do this every time or will the versions 8.1 and 8.2 be added to the max2play update list ? If this is only done when using max2play in beta version that would be fine as those using this will know there may be issues .

    Also while I can see these updates under the slimdevices nightly downloads they are not the complete wget links you have added , where could I find these full links ?

    • This reply was modified 6 months, 2 weeks ago by  Bencat57.
    12. Januar 2021 at 15:51 #50589

    Hi Bencat,

    We have now made the other Squeezebox Server versions ready for installation again. You can find them when you perform a beta update of Max2Play. Please note, however, that some of the new versions have not yet been tested by us.

    15. März 2021 at 17:53 #50945

    Good afternoon

    Version 2.53
    Raspberry PI 3b+

    Linux max2play 5.10.20-v7+ #1404 SMP Thu Mar 4 19:40:23 GMT 2021 armv7l GNU/Linux

    I’m having a problem with Squeezebox Server on MAX2Play I don’t know if it was after some system update. Simply stopped accessing
    in the Max2play control panel is active

    Status: Squeezebox Server is running with processID 509

    ● logitechmediaserver.service – LSB: Startup script for the Logitech Media Server
    Loaded: loaded (/etc/init.d/logitechmediaserver; generated; vendor preset: enabled)
    Active: active (running) since Sun 2021-03-14 20:12:09 -03; 16h ago
    Docs: man:systemd-sysv-generator(8)
    Process: 374 ExecStart=/etc/init.d/logitechmediaserver start (code=exited, status=0/SUCCESS)
    Tasks: 3 (limit: 4915)
    CGroup: /system.slice/logitechmediaserver.service
    ├─ 509 /bin/bash /usr/sbin/squeezeboxserver_safe /usr/sbin/squeezeboxserver –prefsdir /var/lib/squeezeboxserver/prefs –logdir /var/log/squeezeboxserver/ –cachedir /var/lib/squeezeboxserver/cache –charset=utf8
    ├─4699 /usr/bin/perl /usr/sbin/squeezeboxserver –prefsdir /var/lib/squeezeboxserver/prefs –logdir /var/log/squeezeboxserver/ –cachedir /var/lib/squeezeboxserver/cache –charset=utf8
    └─4700 sleep 5

    mar 14 20:12:08 max2play systemd[1]: Starting LSB: Startup script for the Logitech Media Server…
    mar 14 20:12:09 max2play logitechmediaserver[374]: Making sure that Logitech Media Server is not running first: No process in pidfile ‚/var/run/logitechmediaserver.pid‘ found running; none killed.
    mar 14 20:12:09 max2play logitechmediaserver[374]: Starting Logitech Media Server.
    mar 14 20:12:09 max2play systemd[1]: Started LSB: Startup script for the Logitech Media Server.

    lsof -i -P -n
    COMMAND PID USER FD TYPE DEVICE SIZE/OFF NODE NAME
    avahi-dae 465 avahi 12u IPv4 15469 0t0 UDP *:5353
    avahi-dae 465 avahi 13u IPv6 15470 0t0 UDP *:5353
    avahi-dae 465 avahi 14u IPv4 15471 0t0 UDP *:36088
    avahi-dae 465 avahi 15u IPv6 15472 0t0 UDP *:55446
    sshd 674 root 3u IPv4 16536 0t0 TCP *:22 (LISTEN)
    sshd 674 root 4u IPv6 16538 0t0 TCP *:22 (LISTEN)
    rpimonito 760 pi 4u IPv4 14986 0t0 TCP *:8888 (LISTEN)
    shairport 787 pi 3u IPv4 16216 0t0 TCP *:5000 (LISTEN)
    shairport 787 pi 4u IPv6 16217 0t0 TCP *:5000 (LISTEN)
    apache2 841 root 3u IPv4 16227 0t0 TCP *:80 (LISTEN)
    nmbd 842 root 16u IPv4 17470 0t0 UDP *:137
    nmbd 842 root 17u IPv4 17471 0t0 UDP *:138
    nmbd 842 root 18u IPv4 17478 0t0 UDP 192.168.10.100:137
    nmbd 842 root 19u IPv4 17479 0t0 UDP 192.168.10.255:137
    nmbd 842 root 20u IPv4 17480 0t0 UDP 192.168.10.100:138
    nmbd 842 root 21u IPv4 17481 0t0 UDP 192.168.10.255:138
    minidlnad 844 minidlna 6u IPv4 17490 0t0 UDP 239.255.255.250:1900
    minidlnad 844 minidlna 8u IPv4 17491 0t0 TCP *:8200 (LISTEN)
    minidlnad 844 minidlna 9u IPv4 17496 0t0 UDP 192.168.10.100:52819
    apache2 846 www-data 3u IPv4 16227 0t0 TCP *:80 (LISTEN)
    apache2 847 www-data 3u IPv4 16227 0t0 TCP *:80 (LISTEN)
    apache2 848 www-data 3u IPv4 16227 0t0 TCP *:80 (LISTEN)
    apache2 849 www-data 3u IPv4 16227 0t0 TCP *:80 (LISTEN)
    apache2 850 www-data 3u IPv4 16227 0t0 TCP *:80 (LISTEN)
    smbd 874 root 33u IPv6 16279 0t0 TCP *:445 (LISTEN)
    smbd 874 root 34u IPv6 16280 0t0 TCP *:139 (LISTEN)
    smbd 874 root 35u IPv4 16281 0t0 TCP *:445 (LISTEN)
    smbd 874 root 36u IPv4 16282 0t0 TCP *:139 (LISTEN)
    apache2 924 www-data 3u IPv4 16227 0t0 TCP *:80 (LISTEN)
    librespot 967 pi 20u IPv4 17706 0t0 TCP *:33493 (LISTEN)
    librespot 967 pi 21u IPv4 17707 0t0 UDP *:5353
    librespot 967 pi 23u IPv4 17720 0t0 TCP 192.168.10.100:37508->104.154.126.254:4070 (ESTABLISHED)
    smbd 1037 root 37u IPv4 18656 0t0 TCP 192.168.10.100:445->192.168.10.102:33696 (ESTABLISHED)
    sshd 4623 root 3u IPv4 26935 0t0 TCP 192.168.10.100:22->192.168.10.50:55606 (ESTABLISHED)
    sshd 4646 pi 3u IPv4 26935 0t0 TCP 192.168.10.100:22->192.168.10.50:55606 (ESTABLISHED)

    [email protected]:/home/pi# tail -f /var/log/squeezeboxserver/server.log
    2021-03-15 12:32:08 Logitech Media Server died. Restarting.
    2021-03-15 12:32:13 Logitech Media Server died. Restarting.
    2021-03-15 12:32:18 Logitech Media Server died. Restarting.
    2021-03-15 12:32:23 Logitech Media Server died. Restarting.
    2021-03-15 12:32:28 Logitech Media Server died. Restarting.
    2021-03-15 12:32:33 Logitech Media Server died. Restarting.

    /usr/sbin/squeezeboxserver –prefsdir /var/lib/squeezeboxserver/prefs –logdir /var/log/squeezeboxserver –cachedir /var/lib/squeezeboxserver/cache –charset=utf8 –d_server –debug server

    ERROR: you didn’t tell me how to implement your appender ’server‘ at /usr/share/squeezeboxserver/CPAN/Log/Log4perl/Config.pm line 347.

    Could someone help me solve this problem?

    Thank you very much in advance

    • This reply was modified 4 months, 1 week ago by  Ezaul Zillmer.
    16. März 2021 at 3:09 #50947

    apt –purge remove logitechmediaserver

    rm /usr/share/squeezeboxserver -Rf
    rm /var/lib/squeezeboxserver -Rf

    install Menu Max2play
    http://downloads.slimdevices.com/LogitechMediaServer_v8.1.1/logitechmediaserver_8.1.1_arm.deb

    Resolvido!

    18. März 2021 at 18:12 #50952

    Hi Ezaul,

    I am glad that you were able to solve your problem. The server installation was probably broken.

    23. März 2021 at 12:44 #50971

    I tried to install LMS 8.2 via putting the link in the form – but in the end it always installs LMS 7.9.4 https://downloads.slimdevices.com/nightly/8.2/lms/68ec4e69d55e9746c8d4dee4fa1c74617a5464e9/logitechmediaserver_8.2.0~1616476551_all.deb

    Funny thing is it already did work some weeks ago, but I went back because shairtunes did not work (but now realize this is a problem of iOS 14.5 (beta?)

    23. März 2021 at 18:00 #50986

    Now I even switched to the beta version of Max2Play and choose LMS 8.2 from the list – still it always installs 7.9.4. Inserting the URL manually will be ignored (maybe because it is https instead of http?) https://downloads.slimdevices.com/nightly/8.2/lms/68ec4e69d55e9746c8d4dee4fa1c74617a5464e9/logitechmediaserver_8.2.0~1616476551_all.deb

    25. März 2021 at 14:47 #51030

    Hi justwords,

    I have just tested the installation of LMS v8.2 with our beta image and was able to install the server correctly. Please burn a fresh Max2Play image and install the server again. Maybe there was a problem updating the server. There should be no problems with a fresh installation though. I will report your problem to our developer.

    Edit: The correct link should currently be: http://downloads.slimdevices.com/nightly/./8.2/lms/5ace4941f95fbf9995f25424c24d4c7b4c74d680/logitechmediaserver_8.2.0~1616618635_arm.deb

    • This reply was modified 4 months ago by  MarioM.
    26. März 2021 at 16:01 #51045

    I was notified on LMS that a new version of 8.2 was available so using Max2play beta as normal version 21020 I used the Squeezebox server page as normal dropped down the versions tab and chose 8.2 nightly . This loaded but unlike as normal did not start Squeezebox Server clicking on the start button sent the site working but when it stopped the SQ had not started. I tried 8.1,8.0 and finally 7.9 Nightly and only this version worked and plays music .

    Is there a general issue or is this just me ?

    28. März 2021 at 15:22 #51046

    Still the same issue today notified on LMS that a new version was available . Tried to update to all three 8.0 versions but noe of them worked as although it looked as if they loaded using the normal url link 192.168.1.—:9000 is not able to contact LMS . Any ideas on what the issue is ? A new install 7.9 nightly works .

    29. März 2021 at 14:30 #51049

    Hi Bencat,

    I first installed LMS v7.9 and then v8.2 on a test device (Pi 4, Buster Beta 210202) via our web interface and couldn’t find any problems. Please double check that you are using our latest beta version. Apart from that I can only recommend you to install the server on a fresh Max2Play image. Do you urgently need version 8.xx functions? As long as version 7.9 works for you and you don’t miss any functions that the new versions offer, you don’t necessarily need to update.

    29. März 2021 at 16:37 #51052

    good morning my friend!

    That that would comment on the need to put 8.2 to work ?? here are the changes

    Version 8.2.0

    
    
    New Features:
    Try to group online artists with local artists by ignoring slightly different spelling (eg. "The Beatles" vs. "Beatles", "Amy Macdonald" vs. "Amy MacDonald").
    a href="https://github.com/Logitech/slimserver/pull/537">#537 - Add audio option to combine channels to build a mono signal (whether player is synchronized or not).
    a href="https://github.com/Logitech/slimserver/pull/538">#538 - Add Balance setting for players which support it (thanks philippe44!).
    
    Server Changes:
    When an online scan doesn't return any track, but previously had some, do not remove tracks from library. The empty new list is likely due to a scan failure.
    Try to improve backwards compatibility with eg. Erland's plugins, which sometimes struggle with the remote tracks.
    #411 - Transcoder conversion rules: Support resampling for Ogg/Flac streams (thanks bpa/mw9!)
    
    Platform Support:
    #18 - Add a systemd service file for Debian based systems (thanks mw9 & tomscytale).
    #22 - Add systemd service configuration for RPM based systems (thanks JohanSaaw!)
    #526 - Add Perl 5.32 and 5.30 support for Linux aarch64 platform. (thanks clivem!)
    Remove Font::FreeType from Linux distributions. It's easy enough to install it using the system's package manager, and it would conflict on system where we don't provide the binary.
    
    Bug Fixes:
    #554 - Long current playlist disappears from UI during wipe and rescan.
    
    Other:
    #528 - On Unix-like platforms, we now ensure that plugins are installed in such a way that none of their files are writable by users other than the user running LMS, even if theyʼre stored that way in the plugin ZIP file.

    Bencat57 and as MarioM already said you are having a problem with your installation … redo your card and install the version of Logitech Media Server that you want through the Max2play control pane

    • This reply was modified 3 months, 3 weeks ago by  Ezaul Zillmer.
    10. Mai 2021 at 17:12 #51221

    I have now noticed that without doing anything the links for the nightly 8.2 updates have started to appear again and they are now working as they used to .

    Please note that this is using the same SD card image that was not able to do this in the thread I mentioned before. So presume that something has been changed in which case it would always be nice if this could be mentioned in these threads so that those like myself were only being allowed to use a single instance of LMS and not able to update that can now update easily as was the case before.

    11. Mai 2021 at 17:53 #51234

    I’ve noticed the same thing – if I set my LMS up to autodownload updates it puts them in
    /var/lib/squeezeboxserver/cache/updates/

    But the way the updater in Max2Play works, is that it downloads from the repo and puts it in
    /opt/max2play
    and renames it as lms.deb

    If I try to paste in the latest repo version in max2play, it ignores it and continues to just install lms.deb over itself

    So I either have to run

    dpkg -i /var/lib/squeezeboxserver/cache/updates/logitechmediaserver_8.2.0~1620630276_arm.deb

    from the command line

    or I have to manually copy logitechmediaserver_8.2.0~1620630276_arm.deb to opt/max2play and rename it as lms.deb
    then the upgrader runs from the max2play GUI ok

    11. Mai 2021 at 17:57 #51235

    I have now noticed that without doing anything the links for the nightly 8.2 updates have started to appear again and they are now working as they used to

    I’m on Max2play 2.53 and I only get the links for 7.9 and 8.0 in the drop down

    12. Mai 2021 at 11:37 #51238

    Hi Bobby,

    To view all versions of the LMS, please update Max2Play to the latest version or do a beta update.

    12. Mai 2021 at 11:44 #51239

    Thanks – i’m on 2.53 and it says that is the latest

    How do i update to a beta version?

    18. Mai 2021 at 14:05 #51263

    Hi Bobby,

    To update Max2Play to the latest beta version you need a Max2Play Premium membership. You can purchase this in our store. Otherwise, all Squeezebox Server versions should still be displayed in version 2.53. If it is not too much trouble, I would recommend you to burn Max2Play on the SD card and then update it again.

Viewing 20 posts - 1 through 20 (of 20 total)

You must be logged in to reply to this topic.

Register here