updating kodi

This topic contains 31 replies, has 18 voices, and was last updated by  Christoph premium 1 month, 1 week ago.

Viewing 30 posts - 1 through 30 (of 32 total)
  • 16. September 2015 at 20:02 #15717

    Recently Kodi told me that 15.1 is available. Is it possible to update the Kodi that is installed on max2play?
    What is the best procedure for that?

    21. September 2015 at 15:26 #15756

    Hi waterdrinkingman,
    You can update your version of Kodi in the Webinterface-tab “Kodi” under the section “Kodi / XBMC start installation – Replaces current Version…”. Just paste the URL for the Kodi installation you desire (must be the .deb package link) and click on “Kodi/XBMC start installation”

    21. September 2015 at 22:46 #15767

    where could i find a .deb URL which will be compliant with this rapsbian/squeezeplug/max2play distrib ?

    22. September 2015 at 16:53 #15772

    The update capability is currently only working on the Max2Play Odroid Images. Sorry for the misunderstanding. When we have implemented Kodi 15.1 for Raspberry Pi, we will announce it.

    2. November 2015 at 11:33 #16675

    @Heiner: I hope you can step up your efforts of updating the Kodi version in the RP Max2Play image. Kodi 15.2 has been stable for most platforms for some time, and 16.0 is coming quickly (alpha 4 is already out). Major Kodi addons start having problems with the Max2Play version (14.x). One of the key reasons why I paid for Max2Play was the possibility of easily switching between Kodi and Squeezplug – seems I’m about to loose this feature soon …

    3. November 2015 at 18:02 #16753

    Hi malohm,
    We now have the capacity to update to Kodi 15. When your version of Max2Play is up to date (version 2.24) you can see in the Kodi-menu under the option start installation an URL for update (http://steinerdatenbank.de/software/kodi-15.tar.gz). Just click the “start installation”-button and your version of Kodi will be updated.

    4. November 2015 at 20:03 #16780

    Thanks Heiner – this worked!

    5. November 2015 at 19:47 #16784

    Hi,

    im an user of kodi on pi2. Til yesterday im am using kodi 16 beta openelec builds. These builds made it possible to play 3d mvc files and isos by my omv mediaserver.

    Today i have bougt the full licence of max2play because i want the pi2 as logitechmediaserver and player for music with media files by an extern 2,5 inch hdd instead of playing the music starting the big omv server with several 4 TB Hdd.

    But an problem occurs with the kodi version you have integrated in max2play. After updating to latest max2play beta version kodi shows 15.1 as his own version. And here it is impossible to see an option for activating 3d mvc. Please update your kodi version to 15.2 or even better for the customers who like kodi beta versions to 16 alpha.

    Kind Regards

    Gerald Paul

    6. November 2015 at 0:03 #16785

    please help Installationspaket: http://steinerdatenbank.de/software/kodi-15.tar.gz
    Installation startet – This Messages refreshes every 3 seconds to show current status of installation. If finished this message disappears.
    27250K ………. ………. ………. ………. ………. 97% 1007K 0s
    27300K ………. ………. ………. ………. ………. 98% 32.1K 0s
    27350K ………. ………. ………. ………. ………. 98% 7.76M 0s
    27400K ………. ………. ………. ………. ………. 98% 7.15M 0s
    27450K ………. ………. ………. ………. ………. 98% 7.55M 0s
    27500K ………. ………. ………. ………. ………. 98% 6.64M 0s
    27550K ………. ………. ………. ………. ………. 98% 8.48M 0s
    27600K ………. ………. ………. ………. ………. 99% 6.64M 0s
    27650K ………. ………. ………. ………. ………. 99% 6.25M 0s
    27700K ………. ………. ………. ………. ………. 99% 8.84M 0s
    27750K ………. ………. ………. ………. ………. 99% 790K 0s
    27800K ………. ………. ………. ………. ………. 99% 710K 0s
    27850K ………. ………. ………. ………. ………. 99% 726K 0s
    27900K ……. 100% 3.57M=20s

    2015-11-04 22:43:00 (1.37 MB/s) – `/opt/max2play/xbmc.deb’ saved [28577012/28577012]

    dpkg-deb: error: `/opt/max2play/xbmc.deb’ is not a debian format archive
    dpkg: error processing /opt/max2play/xbmc.deb (–install):
    subprocess dpkg-deb –control returned error exit status 2
    Errors were encountered while processing:
    /opt/max2play/xbmc.deb
    Installation abgeschlossen
    rm: cannot remove `/usr/lib/arm-linux-gnueabihf/mesa-egl/’: No such file or directory
    finished

    Installation abgeschlossen!
    steinerdatenbank.de
    steinerdatenbank.de
    wath is wronge
    Version 2.22
    Raspberry Pi max2play
    11 uur geleden

    Seems like you ran out of free memory on your sd-card. Make sure to expand the filesystem (on settings page) before running any installations. You see the free space on the bottom of the settings page.
    5 uur geleden
    ### FILESYSTEM ####
    Filesystem 1K-blocks Used Available Use% Mounted on
    rootfs 3663692 2366612 1113848 68% /
    /dev/root 3663692 2366612 1113848 68% /
    devtmpfs 218604 0 218604 0% /dev
    tmpfs 44576 472 44104 2% /run
    tmpfs 5120 0 5120 0% /run/lock
    tmpfs 89140 0 89140 0% /run/shm
    /dev/mmcblk0p1 57288 14736 42552 26% /boot

    #### LOAD AVERAGE ####
    0.18 0.09 0.12 1/80 31590

    #### KERNEL ####
    Linux max2play 3.18.7+ #755 PREEMPT Thu Feb 12 17:14:31 GMT 2015 armv6l GNU/Linux

    #### LINUX-VERSION ####
    Distributor ID: Debian
    Description: Debian GNU/Linux 7.8 (wheezy)
    Release: 7.8
    Codename: wheezy
    i use a 8 gig sd cart
    this program dont use it all left 4 gig that it not use

    Make sure before connecting any usb devices or other storages to click “Expand Filesystem” on settings page and reboot. After this the whole SD card is available.
    Ok wil try that and if i buy the program is that only a key so that i get the premium
    http://steinerdatenbank.de/software/kodi-15.tar.gz after update kodi dont start
    steinerdatenbank.de
    steinerdatenbank.de
    ongeveer een uur geleden
    Installationspaket: http://steinerdatenbank.de/software/kodi-15.tar.gz
    Installation startet – This Messages refreshes every 3 seconds to show current status of installation. If finished this message disappears.
    — Generating done
    — Build files have been written to: /opt/kodi-platform
    [100%] Built target kodiplatform
    sudo: unable to resolve host max2play
    [100%] Built target kodiplatform
    Install the project…
    — Install configuration: “”
    — Up-to-date: /usr/local/lib/libkodiplatform.so.15.1.0
    — Up-to-date: /usr/local/lib/libkodiplatform.so.15.0
    — Up-to-date: /usr/local/lib/libkodiplatform.so
    — Up-to-date: /usr/local/include/kodi/util/XMLUtils.h
    — Up-to-date: /usr/local/lib/pkgconfig/kodiplatform.pc
    — Up-to-date: /usr/local/lib/kodiplatform/kodiplatform-config.cmake
    Reset Compiler to first version
    There are 2 choices for the alternative gcc (providing /usr/bin/gcc).

    Selection Path Priority Status
    ————————————————————
    0 /usr/bin/gcc-4.6 60 auto mode
    1 /usr/bin/gcc-4.6 60 manual mode
    * 2 /usr/bin/gcc-4.7 40 manual mode

    Press enter to keep the current choice[*], or type selection number: update-alternatives: using /usr/bin/gcc-4.6 to provide /usr/bin/gcc (gcc) in auto mode
    Click here to reload Page
    finished

    Installation abgeschlossen!
    steinerdatenbank.de
    steinerdatenbank.de
    Trying to launch … successful with ID 11327
    Status: Kodi / XBMC not running
    not work
    it not start

    6. November 2015 at 14:00 #16788

    Hi Amsnl,
    It seems you forgot to expand your filesystem. Please burn a fresh image and expand your filesystem under “Settings/Reboot” to be able to use the full 8GB of your memory card and properly install Kodi.

    9. December 2015 at 13:05 #17193

    Hi There,
    Kodi isn’t starting anymore after the 15.1 update with the Pi B with wolfson soundcard, LMS and Squeezelite running.
    I try to start Kodi from the website but the service is not starting:

    Kodi / XBMC – Status, Start & Stop
    Versucht zu starten … Erfolgreich mit ID 4795
    Status: Kodi / XBMC läuft nicht

    I have tried the same update with the Pi B+ without Wolfson and LMS (Only Squeezelite running) and Kodi isn’t starting either.
    It is the 2.25 version of max2play wihtout any changes.(apart from expanding the SD-card and wifi settings).

    Has anyone the same problem? Or knows how to fix it?

    9. December 2015 at 13:48 #17194

    update: When I tick the “Aktualisieren der HDMI-Ausgabe”, it still doesn’t work but then comes the login page for the Desktop.
    I tried to login with “Kodi” (login:pi pass:raspberry) but it failed. Then I tried to login with “Defaut Xsession” and that works.
    I can see Kodi under Menu/sound&video but it won’t start.
    (My Monitor is connected via HDMI/DVI adaptor and I can’t test with a pure HDMI connection but never had issues)

    9. December 2015 at 13:57 #17195

    I found a kodi crashlog in the /home/pi folder. there is quite a lot of text, can I attach it here somehow?

    • This reply was modified 12 months ago by  kremat.
    11. December 2015 at 17:29 #17291

    Hi kremat,

    it is not possible to attach files to posts, sorry. Just paste your crashlog into this topic. What is logged in “DEBUG info” in the Max2Play Kodi interface (end of menu)?

    Basically, running Squeezelite and Kodi at the same time does not work regardless of which Kodi version is installed. On my test system (with HiFiBerry DAC+, M2P 2.25), I cannot start Squeezelite successfully as long as Kodi (15.1) is running as expected. The other way round, Max2Play automatically stopps Squeezelite when starting Kodi. It works perfectly fine.

    Maximilian from Max2Play

    22. December 2015 at 12:59 #17459

    Hi,
    I know that both at the same time are not working and it is working like a charm with Wheezy (14.2)… squeezeplug is stopping, xmbc starts perfectly and after I stop it, squeezeplug starts playing music again.
    But Kodi/XBMC is not staring after the update to 15.1…
    apparently I’m the only one with this problem….I will leave it on 14.2 though.

    26. December 2015 at 3:48 #17483

    Hello

    thx for M2P i give a new try this week and it’s perfect for my needs.

    Like kremat, i can’t use kodi 15.1, i stay with 14.2.

    I dig later for install IPTV in this version.

    19. January 2016 at 12:23 #17997

    How do I update kodi to 15.2 on rpi with max2play?

    23. January 2016 at 22:10 #18107

    Hi,

    it seems that the current M2P version 2.27 has problems to install KODI 15.1 also on a fresh and expanded OS on a RPI1.
    The only chance I had to solve it was to install/update it manually by removing/solving a dependency problem with
    “apt-get update”
    “apt-get install kodi”
    “apt-get -f install”
    “apt-get autoremove”
    After this KODI (15.2) started successfully.

    Maybe this information can be used to fix the current setup.

    Cheers,
    Sandman60

    24. March 2016 at 8:18 #19444

    @sandman60:

    Thanks very much! This work for me.

    20. April 2016 at 10:22 #19852

    Olé!
    That works like a charm!
    Thanks a million mister sandman!

    23. April 2016 at 17:20 #19920

    You are welcome. THX for the feedback. Hopefully this workaround will take place in one of the next updates.
    Cheers,
    Sandman

    25. April 2016 at 14:14 #19943

    Hi guys,
    Our current Jessie Image has Kodi 2:15.2-2~jessie.
    The installation protocol should work as well, depending on the source package you use for installation.

    edit: We also took out the preset download link that would not be working with the Jessie-Image to prevent further confusion.

    • This reply was modified 7 months, 1 week ago by  Heiner.
    26. April 2016 at 23:41 #19982

    beim Versuch auf Kodi 15.1/2 zu upgraden hatte ich leider keinen Erfolg.
    War ich zu voreilig? Ich hatte im Forum als Download Link die Steinerdatenbank reinkopiert,
    existiert aber nicht?

    Welche andere URL könnte ich für die aktuellste Kodiversion nehmen?

    Danke für die Hilfe,

    Volker

    12. May 2016 at 12:25 #20097

    Hallo Volker,
    Die aktuellen Images haben die aktuelle Version von Kodi 15.2-2 vorinstalliert. Momentan gibt es noch keine Möglichkeit eine neuere Version zu installieren, weshalb das Feld für diese URL aktuell leer steht. Sobald es eine neuere kompatible Version gibt, werden wir diese umgehend dort einbringen.

    12. May 2016 at 12:35 #20098

    Will the next version (16.1) also be available for wheezy-images?

    12. May 2016 at 14:00 #20105

    Kodi 16.1 jessie binaries are here: http://pipplware.pplware.pt/pipplware/dists/jessie/armv7/binary/
    (didn’t have time to try on Max2Play yet … anybody else?)

    15. May 2016 at 10:14 #20146

    Hallo,
    ich habe bei der Version 2.31 für meinen Pi2 ein Update von Kodi auf 15 versucht. Leider hat dies nicht geklappte, ich finde aber auch keine URL im WWW für eine neue Intall-Datei.
    Wie bekomme ich das System wieder zum laufen?
    Der Link von der Steinerdatenbank funktioniert (s.oben) funktioniert leider nicht..

    Dank euch..

    25. May 2016 at 16:18 #20279

    Hallo Thomy,
    Der Link wurde aus aktuellen Versionen von Max2Play entfernt. Wir empfehlen die installierte Version zu nutzen und werden euch natürlich darüber informieren wenn eine neue Version in einem Update enthalten ist.

    20. September 2016 at 2:07 #23107

    Hallo Heiner,
    es wäre wirklich schön, wenn Ihr Kodi V16.X nun auch in den packages für den Raspberry Pi implementieren würdet und nicht nur für die Odroid Platform (xu4) bereithaltet.

    Liebe Grüße,
    Klaas

    11. October 2016 at 21:54 #23377

    Hallo Heiner,

    hat sichbezüglich dieses Themas etwas getan?
    Kodi 16 wär schon schön…. 🙂

    Beste Grüße

Viewing 30 posts - 1 through 30 (of 32 total)

You must be logged in to reply to this topic.

Register here