Unable to connect to WiFi

This topic contains 2 replies, has 2 voices, and was last updated by  Heiner Moderator 2 weeks, 1 day ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • 8. Juni 2019 at 17:33 #45639

    I don’t recall having any issues in the past with a Raspberry Pi 3 Model B but I have since re-purposed that and am trying to set up M2P on some Raspberry Pi 3+ Model A and I cannot get it to save the WiFi config. I connect to it via it’s AP mode, connect to it’s IP directly (192.168.189.1) as DNSMasq does not seem to provide an IP for the suggested http://max2play address but every option I attempt to change to the wireless settings results in it coming back up with a failure (Incomplete, deleting file). I’ve tried setting the WiFi via wpa_supplicant.conf, via raspi-config but it still does not want to connect. I also tried using it’s loopback and configuring it with a keyboard and mouse connected to a screen and still achieve the same results (except one time it saved for no apparently different reason but I was unable to replicate).
    The message in the web GUI is:

    Setup WiFi Started
    
    2019-03-29 13:29:05|
    Device "eth0" does not exist.
    Disable Accesspoint
    ifdown: interface wlan0 not configured
    0
    OK
    OK
    OK
    OK
    OK
    OK
    No IP-Address could be received - WiFi NOT working correctly. Please check Network-ID and Passphrase!
    ifdown: ignoring unknown interface wlan0=wlan0
    OK
    OK
    WiFi detected
    Restarting hostapd (via systemctl): hostapd.service.
    Restarting dnsmasq (via systemctl): dnsmasq.service.
    Finished Please Click here Reload Page!

    I checked my WiFi logs and for some reason it seems to not be connecting and generating some weird traffic in the process:

    Jun 7 15:40:45.330	Debugging	Station b827.ebd4.e49d Authentication failed
    Jun 7 15:40:42.326	Information	Interface Dot11Radio1, Deauthenticating Station b827.ebd4.e49d Reason: Sending station has left the BSS
    Jun 7 15:40:34.238	Warning	Client b827.ebd4.e49d had 1 AES-CCMP TSC replays
    Jun 7 15:40:15.630	Warning	Client b827.ebd4.e49d had 1 AES-CCMP TSC replays
    Jun 7 15:40:05.627	Warning	Client b827.ebd4.e49d had 1 AES-CCMP TSC replays
    Jun 7 15:39:56.624	Warning	Client b827.ebd4.e49d had 1 AES-CCMP TSC replays
    Jun 7 15:39:41.619	Warning	Client b827.ebd4.e49d had 1 AES-CCMP TSC replays
    Jun 7 15:39:39.778	Information	Interface Dot11Radio1, Station b827.ebd4.e49d Associated KEY_MGMT[WPAv2 PSK]

    Despite the GUI logs saying it can’t get an IP address, no requests are hitting the DHCP service on my network (Except for the one time).
    I don’t know if this is a RPi 3+ thing or a M2P thing causing my issue but I also noted that the script M2P is using is using the now depreciated ifdown ifup commands.

    11. Juni 2019 at 2:42 #45645

    After some more investigation it seems the scripts are not running correctly.
    If I manually run the script /var/www/max2play/application/plugins/accesspoint/scripts/uninstall_accesspoint.sh it removes the AP mode and upon rebooting I can manually enter the WiFi details and have it connect. The problem I am now having is that they do not seem to be applying for all other settings too so I cannot apply settings under Rasberry Settings such as the sound card, CPU/GPU, Bluetooth, etc.
    The same thing occurs with all other settings. After about 3 attempts it decided to take a static IP change that persisted after a reboot but I have no idea why these aren’t running. Apache is running as root so there should be no permissions reason these scripts aren’t running.
    Any suggestions?

    12. Juni 2019 at 10:15 #45675

    Hi justinj,

    Thanks for sharing this issue in such detail. I will try to recreate it and discuss it with our head developer.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.

Register here