Unable to connect to max2play web interface

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Unable to connect to max2play web interface

This topic contains 23 replies, has 7 voices, and was last updated by  phants 2 days, 20 hours ago.

Viewing 24 posts - 1 through 24 (of 24 total)
  • 8. April 2016 at 13:19 #19709

    Hi

    I have a Raspberry pi 2 with max2play (I can’t currently determine which version).
    All is functioning normally (Logitech media server, Jivelite, Kodi and ssh) but I am unable to access the Max2play web interface. http:// max2play (error: max2play’s server DNS address could not be found.) or by http://192.168.1.45 (192.168.1.45 refused to connect.) http://192.168.1.45:9000 works normally to give the Logitech Media Server.
    This may have happened as a result of my doing an ‚apt-get update‘ and ‚apt-get upgrade‘ via ssh, though it didn’t seem to happen immediately). I did this because the web interface informed me that a new version of max2play was available and invited me to upgrade. However each time I tried that using the web interface the screen ended with the error message ‚upgrade failed‘.)
    I noticed when I did sudo apt-get upgrade that certain packages were held back (kodi libcec3 lxpanel lxpanel-data nuscratch raspberrypi-ui-mods) . I have tried ’sudo reboot‘
    Can anyone advise me how to get the web interface back? I am reluctant to reinstall max2play again from scratch as the current system is otherwise working well and took a while to set up. I was however hoping to turn on turbo mode via the web interface.

    Any advice gratefully received.

    Thanks

    • This topic was modified 2 years, 9 months ago by  chuby57.
    9. April 2016 at 11:04 #19720

    Further information: Running `sudo ./update_max2play.sh via ssh gives the following output

    Get Data
    --2016-04-09 10:54:53--  http://shop.max2play.com/media/downloadable/currentversion/webinterface.zip
    Resolving shop.max2play.com (shop.max2play.com)... 104.28.29.89, 104.28.28.89, 2400:cb00:2048:1::681c:1c59, ...
    Connecting to shop.max2play.com (shop.max2play.com)|104.28.29.89|:80... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: unspecified [application/zip]
    Saving to: 

    /opt/max2play/cache/webinterface.zip‘

    [ <=> ] 764,795 921K/s in 0.8s

    2016-04-09 10:54:54 (921 KB/s) – `/opt/max2play/cache/webinterface.zip‘ saved [764795]

    –2016-04-09 10:54:54– http://shop.max2play.com/media/downloadable/currentversion/scripts.zip
    Resolving shop.max2play.com (shop.max2play.com)… 104.28.28.89, 104.28.29.89, 2400:cb00:2048:1::681c:1d59, …
    Connecting to shop.max2play.com (shop.max2play.com)|104.28.28.89|:80… connected.
    HTTP request sent, awaiting response… 200 OK
    Length: unspecified [application/zip]
    Saving to: `/opt/max2play/cache/scripts.zip‘

    [ <=> ] 910,030 662K/s in 1.3s

    2016-04-09 10:54:56 (662 KB/s) – `/opt/max2play/cache/scripts.zip‘ saved [910030]

    Install Webinterface
    Inconsistency detected by ld.so: dynamic-link.h: 190: elf_get_dynamic_info: Assertion `info[20]->d_un.d_val == 17 || info[20]->d_un.d_val == 7′ failed!
    Install Scripts
    Inconsistency detected by ld.so: dynamic-link.h: 190: elf_get_dynamic_info: Assertion `info[20]->d_un.d_val == 17 || info[20]->d_un.d_val == 7′ failed!
    rm: cannot remove `/etc/init/whoopsie.conf‘: No such file or directory
    rm: cannot remove `/etc/rsyslog.d/50-default.conf‘: No such file or directory
    crontab: user `odroid‘ unknown
    crontab: user `odroid‘ unknown
    Factory Settings available
    OK
    usermod: user ‚mpd‘ does not exist
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    lsb-release is already the newest version.
    ntfs-3g is already the newest version.
    The following packages were automatically installed and are no longer required:
    libvncserver0 tcl tk x11vnc-data
    Use ‚apt-get autoremove‘ to remove them.
    0 upgraded, 0 newly installed, 0 to remove and 6 not upgraded.
    Get Plugin from http://shop.max2play.com/media/downloadable/beta/squeezeplug.tar
    Load Plugin from tar
    –2016-04-09 10:55:01– http://shop.max2play.com/media/downloadable/beta/squeezeplug.tar
    Resolving shop.max2play.com (shop.max2play.com)… 104.28.29.89, 104.28.28.89, 2400:cb00:2048:1::681c:1c59, …
    Connecting to shop.max2play.com (shop.max2play.com)|104.28.29.89|:80… connected.
    HTTP request sent, awaiting response… 200 OK
    Length: unspecified [application/x-tar]
    Saving to: `/opt/max2play/cache/plugin.tar‘

    [ <=> ] 215,040 389K/s in 0.5s

    2016-04-09 10:55:02 (389 KB/s) – `/opt/max2play/cache/plugin.tar‘ saved [215040]

    Installing Plugin squeezeplug
    Install successful
    Copy custom header files
    mkdir: cannot create directory `/var/www/max2play/public/addons/squeezeplug‘: File exists

    14. April 2016 at 15:22 #19778

    Hi chuby,

    the Webserver (apache) may not be running due to the performed „apt-get upgrade“ command. You may check for an error on start of apache by starting it manually by entering „sudo /etc/init.d/apache2 start“ and checking config files with „apache2ctl configtest“. If this doesn’t help I suggest a complete reinstall (start with a new sd-image).

    14. April 2016 at 15:53 #19780

    Hi flysurfer

    Thanks for your reply. I decided to follow the second suggestion and reinstall with a new sd-image downloaded from the Download link. I have set everything up as before and all works well. I still have the “ Max2Play update is available – start update on tab Settings / Reboot“ message on the Start page. Is it safe/necessary to try it? I wouldn’t want to have to set everything up again. What is the best option for backing up my installation before trying it?

    14. April 2016 at 16:10 #19783

    Hi chuby,
    The update message refers to Max2Play’s internal update, meaning the Update-Button in the „Settings/Reboot“ menu. This update procedure is totally safe and can be done without any risk. However, if you do want to back up your image, just use a simple tool like the Win32DiskImager, insert your configured SD card in your PC, find it in the DiskImager and click „Read“ to create an .img-file which you can then use to replicate your image.

    15. April 2016 at 11:55 #19787

    Hi Hiener

    Thanks for the advice. The update worked fine this time. Everything functions perfectly.

    Just for information I am a linux user and used the SD image backup advice on this page
    https://www.raspberrypi.org/documentation/linux/filesystem/backup.md
    and produced an approximately 4G file. I haven’t tried restoring it though!

    21. Oktober 2017 at 11:43 #32031

    I have a similar issue…but I can’t connect through SSH either….“connection refused“…any ideas?

    24. Oktober 2017 at 12:15 #32056

    Hi okenny,

    What login did you try? user: pi pw: raspberry with default RPi image

    Have you tried accessing the web interface with the device’s IP from your router’s web interface?

    24. Oktober 2017 at 13:36 #32067

    yep, tried from several devices. I get connection refused with SSH, does not even allow me to type in my PW. My other clients are working fine.

    24. Oktober 2017 at 14:06 #32071

    So, there is no device in your router’s list named max2play? If so, you need to burn a fresh image as this one does not seem to boot correctly.

    24. Oktober 2017 at 14:23 #32073

    yep, the ip adress is there….I also suspect SD card problem. I will make a new image.

    BTW – I have 8 Raspis (5 of which for Squeezelite), SD card reliability is the biggest problem. Netboot or something else is badly needed to solve that issue. I considered moving to SONOS due to the issues which I have had…

    25. Oktober 2017 at 9:30 #32084

    Hi okenny,

    For your player Pi’s, you can use our write protection plugin.

    Further, you can add shutdown commands for all devices as http-requests (shown in the voice control beta plugin) to safely shut down any systems you want to remove from their power supply.

    This should add a lot of longevity to your SD cards. We have devices running here for multiple years, nearly without any interruption.

    Another important factor is the speed and quality of the card itself. We recommend using nothing below Class 10.

    25. Oktober 2017 at 9:38 #32085

    great advice, thank you Heiner
    I have tried the write protection plugin before but I found it rendered my raspi inoperative once or twice (straight after reboot raspi stopped responding), not sure if it was coincedence or something was wrong. Was there even such an issue reported to you?

    25. Oktober 2017 at 10:59 #32095

    Hi okenny,

    A few plugins need access to the SD card and make the write protection inoperable. The Squeezebox Server is one such example.

    Which plugins are you using on the raspi in question?

    25. Oktober 2017 at 11:12 #32096

    Oh I don’t remember, my server runs on an x86 machine so it wasn’t that. I’ll try again with as few plugins as possible. Thank you.

    27. Oktober 2017 at 3:57 #32140

    Looks like there might be a bigger issue, as I am experiencing the same symptoms. I can access LMS via port 9000 but not max2play directly. I did try restarting apache with no success. see below

    [email protected]:~$ sudo /etc/init.d/apache2 start
    Starting apache2 (via systemctl): apache2.serviceWarning: Unit file of apache2.service changed on disk, ’systemctl daemon-reload‘ recommended.
    Job for apache2.service failed. See ’systemctl status apache2.service‘ and ‚journalctl -xn‘ for details.
    failed!
    [email protected]:~$ sudo systemctl daemon-reload
    [email protected]:~$ sudo /etc/init.d/apache2 start
    Starting apache2 (via systemctl): apache2.serviceJob for apache2.service failed. See ’systemctl status apache2.service‘ and ‚journalctl -xn‘ for details.
    failed!
    [email protected]:~$

    27. Oktober 2017 at 13:29 #32157

    Hi sfraser,

    Please check your router’s web interface for the IP of your device, enter it into any browser, change the name of your device in Settings/Reboot, reboot and try accessing that name.

    Your issue is most likely not related to apache.

    27. Oktober 2017 at 15:37 #32160

    Hi, i always use the IP address of the node to access the node. Is there any reason why it should not work with ip address vs the host name?

    Thanks for your help,

    Scott

    30. Oktober 2017 at 12:45 #32180

    Hi Scott,

    No there should not be any issue. However, since you cannot access the Max2Play web interface right after the first boot, something has to be wrong. However, apache is most likely not related to it.

    If yo have not yet, please try burning a fresh image and immediately check whether you can access the Max2Play web interface.

    2. Dezember 2018 at 6:59 #42468

    I’m having the same problem

    Raspberry Pi can't access Max2Play web interface

    I have re-imaged a couple times, everything works until Max2Play reboots. then I got nothing for web access. LMS still sees and controls the player.

    4. Dezember 2018 at 16:06 #42537

    Hi radiomog,

    The Raspberry Pi has the Max2Play web interface on it. When connected to your local network, you can access the web interface from any other device with a browser. Just type „max2play/“ in your smartphone, tablet or PC.

    12. Januar 2019 at 18:22 #43556

    I am running MAX2PLAY on a Pi Zero with a write protected SD card.

    I now have the same problem. My player works OK streaming music from iTunes but all of a sudden I can’t access the web interface using either the device name or IP address. Curiously it appears on my router with the device name „localhost“ – this is DEFINITELY the Pi.

    I have no access to diagnostic info as I am running on a Pi Zero embedded in a portable speaker. I have no access to the HDMI port without a complete strip down. For the same reason, flashing a new SD card will be a real pain.

    14. Januar 2019 at 16:07 #43603

    Hi phants,

    Firstly, try making a backup of your current image with an image software or our image burner plugin.

    Does the localhost have the same IP and if so, does the url „localhost/“ get you access to any interface?

    Also, does your system run 24/7 or do you shut down the Pi? If so, do you click „shutdown“ in the webinterface before doing so? While the write proctection does make your card more robust, continuous manual shutdowns might still damage it.

    14. Januar 2019 at 21:55 #43636

    I don’t run 24/7 but generally do shutdown properly. I had hoped that a read only SD card would give me some protection from corruption. Recently I have not been able to shutdown because I cannot access the web interface and so have to pull the power plug.

    Localhost has the correct ip for the Pi but I cant connect with /localhost

    The last update I made was a change to fix the lack of Internet connection and then updated to the latest version. It was since then that the problem occurred. I cant remember what I changed but I think I added GOOGLE DNS,

    Looks like I will have to get my screwdriver out, pull things apart and create a new SD.

Viewing 24 posts - 1 through 24 (of 24 total)

You must be logged in to reply to this topic.

Register here