Unable to access device once wireless is configured

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Unable to access device once wireless is configured

This topic contains 2 replies, has 2 voices, and was last updated by  Heiner Moderator 3 years, 4 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • 31. Mai 2018 at 5:15 #35987

    I’m new to M2P, so I may not be doing something correctly, but I’m trying to use wifi exclusively on a headless Raspberry Pi with M2P 2.45 and upgrading to 2.46. With either version, as soon as I configure wireless, power off and unplug the LAN, as soon as I power back on I can no longer access the wifi interface. Also, if I plug in Ethernet again I also cannot access the device via that interface. What I have learned when I plug in a monitor and keyboard is the device has an IP, however I cannot ping it, nor can I SSH to it and the web interface does not work either, but I can do commands like aut-get update and apt-get upgrade, so I know it has internet access. I can do ifdown and ifup and receive a new IP, however I still cannot access the device. I have also tried completely rebuilding /etc/network/interfaces with a basic configuration with no luck, the device acts like it has a firewall installed.

    Here are the basic steps to reproduce the issue on either an RPi 3B or 3B+
    1. Load SD with 2.45 image and boot via Ethernet
    2. Configure for HifiBerry at start screen
    3. go to settings insert email address and change locale – reboot
    4. go to LAN/Wifi settings, enable and enter the SSID and passphrase for WPA2 network- save – at this point both wireless and Ethernet interfaces work and are accessible
    5. shutdown from settings tab, unplug ethernet, power on
    6. device is no longer accessible

    My configuration is as follows:

    Raspberry Pi 3B and 3B+
    M2P 2.45 image and 2.46 via upgrade
    Patriot 32GB memory card
    HifiBerry DAC+ Pro

    Please help and/or advice would be appreciated.

    Thanks,

    -Stuart

    31. Mai 2018 at 6:34 #35988

    I believe I have figured out the issue, turn off bluetooth, an option to get the HifiBerry DAC+ Pro to work properly, apparently adversely affects network….

    31. Mai 2018 at 16:47 #36001

    Hi Stuart,

    Thanks for the update, I will try to recreate this issue here.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.

Register here