Ubuntu 16.04 LTS on odroid-XU4

This topic contains 7 replies, has 2 voices, and was last updated by  bobertuk premium 2 months, 1 week ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • 3. August 2016 at 12:16 #21983

    Now that Odroid have a fully functioning Ubuntu 16.04 LTS (which is very stable) running on their sbc computers have you any plans to move to it from Ubuntu 15.04? The biggest reason I can see for doing this is that 16.04 has long term support (5 years) whereas 15.04 and 15.10 are no longer supported by Odroid or Cannonical. Particularly important as these systems are open to the Internet. I have tried installing max2play from GitHub onto the odroid Ubuntu 16.04 LTS image but with no success after following your GitHub instructions.

    I do not have sufficient knowledge of max2play to work out where the problems are but did manage to find and successfully install apache2, php5 and php5-json (Ubuntu 16.04 runs php7)

    16.04 uses perl 5.22 but perlbrew allows use of older perl versions so that shouldn’t be an issue.



    8. August 2016 at 17:28 #22085

    Hi Bob,

    there might be some problems due to php7 and some config file changes. LMS as nightly build comes only with Perl 5.20 support for ARM, so this libraries need to be build.

    I will have a look at the Max2Play installer script and see if I can fix it to work on Ubuntu 16.04 once I find the time for it.

    9. August 2016 at 14:27 #22099

    I updated the installer script for Max2Play to work with ODROID Ubuntu 16.04. There are still some other issues due to the new Ubuntu version that need to be addressed within the web interface of Max2Play, but the basic installation is working.

    I will publish a Max2Play-Version for the ODROID XU4 and Ubuntu 16.04 in our Download section within the next week.

    9. August 2016 at 14:39 #22101

    Hi flysurfer,

    Many thanks for looking into this. Michael Herager (squeezebox forum) has said he put resources for perl 5.22 into LMS but I don’t know if he has done so for ARM or for 32 bit. I look forward to giving your Ubuntu 16.04 LTS image a try when it’s ready.

    Again, many thanks


    9. August 2016 at 18:13 #22125

    I just finished building the CPAN resources for ARM and Perl 5.22. Michael normally doesn’t build the arm binaries as he has no Pi/Odroid.

    I also adjusted the LMS-Installer Script (in BETA of Max2Play) to fetch the compiled sources from our server and put them into the right place…

    If you like, you may use the installer script for Max2Play -> update to latest Beta with Web interface -> intall LMS via Web interface… no guarantee, but this should work – I will test it tomorrow with a fresh install.

    • This reply was modified 2 months, 1 week ago by  flysurfer.
    11. August 2016 at 19:36 #22217

    Hi flysurfer,

    I re-imaged an SD card with Odroid-XU4 Ubuntu 16.04 LTS, then, before doing anything else…

    sudo apt-get update
    sudo apt-get upgrade
    sudo apt-get dist-upgrade

    1. Using your latest install_max2play.sh script, installed max2play which then started properly.
    2. Registered max2play, updated to latest max2play then installed latest beta.
    4. Registered my local USB HDD
    3. Installed latest LMS 7.9 and started that without any problems.

    So everything seems to be working well. Thank you ­čÖé

    I did encounter a problem with a previous attempt at doing this when I updated Mate from 1.12 (which is installed by the odroid image) to 1.14. For some reason this slowed down the XU4 so much as to make it unusable. I didn’t attempt this the second time and everything works well. Don’t know if it was the update to Mate 1.14 that caused the problem but I’ll look at that another time. For now I’m happy with what I have. When I’m happy everything is stable, I’ll make an image of my SD card and burn it to eMMC.

    Many thanks


    P.S. I did run into another problem! When I set up my USB HDD in max2play/filesystems my Odroid refused to reboot correctly. The boot process dropped out to the command line with an error stating that it didn’t understand the ‘nobootwait’ parameter. I had to vi /etc/fstab from that command line and remove the parameter and reboot. Then everything was fine. Not sure why because I thought ‘nobootwait’ is standard.

    • This reply was modified 2 months, 1 week ago by  bobertuk.
    • This reply was modified 2 months, 1 week ago by  bobertuk.
    • This reply was modified 2 months, 1 week ago by  bobertuk.
    12. August 2016 at 20:23 #22238

    Hi again flysurfer,

    I’ve discovered a couple of other issues with the Ubuntu 16.04 LTS max2play install.

    1. After installing ‘alsa’ in audio player, the graphic Equalizer starts but no adjustments can be made with the sliders.

    2. ‘Install Bluetooth’ in the Bluetooth plugin errors with…

    “Package bluez-utils is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source
    However the following packages replace it:

    So Bluetooth doesn’t start.

    Hope this is helpful


    • This reply was modified 2 months, 1 week ago by  bobertuk.
    15. August 2016 at 0:39 #22268

    I tried out your new m2p Ubuntu 16.04 image and found the same issues…

    1. Audioplayer/Equalizer sliders still not working.

    2. Bluetooth not installing from the plugin. Resolved by installing bluez-Utils from a downloaded deb package before installing the Bluetooth plugin.

    3. Filesystem Mount ‘nobootwait’ parameter has definitely been deprecated in Ubuntu 16.04. Can use ‘nofail’ instead. ‘nofail’ isn’t as good – if a mounted HDD has been disconnected the system halts for a time (I think up to 90 seconds) waiting for the HDD to reconnect. If the HDD is still not present system continues to boot/reboot.

    4. There’s definitely a problem using mate desktop 1.14! Tried installing it 2 more times onto fresh m2p images but each time the desktop became very unresponsive and some GUI’s were washed out and unreadable. Basically unusable so better to leave mate at 1.12.

    Hopefully you will be able to resolver the Equalizer issue.

    Thank you


Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.

Register here