[SOLVED] Turn off onboard wifi radio for rasberry pi 3

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI [SOLVED] Turn off onboard wifi radio for rasberry pi 3

This topic contains 6 replies, has 3 voices, and was last updated by  Heiner Moderator 9 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • 8. December 2016 at 16:13 #24690

    Is there a way to turn off the onboard wifi on Raspberry Pi 3? I would like to use USB wifi and move the dongle cable away from the raspberry pi. I don’t want any wifi radio signal coming from the PI 3 itself
    Thanks

    8. December 2016 at 18:45 #24704

    Hi Tmax,

    Yes there is, just go to the Raspberry Settings tab and activate

    Disable Default WiFi Interface WLAN0 on RPI3  [  ]
    This moves the build-in WiFi on Pi 3 to wlan1. This is necessary to add another WiFi stick on interface wlan0.

    Best regards,
    JCU

    8. December 2016 at 18:59 #24706

    Hi JCU
    I was not sure if that setting switched the radio off or just moved the logical wlan port that it used to connect. Do you know if it turns radio off? I guess it does say disable so it may well do that.

    8. December 2016 at 19:13 #24708

    Hi Tmax,

    To be honest I am not sure if this setting completely disables the onboard wifi or merely renames and moves it from wlan0 to wlan1. I believe it does the latter.

    The setting in any event makes an exterior USB wifi stick the default wlan0. I have two different RPi-Max2Play setups and use USB wifi sticks (and this setting) on both. It made quite a difference in terms of signal connection strength – and in turn in listening enjoyment as well, particularly with larger FLAC files…

    13. January 2017 at 17:14 #25880

    Hi guys,
    We also have an option in our Raspberry Settings to completely turn off the built-in WiFi.

    13. January 2017 at 17:59 #25899

    Hello Heiner
    What is that option?
    I am currently using the following
    blacklist brcmfmac
    blacklist brcmutil

    13. January 2017 at 18:34 #25907

    It’s the same option JCU mentioned. The move to the secondary interface ceases its activity.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.

Register here