trying to get wifi going, keep getting errors

Max2Play Home 2016 (en) Forums Max2Play Add-ons trying to get wifi going, keep getting errors

This topic contains 7 replies, has 2 voices, and was last updated by  jmkeuning premium 3 months, 2 weeks ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • 24. Februar 2018 at 5:13 #34073

    (I banged away at it and got connected. See my next reply for explanation of why, even though it is working, I am not really sure why.)

    I don’t even know what to tell you. Where to start. Raspberry pi with Hifiberry Digi+ is attached to router with ethernet cable. My LMS can see the device.

    I am trying to use „Automatic WiFi Setup with WPS“
    My asus rtn66u router has wps enabled.
    I have reset the raspberry pi

    I get this notice:
    OK
    Using jones for WPS
    ERROR creating connection
    Selected interface ‚wlan0‘ OK

    EDIT:
    Version 2.45
    Raspberry PI 3

    eth0      Link encap:Ethernet  HWaddr b8:27:eb:77:e0:7b  
              inet addr:192.168.1.10  Bcast:192.168.1.255  Mask:255.255.255.0
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:22370 errors:0 dropped:0 overruns:0 frame:0
              TX packets:6161 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:12102597 (11.5 MiB)  TX bytes:1204072 (1.1 MiB)
    
    lo        Link encap:Local Loopback  
              inet addr:127.0.0.1  Mask:255.0.0.0
              UP LOOPBACK RUNNING  MTU:65536  Metric:1
              RX packets:287 errors:0 dropped:0 overruns:0 frame:0
              TX packets:287 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1 
              RX bytes:21600 (21.0 KiB)  TX bytes:21600 (21.0 KiB)
    
    wlan0     Link encap:Ethernet  HWaddr b8:27:eb:22:b5:2e  
              UP BROADCAST MULTICAST  MTU:1500  Metric:1
              RX packets:28 errors:0 dropped:0 overruns:0 frame:0
              TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:5221 (5.0 KiB)  TX bytes:888 (888.0 B)
    
    ### WLAN ###
    • This topic was modified 7 months ago by  jmkeuning.
    • This topic was modified 7 months ago by  jmkeuning.
    24. Februar 2018 at 6:49 #34075

    So now I have:
    Status: WiFi USB adapter status is active. WiFi connection status is active (IP: 192.168.1.13 192.168.189.1)

    But how does this WPS thing work? My router reported success, but I had the ethernet cable plugged in so I was not connected via wifi. When I unplugged the ethernet cable and restarted the pi, it did not connect to wifi.

    The instruction says: „Wifi Protected Setup: Enable WPS in your Router and reboot Max2Play to automatically set up WiFi. Starts only, if no LAN-cable connected!“

    But then below there is a big button to Start Automatic Wifi Setup. How do I hit that button if ethernet is not connected?

    So I started WPS on the router, and then restarted the pi, and I have wifi! It is working.

    But I still do not understand if I needed to do the WPS or if I am connecting because the SSID and password are filled out?

    27. Februar 2018 at 17:10 #34112

    Hi jmkeuning,

    Sorry about the late response, I way on holiday last week and am still catching up 😉

    This is the procedure of how Max2Play tries to connect:

    1. Check for ethernet -> connected, done

    2. No ethernet -> start WPS scan -> running for 30 seconds -> connected, done

    3. No WPS connection established -> start automatic Access Point
    4. automatic Access Point started -> access the web interface with any device by selecting „Max2Play“ WiFi in your phone/tablet/etc.
    5. Now you can use Max2Play „offline“ until you manually enter your real WiFi credentials in the WiFi/LAN menu of our we interface and reboot

    hope this helps

    4. Juni 2018 at 5:02 #36040

    I am back to not being able to connect via wifi. Today my hifiberry went offline and I could not get it to come back online, so as I was troubleshooting I decided to update the software. I went through the process of mounting the new image (m2p_stretch_rpi_245.img).

    After the upgrade I was connected via wifi but the digi+ was not working. I saw a message on one of the pages that I needed to reboot to get the digi+ working and I did that. No wifi. So I try the WPS twice. No wifi. Plug in the ethernet cable I can connect just fine. Try WPS again. No wifi. Again and again. I am wearing out my carpet walking between the hifiberry and router.

    What do I do now?

    EDIT – my credentials are entered on the wifi page. I see no max2play access point.

    • This reply was modified 3 months, 2 weeks ago by  jmkeuning. Reason: add some information
    4. Juni 2018 at 14:10 #36064

    Hi jmkeuning,

    Sorry about the headaches, WiFi and WPS in particular can be fickle.

    When connected via ethernet, check the automatic AP option in the WiFi/LAN menu and make sure it is deactivated.
    Make sure the option „Load WiFi Interface:“ is active.
    Make sure your login credentials are correct and save them again.
    Shut down the Pi.
    Remove the the Pi from ethernet and boot it again.

    5. Juni 2018 at 5:56 #36084

    That was just about eternally frustrating. I followed your instructions this morning and got connected. the one thing I did differently this time is I left the ethernet plugged in until after I was disconnected from power. I left it connected today and monitored it remotely. It appeared to stay connected.

    When I got home and started working on it about two hours ago I was trying to use the Spotty app to play via Spotify Connect to the max2play device. No sound. I had power lights, and the optical light was lit, but no sound. Max2play appeared in the LMS web UI. So I swapped out the optical cable and some sound started coming through intermittently. That seemed really odd to me. I was switching the cable back, and the power came disconnected. That set me off on two hours of fiddling around. Something timed out at some point and I had to start over with a new image. Not a big deal, right, probably worthwhile. So I start from scratch, get it all set up. Get through it all and I CANNOT get the wifi to connect. Again, I am walking back and forth trying to get this going. Every time I am on ethernet I can hit http://max2play/ immediately. As soon as I shut down and power up I can not connect to wifi. I double and triple check the wifi settings. Nothing.

    I do not want to be without music, so I pull the old squeezebox duet from the drawer and I have that connected and playing within 20 minutes. On that note – I should say that I also have a SB Touch on this network and it works flawlessly.

    As a last ditch effort I try WPS with the max2play (which was not working yesterday) and it connected. This makes no sense to me.

    I am not smart enough to put some sort of monitoring on the digi+ to try to figure out why it is not working. I mean, just when I decide the wifi on the rpi3 must be broken, I get connected. Like I am right now. That reminds me – you know what is the WORST? At one point after I was ready to shutdown from the ethernet, I decided I did not want to unplug from power and walk over to my desk and plug into that power for the switch to wifi… so I left it on the power by the router… And I connected to wifi. Awesome… unplug, walk over to the computer, hook to power… nothing. But that power supply is the one that it is connected to right now, working. So it is not the power supply.

    My last recent post was on Feb 24. It ran flawlessly until yesterday. Basically three months. And then flawlessly ceases to exist.

    If you have any pointers or diagnostics I can run, I am open to ideas.

    I coped this at one point, when I was connected to ethernet:

    #### FILESYSTEM ####
    Filesystem     1K-blocks    Used Available Use% Mounted on
    /dev/root       29441240 1734508  26486584   7% /
    devtmpfs          435668       0    435668   0% /dev
    tmpfs             440276       0    440276   0% /dev/shm
    tmpfs             440276    6176    434100   2% /run
    tmpfs               5120       4      5116   1% /run/lock
    tmpfs             440276       0    440276   0% /sys/fs/cgroup
    /dev/mmcblk0p1     61384   22808     38576  38% /boot
    tmpfs              88056       4     88052   1% /run/user/1000
     
    
    #### LOAD AVERAGE ####
    0.27 0.14 0.05 1/200 2525
     
    
    #### KERNEL ####
    Linux max2play 4.9.39-v7+ #1020 SMP Sat Jul 22 14:21:01 BST 2017 armv7l GNU/Linux
     
    
    #### LINUX-VERSION ####
    Distributor ID:	Raspbian
    Description:	Raspbian GNU/Linux 8.0 (jessie)
    Release:	8.0
    Codename:	jessie
     

    And then this just now that it is on wifi:

    #### FILESYSTEM ####
    Filesystem     1K-blocks    Used Available Use% Mounted on
    /dev/root       29441240 1732732  26488360   7% /
    devtmpfs          435668       0    435668   0% /dev
    tmpfs             440276       0    440276   0% /dev/shm
    tmpfs             440276    6164    434112   2% /run
    tmpfs               5120       4      5116   1% /run/lock
    tmpfs             440276       0    440276   0% /sys/fs/cgroup
    /dev/mmcblk0p1     61384   22808     38576  38% /boot
    tmpfs              88056       4     88052   1% /run/user/1000
     
    
    #### LOAD AVERAGE ####
    0.13 0.04 0.01 1/193 4286
     
    
    #### KERNEL ####
    Linux max2play 4.9.39-v7+ #1020 SMP Sat Jul 22 14:21:01 BST 2017 armv7l GNU/Linux
     
    
    #### LINUX-VERSION ####
    Distributor ID:	Raspbian
    Description:	Raspbian GNU/Linux 8.0 (jessie)
    Release:	8.0
    Codename:	jessie
     
    
    5. Juni 2018 at 14:40 #36091

    Hi jm,

    Your logs say you still use the jessie image. Did the switch to Stretch not work?

    5. Juni 2018 at 15:07 #36092

    I did not notice that. When I reinstalled last night I must have mounted the old one which was still sitting in my downloads folder. Lovely.

    I will fix that tonight and go through this again.

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.

Register here