Touchscreen Calibration issues (5" Waveshare HDMI Display)

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Touchscreen Calibration issues (5" Waveshare HDMI Display)

This topic contains 3 replies, has 3 voices, and was last updated by  Bull premium 2 months, 4 weeks ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • 18. August 2016 at 15:06 #22322

    My RPi runs fine with a 5″ HDMI Touchscreen from Waveshare, but calibration of the touchscreen is not possible.
    Means, that I can control only the center area of the screen, but not the Buttons at the bottom nor the two buttons at the top of the screen, I cant reach them. Control by Mouse or Keyboard works fins.

    I tried several things, but till now without success.
    – installed the tslib and used the integrated ts_calibration function. That seems to go and some new values are written in /etc/pointercal but nevertheless, same touchcontrol issues
    – tried to find some UserInterface in the Windowmanager, but there is no option to calibrate a touchscreen
    – I searched the web now for hours, but can only find configurations and examples that do not work for me (to be honest, cant exactly remember, which things I tried in detail, have been too many)

    Do I have to calibrate under the CLI or the windowmanager ?

    In my opinion, the waveshare displays arent the best at all, but for this job almost well. Seems, that nobody else had to calibrate his touchscreen at all, or am I wrong ? Do these displays work right out of the box ?

    Hope somebody points me into the right direction and I can get my touchscreen to work, because its the last step to a working Max2Play Controller for mounting on the wall…

    2. September 2016 at 19:39 #22855

    I’m interested on this too. May be someone could help us!

    cheers
    Bull

    5. September 2016 at 16:12 #22870

    Hello martin-s and Bull,

    Thanks for your request.

    Maybe this is a help for you: http://www.waveshare.com/wiki/5inch_HDMI_LCD

    It is possible that the calibration file is not automatically loaded from the path which you have used. Usually the config should be saved under /etc/X11/xorg.conf.d/ or /usr/share/X11/xorg.conf.d/

    For example: /etc/X11/xorg.conf.d/99-calibration.conf

    Please send us what stands in your config file, so we can try this.

    Best Regards

    5. September 2016 at 19:43 #22871

    Hello Christoph, many thanks for your reply.

    I’m little afraid because the last time that I tried to install the drivers from waveshare the max2play didn’t start. It prompt for a user & password in console but any user/password that I’ve been tried didn’t works, and finally I reinstalled again the max2play writing the sd again.

    So please What do you need exactly that I need to do to send you the files that you need.

    the installation of the drivers with user pi or root(given a password)
    the installation of the calibration software?
    or whatever.

    I don’t have any problem to collaborate and do all the neccesary tests that you need, but I need to know what do you need that I need to do in raspbian because I’m quite new using this system.

    thank youn in advance
    BR
    Bull

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

Register here