The official Raspberry Pi 7'' touch display

Max2Play Home 2016 (en) Forums Max2Play Development (Ideas, Wishes) The official Raspberry Pi 7'' touch display

This topic contains 19 replies, has 4 voices, and was last updated by  Raymond Day premium 1 year, 1 month ago.

Viewing 20 posts - 1 through 20 (of 20 total)
  • 10. September 2015 at 19:46 #15656

    Just two days after the lauch of the device, most of the webshops selling it are rapidly running out of stock.

    RGB 800×480 display @60fps
    24-bit colour
    FT5406 10 point capacitive touchscreen
    70 degree viewing angle

    Is there any chance MAX2PLAY will be supporting it in the future ?
    Either by adding ‘out of the box’ support in the ‘Free version’, as a paid for add-on in the ‘Premium version’, or by providing instructions on how to modify the MAX2PLAY distribution?

    Much obliged,
    LeZandre

    11. September 2015 at 14:57 #15658

    The new Raspberry Pi Display is a very interesting new hardware. Once we get our hands on one, we will decide how to implement it in Max2Play. Thanks for your input, we will keep your ideas in mind. Stay tuned on our blog and facebook page for coming news.

    24. September 2015 at 13:05 #15803

    I got a 2.8″ display that did not work with Max2Play. So I installed the OS that works with it. Then looked on the web if there is some how to install Max2Play on a OS all ready loaded. I found a neat script. It worked.

    Just setting from there but don’t install the “Raspberry Pi Touch Display: Easy Install & Setup of Touch Displays 2,8″ and 3.2″” because that made 2.8 touch screen not display again. I had to start over.

    Guess the same would work for your 7″ touch display. Just install the OS that works with it then the this script. I will past it in here. It’s named “install_max2play.sh” chmod it with I guess 555 should make it run.

    Guess I can’t save it with that script in here.

    Will look for the link again…..

    Looked for “script max2play” found it fast here:

    https://github.com/max2play/webinterface/blob/master/install_max2play.sh

    24. September 2015 at 20:54 #15813

    Thanks.

    The script ran OK.

    But I can’t get squeezeplay to start.

    I selected force Headphone jack as output.

    Mediaplayer Squeezelite & Airplay – Status, Start / Stop

    Trying to launch … NOT successful Click here to show detailed information
    [20:46:47.747640] test_open:294 playback open error: Invalid argument
    [20:46:47.748028] output_init_common:381 unable to open output device

    25. September 2015 at 14:16 #15822

    I have just tried this and got the same issue with Squeezelite not starting. I resolved it by changing the soundcard in Audioplayer – Edit Advanced Options. I changed from default to sysdefault. Not sure what that does different but I was able to start Squeezelite afterwards.

    This is for sound out of the 3.5mm headphone jack. The Rpi touchscreen seems to be working ok as well.

    Thanks to Raymond for the touchscreen suggestion.

    • This reply was modified 1 year, 2 months ago by  Patrocks.
    25. September 2015 at 19:21 #15837

    I added JiveLite. Works fine, but is in dire need of fitting skin.

    http://forums.slimdevices.com/showthread.php?98156-Announce-JiveLite-cut-down-squeezebox-control-application&p=738544&viewfull=1#post738544

    Also, kodi seems to be having some trouble with displaying movies in proper ratio/resolution.
    Just as if it’s only using 2/3’s of the screen.

    When/If the nice folks of the Max2Play developer team get their hands on fixing those matters, I’b be more than willing to by a premium license.

    • This reply was modified 1 year, 2 months ago by  LeZandre.
    • This reply was modified 1 year, 2 months ago by  LeZandre.
    25. September 2015 at 22:34 #15840

    Have you tried the Joggler skin? It is working well on the RPi touchscreen for me after removing the taskbar and window.

    25. September 2015 at 23:14 #15841

    I’m using the Joggler skin.
    Do yo know the command line/procedure for launching JiveLite without window?
    At the moment I’ve launched it with ” ./bin/jivelite “.
    This way it opens up Windowed on the desktop.

    • This reply was modified 1 year, 2 months ago by  LeZandre.
    26. September 2015 at 9:18 #15843

    Sorry I don’t. I originally tried right clicking and hiding but that didn’t seem to work. Then I realised I paid for premium and there is a tick box option in the max2play settings that does it for me.

    I am not too knowledgeable on file locations in Linux but if you know where the start up script would be I can ssh in and look at if for you.

    26. September 2015 at 11:18 #15844

    I got that 7 inch official Raspberry Pi touch display.

    Could not get a image to boot up on it to the login. Could not even get a desktop on it.

    When I got up today I installed Max2Play fresh. Expand the file system rebooted and put my e-mail in and installed the:

    Raspberry Pi Touch Display: Easy Install & Setup of three different Touch Displays (2.4”, 2.8″ and 7″) – including the official Raspberry Pi Touchdisplay

    Then I could pick the 7″ and install it. It did not show up before. Then rebooted and the text came up on the 7″ so it worked. This time got to the login too 🙂

    Then installed the JiveLite and that takes a little time. Looks like it makes it. Rebooted and started it.

    It works on the 7″ touch screen. It ask for language and then the skin and it had 640 x 480 but the last was Juggler Skin. I picked that on the display.

    But picked it out with a USB mouse. The touch is not working. Not sure if I plug the ribbon cable in right or if it’s a setting.

    But seems like it’s working good just have to fix the touch yet.

    Still in the “Install further jivelite Skins (important for small touchscreens)” I can only pick the “Port for 2.8″ 320×240 Adafruit LCD…” now. But I don’t need to pick it any more. But something it don’t show up any more there. It did and it was the only one 7″ when I installed from the start.

    • This reply was modified 1 year, 2 months ago by  Raymond Day.
    • This reply was modified 1 year, 2 months ago by  Raymond Day.
    27. September 2015 at 11:31 #15847

    Just found out why the touch did not work. I was using a 2.1 amp USB power to power them both. It has 2 ports a 2.1 and a 1 amp USB Used a USB Y cable so it gets them from both so 3.1 amp and that works. Now I can use the touch screen.

    All seems to work good.

    Be nice if could set a clock up when it’s not playing music.

    27. September 2015 at 11:33 #15848

    I got that before all so with the head phone out. Just pick the other default audio out. They look about the same. Then restart the player and it will start.

    28. September 2015 at 13:48 #15851

    One thing I see there is all way a 4 color square in the top right corner. Even when it’s off. I guess it could burn in the LCD 7″ touch screen with time. Any way to fix this?

    All else seems to be working real good with it now.

    28. September 2015 at 15:09 #15854

    One thing I see there is all way a 4 color square in the top right corner. Even when it’s off. I guess it could burn in the LCD 7″ touch screen with time. Any way to fix this?

    That sounds like the Pi under voltage warning. I don’t have it on my touchscreen. In which case your Pi needs more power. Common suggestions are try a different PSU or if you think your PSU is ok try different USB leads (some leads cannot carry the amps needed).

    28. September 2015 at 17:24 #15873

    Thanks. I just put the best USB cable and best 5 volt power I have on it. A 5 volt brick I solder a female USB end on it. It’s 5 volts at 5 amps.

    The 4 color cube in the top right can go off some and then on still.

    I guess because I have the power going in the LCD board then out from there to the Pi. I got to test 2 power to each I guess and see if that fixes it. I guess the LCD board can’t do out the right power from it’s USB out to the Pi.

    28. September 2015 at 17:33 #15874

    Just did that using the 2 ports on the USB to put power to each the Pi and the 7″ touch screen. This time it don’t have the color cube in the top right.

    Just shows that the board that comes with this 7″ touch screen the use power out on the side can not power up the Pi good.

    Thank you. I did not think this was the problem. It’s fixed now. 🙂

    28. September 2015 at 18:42 #15878

    I power the LCD with a 5V 2A white Raspberry pi powersupply and feed the Raspberry pi with the supplied breadboard leads through GPIO pins.
    I’ve got a USB keyboard and mouse, as well as a WIFI dongle stuck in the Raspberry Pi’s USB boards.
    So far no ‘Low Power’ indicater has shown up.

    Feeding the Raspberry Pi through the Display’s USB connector to the PI’s µ USB power in might cause the problem.
    How much current does a USB 2 port provide? 500 mA max I thought.

    Given the USB 2 port on the display is limited to that specification, that’s not enough to power the Pi and peripherals I’m afraid.

    • This reply was modified 1 year, 2 months ago by  LeZandre.
    • This reply was modified 1 year, 2 months ago by  LeZandre.
    • This reply was modified 1 year, 2 months ago by  LeZandre.
    1. October 2015 at 11:28 #15910

    I was testing this out with other USB cable’s till I got it right. Power it down and up a lot.

    I had the GPIO pins plug in wrong! So plug them in right and then did not need the USB out to in. That one don’t have good amps any way to power the Raspberry Pi because the same USB cable can power it right.

    Used a Y cable to a 2.1 and I guess 1 amp USB and that still did not power it on right. It should be 3.1 amp then.

    Using my power brick that I solder on a USB female end on it. It has 5 volts at 5 amps. It works good. Just have one USB cable going to my Raspberry Pi now.

    Order a $10 USB at 2.5 amps. The best I could find on line. Have to wait to get it.

    What power supply are others using that works with a Raspberry Pi and 7″ touch screen?

    9. October 2015 at 15:10 #16254

    I got mine working good with just a 2.1 amp now. I just plug the power in the Raspberry Pi and from there it goes to the 7″ Touchscreen power with the gpio pins.

    Now I have the HiFiBerry and I just solder the power wires to it. So power goes in the Pi and it gives power though the gpio plug and from the HiFiBerry power goes to the Touchscreen.

    It all works with 2.1 amp USB power I have to it.

    No color cube in top right corner.

    I did have the color cube fading in and out one time with another USB cable and that cable seemed good. I am using a old USB cable and it works. So that may be it for others if you get this or the touch don’t work. It’s because not good power to it.

    27. October 2015 at 0:15 #16565

    I got the IQaudIO Pi-DAC+ and the black case for the Raspberry Pi 7″ touchscreen. The HiFi board sticks out the back so the back is not back as fare as it could be so I had to cut part of it out. If I did it again can see how much I did not have to cut off. I got some photos of it.

    Had to solder the power wires that go to the Display right on the HiFi board because they would of went back way to fare for the case to fit.

    If I did it again would not cut off so much

    The new stand-offs are all most to big. The one goes right next to the power USB plug. It rubs against it. But it worked. Got them from element14 later seen mouser has the better right size ones.

    Cut the 3 holes the 2 big ones and the small one the temp plate from here help with that some but this one is not the same holes. I did a pencil side ways on it to mark were to drill. But it just still would not fit. Used a exacto knife to like whittling the plastic off till it fit.

    Can see it another way.

    Had to wait to get the Stand-off’s in the mail. The IQaudIO HiFi board don’t come with the right ones were you can use it with the 7″ Touchscreen Display.

    I guess this my help others if they want to do this. I think you could do it better them me from seeing the photos here.

    One more photo to see what I guess would ask for.

    Can see here how much I did not have to cut off to fit it.

    I did cut the center mount off between the 2 RCA audio plugs. Before I know I had to cut more off the case. Can see now I did not have to cut that off.

    O yes the HiFi board is the IQaudIO one.

    -Raymond Day

    • This reply was modified 1 year, 1 month ago by  Raymond Day.
    • This reply was modified 1 year, 1 month ago by  Raymond Day.
    • This reply was modified 1 year, 1 month ago by  Raymond Day.
    • This reply was modified 1 year, 1 month ago by  Raymond Day.
    • This reply was modified 1 year, 1 month ago by  Raymond Day.
    • This reply was modified 1 year, 1 month ago by  Raymond Day.
Viewing 20 posts - 1 through 20 (of 20 total)

You must be logged in to reply to this topic.

Register here