Synology NAS Mount Error: "mount.nfs: Failed to resolve server"

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Synology NAS Mount Error: "mount.nfs: Failed to resolve server"

This topic contains 6 replies, has 3 voices, and was last updated by  Olly_RPM premium 12 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • 9. December 2015 at 14:34 #17197

    Hi All,

    Before I get started I would just like to say I have spent a couple of days on this now and I have searched these forums and plenty of others for a solution. I am posting here as a last resort, I have exhausted all other options.

    I am attempting to mount an NFS share using the Max2Play web interface, this should be a simple task but I am having great difficulty. I want to give the Squeezebox Server read-only access to a music folder stored on my NAS drive.

    These are the steps I have gone through…

    1. Created a new user on my Synology DiskStation DS215j.
    -Control Panel>User>Create User>
    -Name> max2play
    -Password: 63Music
    -Permissions: music – read only

    2. Enabled NFS files services on Synology NAS.
    -Control Panel>File Services>
    -Tick Enable NFS
    -Tick NFSv4 Support

    3. Enabled NFS Permissions on music folder on Synology NAS
    -Control Panel>Shared Folder>Selected music>Edit
    -NFS Permissions Tab>Create
    -Enter IP (192.168.1.107) of Raspberry Pi (I have tried with the hostname max2play also)
    -Privelage: read-only
    -Squash: no mapping
    -security: sys
    -Enabled Asyncronus
    -Enabled: Allow connections from non-privelages ports (higher than 1024)
    -Enabled: Allow users to access mounted sub-folders

    4. Verified that the NFS share (music folder can be seen)
    -SSH into Synology NAS
    -Enter: cat /etc/exports
    -Putty Returns: /volume1/music 192.168.1.107(r0,async,no_wdelay,crossmnt,insecure,no_root_squash,insecure_locks,sec=sys,anonuid=1025,anongid=100)

    5. Max2play Filesystem Mount (via web interface)
    In max2play I have entered the following…

    //192.168.1.5:/volume1/music /mnt/mountdir/music nfs user=max2play,password=63Music,sec=ntlm,nolock

    When I press the save button I get the follwing error message…

    mount.nfs: Failed to resolve server //192.168.1.5: Name or service not known
    Mountpoint NOT added! Please refer to the description below!

    Please note I have also tried replacing the IP address with the hostname of my Synology NAS and I receive the same error message. The Debug Info window simply displays the following…

    //192.168.1.5:/volume1/music /mnt/mountdir/music nfs user=max2play,password=63Music,sec=ntlm,nolock

    I will be eternally greatful if anyone can assist, I have almost reached the point of giving up! I did find a similar post in the forums yet the user said they resolved the issue which was located on the NAS side. Unfortuantly they didn’t give any more information.

    Thanks in advance.

    Olly.

    9. December 2015 at 18:52 #17213

    Hi Olly,

    usually it’s easier to use the cifs mount option instead of nfs. The shared folders in your diskstation should be set up very easy with cifs.

    If you want to stay with nfs try following:
    – set the Path to “192.168.1.5:/volume1/music” (remove “//” in front)
    – remove all options (user and password are not set with nfs and will result in an error)
    – set the mountpoint to “/mnt/mountdir”. I just changed this in the Max2Play-Beta, that it automatically creates subfolders and its parentdirectories if these are not existing.

    Cheers,
    Stefan

    9. December 2015 at 22:53 #17221

    Hi Olli,
    also on Synology at NFS permission try to use * instead of PI IP address. This will allow any IP address in your network to access the Synology via NFS. You can set this back to the specific PI IP address any time later once you figured out the issue.

    Good luck Claudio

    10. December 2015 at 11:22 #17223

    Stefan,

    Thank you for replying. I have tried what you suggested and to my suprise it worked!!

    It seems to me that the help instructions on the Filesystem Mount page are somewhat misleading, the fact they use Synology as the example is even more confusing.

    I actually managed to get this working using the NFS permissions locked to the IP address of my Raspberry Pi, however I have taken on Claudio’s advice and used a * wildcard instead of a static IP address as my Raspberry Pi is being served a DHCP address.

    So I now receive a message back saying the mount has been succesful. However if I open up the Squeezebox Server settings and look for the newly created folder /mnt/mountdir it isn’t there.

    I am able to locate the /mnt folder but there is only one other folder shown in there which is /mnt/mpd. I have attempeted to point the server at both locations and performed a rescan. Unfortuantly the server does not find any music at all. Interestingly if I VNC into the Pi and navigate to /mnt/mountdir the folder can be seen but it is empty. What is going on here? See pic…

    Edit: for some reason I couldn’t insert the picture. here is a link.. http://postimg.org/image/d63qwci2j/

    Thanks in advance.

    Olly.

    • This reply was modified 12 months ago by  Olly_RPM. Reason: Unable to embedd screen grab
    10. December 2015 at 12:46 #17228

    Hi Olly,

    I never really used the type NFS to mount any folders on a media device at home. Instead I always use SMB/CIFS as this is really easy. The help instructions are really misleading on this (just changed this for the current BETA and the next release), thanks for pointing this out!

    You might try setting up a simple SMB-Share on your Diskstation (with a user login) and connect to this (probably fastest solution).

    If you want to stick to the NFS Type and the mounting on Max2Play says everything worked fine, you may check if the Setup of your NFS-Share on the Diskstation is complete (try accessing the NFS share from another computer in your network).

    @Claudio: Thanks for your input! I added the “*” option to the help instructions.

    10. December 2015 at 14:24 #17231

    Hi Olli,
    hört sich an, dass das Problem auf Synology Seite ist. Schau mal wo Deine Mediathek indexiert wird unter: System;Medienindizierung;Indizierte Ordner.

    Stelle auch sicher dass der Pfad auf die indizierten Ordner in m2p exakt eingegeben wurde. Den Pfad siehst Du unter: Gemeinsame Ordner; Freigegebene Order Musik; NFS Berechtigungen; links unten im Fenster.

    Grüsse Claudio

    10. December 2015 at 18:42 #17263

    Hi Stefan,

    I had one last attempt at setting up NFS by checking the settings highlighted by Claudio, unfortunately it failed.

    So I went ahead and tried the SMB/CIFS method and it worked! The LMS server is now scanning my shared folder and finding all of my albums. I wish I had gone straight in with the SMB/CIFS method as I would have saved so much time. The thing is my knowledge is limited on this kind of thing, I still don’t have any idea of the pro’s and con’s of each.

    Thank you both for your help.

    Olly.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.

Register here