[SOLVED] Stuttering playback over bluetooth

Max2Play Home 2016 (en) Forums Max2Play Add-ons [SOLVED] Stuttering playback over bluetooth

This topic contains 7 replies, has 6 voices, and was last updated by  fredhopper premium 2 months, 2 weeks ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • 21. March 2017 at 15:43 #27823

    I have an RPi3 with Max2play and a HiFiBerry Amp+. I’ve installed the Bluetooth add-on and configured it for streaming direct to the Max2play soundcard. Both squeezelite and shairplay are set to use pulse.

    I can play music fine through squeezelite, but when I connect an Amazon Echo Dot via Bluetooth, the playback from the Echo is very poor – constant stuttering and breakup.

    Any ideas how I can fix this?

    Cheers,
    Peter

    22. March 2017 at 12:29 #27829

    Hi petercoxphoto

    Please make sure that the Bluetooth speakers are not faraway form the RASPI and make sure that you are using a good quality power supply.

    Regards,
    Mohammad Mbydeen

    22. March 2017 at 14:27 #27830

    Hi Mohammad –
    Thanks for the reply. The two are right next to each other, and I’m using the power supply that came with the Echo Dot, as well as the one I bought from HiFiBerry for the Amp+.

    Cheers,
    Peter

    27. March 2017 at 13:59 #27867

    Hi petercoxphoto

    Have you enabled the checkbox Switch audio output on disconnect in the Bluetooth plugin ?
    Have you tried to reinstall the Bluetooth plugin ?
    What is the version of max2play that you have ?

    Regards,
    Mohammad Mbydeen

    9. May 2017 at 8:35 #28759

    Hi petercoxphoto,

    did you solve the problem and if so how. I also have the same problem.
    The playback from the Echo is very poor (Stream to Raspberry) – constant stuttering and breakup.

    31. May 2017 at 10:21 #29128

    Hi tommy,
    If you have USB periphery connected to your Pi, please try Bluetooth without them connected.

    1. June 2017 at 17:08 #29184

    Hi,

    i had the same Problem with the Raspberry Pi 3 . The Pi 3`s onboard WLAN and Bluetooth is placed in the same chip and only one works properly.

    So you have to buy a Bluetooth or a WLAN USB adapter and disable the same onboard device.

    (I dont know what to do if you are already using a Bluetooth USB adapter)

    2. June 2017 at 14:27 #29211

    I found that updating the Kernel corrected this problem.

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.

Register here