Strech Image – Ampache fehlerhafte Installation

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Strech Image – Ampache fehlerhafte Installation

This topic contains 10 replies, has 5 voices, and was last updated by  KmufRkf premium 1 year, 10 months ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • 9. April 2018 at 17:55 #35085

    Hallo

    wollte den Apache installieren.Er ist zwar laut system installiert aber funktioniert nicht.Lt Log lässt sich php 5 nicht installieren.

    Gibt es dafür eine Lösung

    Hit:1 http://archive.raspberrypi.org/debian stretch InRelease
    Get:2 http://mirrordirector.raspbian.org/raspbian stretch InRelease [15.0 kB]
    Fetched 15.0 kB in 0s (15.0 kB/s)
    Reading package lists...
    Reading package lists...
    Building dependency tree...
    Reading state information...
    Package php5-mysql is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source
    
    Package php5-curl is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source
    
    E: Package 'php5-curl' has no installation candidate
    E: Package 'php5-mysql' has no installation candidate
    Reading package lists...
    Building dependency tree...
    Reading state information...
    mysql-server is already the newest version (5.5.9999+default).
    0 upgraded, 0 newly installed, 0 to remove and 33 not upgraded.
    /var/www /var/www/max2play/public
    fatal: destination path 'ampache' already exists and is not an empty directory.
    /usr/src /var/www /var/www/max2play/public
    All settings correct for using Composer
    Downloading...
    
    Composer (version 1.6.3) successfully installed to: /usr/src/composer.phar
    Use it: php composer.phar
    
    /var/www/ampache /usr/src /var/www /var/www/max2play/public
    Do not run Composer as root/super user! See https://getcomposer.org/root for details
    Loading composer repositories with package information
    Installing dependencies (including require-dev) from lock file
    Nothing to install or update
    Package guzzle/common is abandoned, you should avoid using it. Use guzzle/guzzle instead.
    Package guzzle/http is abandoned, you should avoid using it. Use guzzle/guzzle instead.
    Package guzzle/parser is abandoned, you should avoid using it. Use guzzle/guzzle instead.
    Package guzzle/stream is abandoned, you should avoid using it. Use guzzle/guzzle instead.
    Generating autoload files
    > ComponentInstaller\Installer::postAutoloadDump
    Compiling component files
    Reloading apache2 configuration (via systemctl): apache2.service.
    finished - Click here to reload Page
    
    Ampache ist jetzt installiert!
    10. April 2018 at 10:46 #35099

    Hi laurent,

    Danke für die Info, wir werden dieses Problem schnellstens untersuchen und beheben.

    24. September 2019 at 22:11 #47144

    Hey,

    ich habe ein ähnliches Problem.

    M2P Version ist die neuste 2.50 auf eine Raspberry 3 bei dem gerade apt-upgrade durchgeführt wurde.

    Fehlermeldung ist:

    To activate the new configuration, you need to run:
    systemctl restart apache2
    Considering dependency mpm_prefork for php7.0:
    Considering conflict mpm_event for mpm_prefork:
    Considering conflict mpm_worker for mpm_prefork:
    Module mpm_prefork already enabled
    Considering conflict php5 for php7.0:
    Enabling module php7.0.
    To activate the new configuration, you need to run:
    systemctl restart apache2

    Grüße und ich hoffe mir kann geholfen werden.

    25. September 2019 at 9:53 #47147

    Hallo daemmi,

    Ist dein System seit dieser Fehlermeldung in irgendeiner Form beeinträchtigt?

    27. September 2019 at 17:54 #47189

    Moin Heiner,

    ich habe bis jetzt noch nichts festgestellt. Nutze es aber auch nicht wirklich, da ich bis jetzt nur am testen bin. Der andere ympd Player funktioniert auch weiterhin noch. Also der Server läuft anscheinend. Ich komme auch auf die Seite vom Ampache aber immer mit der Meldung „Error
    Unable to load required dependencies. Please visit the wiki for installation help“

    Beste Grüße

    6. Oktober 2019 at 14:38 #47233

    Hallo,

    … ich habe genau das selbe Problem. Ich gehe davon aus, dass eine Inkompatibilität mit den PHP-Versionen vorliegt?

    Wann ist mit einer Anpassung/Update zu rechnen oder handelt es sich um einen anderen Fehler?

    Danke

    16. Oktober 2019 at 16:28 #47356

    Hallo,

    für das neue Max2Play-Image auf Basis von Buster gibt es jetzt einen Fix in der aktuellen Beta (im Release 2.51 dann verfügbar). Dieser sorgt dafür, dass die richtigen PHP Pakete ausgewählt werden und auch die Datenbank für Ampache korrekt installiert wird.

    Also einfach Beta Update auf der „Einstellungen/Reboot“ durchführen oder bis Ende der Woche warten (Release 2.51). Anschließend Ampache erneut installieren.

    Viele Grüße
    Stefan

    19. Oktober 2019 at 17:55 #47385

    … danke, das probiere ich im Release nächste Woche gleich einmal aus …

    19. Oktober 2019 at 20:02 #47390

    Hallo,

    funktioniert leider noch nicht.

    Wenn ich mit der aktuellen Beta (191016) die Installation probiere (ampache ist schon drauf, ich wähle neu installieren) sehe ich kurz, dass symfony immer noch eine fehlerhafte php-version bemängelt. Der resultierende Fehler bleibt bestehen.

    19. Oktober 2019 at 20:06 #47391
    Bereits installiert - versucht Neuinstallation
    Installation gestartet - Diese Meldung zeigt den aktuellen Status der Installation aller 3 Sekunden an. Wenn diese abgeschlossen ist verschwindet die Meldung und der Server läuft.
    2019-10-19 20:02:13|
    Hit:1 http://mirrordirector.raspbian.org/raspbian stretch InRelease
    Hit:2 http://pipplware.pplware.pt/pipplware/dists/stretch/main/binary InRelease
    Hit:3 http://archive.raspberrypi.org/debian stretch InRelease
    Reading package lists...
    Reading package lists...
    Building dependency tree...
    Reading state information...
    php-cli is already the newest version (1:7.0+49).
    php-curl is already the newest version (1:7.0+49).
    php-gd is already the newest version (1:7.0+49).
    php-mysql is already the newest version (1:7.0+49).
    php7.0-mbstring is already the newest version (7.0.33-0+deb9u5).
    php7.0-xml is already the newest version (7.0.33-0+deb9u5).
    0 upgraded, 0 newly installed, 0 to remove and 103 not upgraded.
    Reading package lists...
    Building dependency tree...
    Reading state information...
    libapache2-mod-php is already the newest version (1:7.0+49).
    0 upgraded, 0 newly installed, 0 to remove and 103 not upgraded.
    Reading package lists...
    Building dependency tree...
    Reading state information...
    mysql-server is already the newest version (5.5.9999+default).
    0 upgraded, 0 newly installed, 0 to remove and 103 not upgraded.
    Reading package lists...
    Building dependency tree...0 upgraded, 0 newly installed, 0 to remove and 103 not upgraded.
    Reading package lists...
    Building dependency tree...
    Reading state information...
    mysql-server is already the newest version (5.5.9999+default).
    0 upgraded, 0 newly installed, 0 to remove and 103 not upgraded.
    Reading package lists...
    Building dependency tree...
    Reading state information...
    mysql-server is already the newest version (5.5.9999+default).
    0 upgraded, 0 newly installed, 0 to remove and 103 not upgraded.
    Set MySQL-Password
    ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)
    /var/www /var/www/max2play/public
    fatal: destination path 'ampache' already exists and is not an empty directory.
    /usr/src /var/www /var/www/max2play/public
    sudo: unable to resolve host max2playBad
    All settings correct for using Composer
    Downloading...
    
    Composer (version 1.9.0) successfully installed to: /usr/src/composer.phar
    Use it: php composer.phar
    
    sudo: unable to resolve host max2playBad
    /var/www/ampache /usr/src /var/www /var/www/max2play/public
    Do not run Composer as root/super user! See https://getcomposer.org/root for details
    Loading composer repositories with package information
    Installing dependencies (including require-dev) from lock file
    Your requirements could not be resolved to an installable set of packages.
    
    Problem 1
    - Installation request for doctrine/annotations v1.6.1 -> satisfiable by doctrine/annotations[v1.6.1].
    - doctrine/annotations v1.6.1 requires php ^7.1 -> your PHP version (7.0.33) does not satisfy that requirement.
    Problem 2
    - Installation request for doctrine/cache v1.8.0 -> satisfiable by doctrine/cache[v1.8.0].
    - doctrine/cache v1.8.0 requires php ~7.1 -> your PHP version (7.0.33) does not satisfy that requirement.
    Problem 3
    - Installation request for symfony/console v4.2.10 -> satisfiable by symfony/console[v4.2.10].
    - symfony/console v4.2.10 requires php ^7.1.3 -> your PHP version (7.0.33) does not satisfy that requirement.
    Problem 4
    - Installation request for symfony/contracts v1.1.5 -> satisfiable by symfony/contracts[v1.1.5].
    - symfony/contracts v1.1.5 requires php ^7.1.3 -> your PHP version (7.0.33) does not satisfy that requirement.
    • This reply was modified 1 year, 11 months ago by  KmufRkf.
    29. Oktober 2019 at 22:09 #47449

    … geht es nur bei mir nicht?

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.

Register here