Strange volume control behavior – cure?

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Strange volume control behavior – cure?

This topic contains 5 replies, has 2 voices, and was last updated by  Heiner Moderator 1 year, 11 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • 29. April 2019 at 4:29 #45170

    I am running the basic MPD version of m2p. when using the volume control on the ympd web itnerface, The volume behaves strangly.
    For example, when the browers interface is started, the volume slider is about 80%, if I increase the slider the volume increases. If I now move the slider to the left to the 80% position, the volume is about 1/2 of what it was when I initially started.
    Now moving the slider to the 100% position, the volume increases but nowhere near as loud at the original 80% position.
    Also increasing the volume is not linear….moving it to the right increase it a little, moving it further to the right just a little bit results in a much louder volume.

    Any help appreciated.

    30. April 2019 at 12:27 #45183

    Hi three_jeeps,

    What sound card do you use and what are your parameters in MPDs advanced settings?

    2. Mai 2019 at 16:35 #45216

    Hi:
    thanks for your help. After dealing with this and issues in other areas of this program, I decided to go a different route for my audio player.
    J

    3. Mai 2019 at 9:53 #45224

    That’s sad to hear, I do recommend you try out advanced setup some time. It’s Max2Play’s true strength and the ideal starting point for multiroom and multimedia applications.

    3. Mai 2019 at 19:16 #45254

    Apologies, I neglected to answer your question above. I am not using an external sound card. I am using the audio subsystem on the RPi. A run an audio cable out of the speaker jack on the RPi to the input of my stereo amp.
    I initially used the default settings for MPD. When I ran into the audio issue I kept audio output type as ‚alsa‘ and changed device from hw:0 to sw:0, which did not help. I’ve compiled and installed MPD on other Linux distros and have some experience dealing with the nuances of MPD. I also tried the other setting listed (I don’t recall ATM what they are). Nothing seemed to work. I restarted the system each time.
    What surprised me is that this functionality is fundamental and it is being delivered to a specific target platform…everything about the environment and hardware is a known entity. For this fundamental operation not to work ‚out of the box‘ is disturbing.

    6. Mai 2019 at 13:20 #45278

    It is indeed, as mentioned be recommend using Max2Play’s advanced preset, nonetheless, the starter should obviously work out-of-the-box.

    I’ll try to recreate your issue and see if it’s a universal one. Could you detail your steps in Max2Play? When you say you used the default settings, how did you test playback and set up the device initially?

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.

Register here