Squeezelite set buffer parameter – b

Max2Play Home 2016 (en) Forums Max2Play as Squeezebox (Player / Server) Squeezelite set buffer parameter – b

This topic contains 9 replies, has 2 voices, and was last updated by  MarioM Moderator 4 months, 2 weeks ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • 13. April 2020 at 15:22 #48478

    Hello

    I want to set buffer size with b <stream>:<output> parameter
    So I add – b 20000:60000 to the line commande. This is all my commands :-C 5 -v -D 3:U32be – b 20000:60000
    With this parameter I can’t start squeezelite because it say there’s one error.
    On picore player there is line to set this parameter and it work I have 20000:60000

    #### AUDIOPLAYER CONFIG ####
    ### Configuration of Audioplayers
    SQUEEZELITE_PARAMETER=-o hw:CARD=DAC,DEV=0 -a 160:4:: -C 5 -v -D 3:U32be – b 20000:60000
    SQUEEZESLAVE_PARAMETER=-n plugequal
    SHAIRPORT_PARAMETER=-d plug:jack
    USE_USB_DAC=0
    USE_EQUALIZER=0
    SYSTEM_USER=pi
    GMEDIARENDERER_ALSA_DEVICE=plug:jack

    Can you help me to set my buffer please

    Thanks

    • This topic was modified 5 months, 2 weeks ago by  Run51.
    14. April 2020 at 11:39 #48481

    It’s OK I have set buffer
    Hello
    I set squeezelite with buffer 20000:6000.
    I have a small mute that when I play dsd file

    Withe picoreplayer and the same squeezelite settings I have no problem!

    Can you help me please.

    15. April 2020 at 14:25 #48487

    Hi Run51,

    Do the problems also occur with other file formats? Does the mute only appear at the beginning of playback or while you are playing a song? Which Pi and which sound card do you use? Which version of Max2Play?

    30. April 2020 at 13:07 #48668

    Hello.

    It’s during playback every 20sec
    With other format I have crunches.lot of churches with 192 24bit
    I use Allo usbridge sig oppo ha-1 dac and the last version of max2play.

    30. April 2020 at 13:09 #48669

    With squeezelite on pcp 6 and same settings it work.
    But I want max2play.
    My settings are not correct? Or it’s an other problem
    Can you help me please

    • This reply was modified 4 months, 4 weeks ago by  Run51.
    5. Mai 2020 at 14:12 #48696

    Hi Run51,

    sorry for the late reply. Please look up what’s in the debug on the audio player page when you play DSD files. Please also send us the current SQUEEZELITE_PARAMETER, since the settings you made there may not work. Presumably something is set there that hinders playback and the LMS converts the signal. This is probably where the dropouts come from.

    5. Mai 2020 at 14:37 #48697

    Hi

    I don’t think it’s lms because with picoreplayer no problem
    I have problem With pcm too. I have crunches.
    This is my debug with dsd

    #### SQUEEZELITE VERSION ####
    Squeezelite Max2Play v1.0.3 based on v1.8.7-999, Copyright 2012-2015 Adrian Smith, 2015-2017 Ralph Irving.

    #### SQUEEZELITE BUILDOPTIONS ####
    Build options: LINUX ALSA EVENTFD RESAMPLE FFMPEG VISEXPORT IR GPIO DSD CONTROLSBS ALSASYNC BLUETOOTHSYNC

    #### AUDIOPLAYER CONFIG ####
    ### Configuration of Audioplayers
    SQUEEZELITE_PARAMETER=-o hw:CARD=DAC,DEV=0 -a 160:4:0:1:0 -b 125000:125000 -C 5 -v -D -p 85
    SQUEEZESLAVE_PARAMETER=-n plugequal
    SHAIRPORT_PARAMETER=-d plug:jack
    USE_USB_DAC=0
    USE_EQUALIZER=0
    SYSTEM_USER=pi
    GMEDIARENDERER_ALSA_DEVICE=plug:jack

    #### SQUEEZELITE -l ####
    Output devices:
    null – Discard all samples (playback) or generate zero samples (capture)
    jack – JACK Audio Connection Kit
    pulse – PulseAudio Sound Server
    equal
    plugequal – Equalizer for plughw:0,0
    default:CARD=DAC – OPPO HA-1 USB AUDIO 2.0 DAC, USB Audio – Default Audio Device
    sysdefault:CARD=DAC – OPPO HA-1 USB AUDIO 2.0 DAC, USB Audio – Default Audio Device
    front:CARD=DAC,DEV=0 – OPPO HA-1 USB AUDIO 2.0 DAC, USB Audio – Front speakers
    surround21:CARD=DAC,DEV=0 – OPPO HA-1 USB AUDIO 2.0 DAC, USB Audio – 2.1 Surround output to Front and Subwoofer speakers
    surround40:CARD=DAC,DEV=0 – OPPO HA-1 USB AUDIO 2.0 DAC, USB Audio – 4.0 Surround output to Front and Rear speakers
    surround41:CARD=DAC,DEV=0 – OPPO HA-1 USB AUDIO 2.0 DAC, USB Audio – 4.1 Surround output to Front, Rear and Subwoofer speakers
    surround50:CARD=DAC,DEV=0 – OPPO HA-1 USB AUDIO 2.0 DAC, USB Audio – 5.0 Surround output to Front, Center and Rear speakers
    surround51:CARD=DAC,DEV=0 – OPPO HA-1 USB AUDIO 2.0 DAC, USB Audio – 5.1 Surround output to Front, Center, Rear and Subwoofer speakers
    surround71:CARD=DAC,DEV=0 – OPPO HA-1 USB AUDIO 2.0 DAC, USB Audio – 7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
    iec958:CARD=DAC,DEV=0 – OPPO HA-1 USB AUDIO 2.0 DAC, USB Audio – IEC958 (S/PDIF) Digital Audio Output
    dmix:CARD=DAC,DEV=0 – OPPO HA-1 USB AUDIO 2.0 DAC, USB Audio – Direct sample mixing device
    dsnoop:CARD=DAC,DEV=0 – OPPO HA-1 USB AUDIO 2.0 DAC, USB Audio – Direct sample snooping device
    hw:CARD=DAC,DEV=0 – OPPO HA-1 USB AUDIO 2.0 DAC, USB Audio – Direct hardware device without any conversions
    plughw:CARD=DAC,DEV=0 – OPPO HA-1 USB AUDIO 2.0 DAC, USB Audio – Hardware device with all software conversions
    usbstream:CARD=DAC – OPPO HA-1 USB AUDIO 2.0 DAC – USB Stream Output

    #### SHAIRPORT (SYNC) VERSION ####
    3.3.1-OpenSSL-Avahi-ALSA-soxr-sysconfdir:/usr/local/etc

    #### OUTPUT SOUND DETAILS CARD 0 ####

    #### OUTPUT SOUND DETAILS CARD 1 ####
    access: MMAP_INTERLEAVED
    format: S32_LE
    subformat: STD
    channels: 2
    rate: 176400 (176400/1)
    period_size: 7056
    buffer_size: 28224

    7. Mai 2020 at 13:32 #48729

    Hi Run51,

    The parameter „-a 160:4:0:1:0“ certainly does not work because there is one „:“ too much. Please try the default parameters or „160:4::“ for more buffer time. It is best to leave out the rest and only keep „-D“, if this is necessary to play the DSD files.

    7. Mai 2020 at 17:56 #48734

    Hello

    Thank you for your reply.
    With these setting I have mute every minutes when I am playing DSD….

    12. Mai 2020 at 15:32 #48764

    Hi Run51,

    sorry for the late reply. Do you have any updates on the problem? We can only recommend that you increase the buffer and do not add any other settings for now.

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.

Register here