Squeezelite -S script gets queued at ON and executed twice at OFF

Max2Play Home 2016 (en) Forums Max2Play as Squeezebox (Player / Server) Squeezelite -S script gets queued at ON and executed twice at OFF

This topic contains 3 replies, has 2 voices, and was last updated by  MarioM Moderator 6 days, 4 hours ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • 24. Oktober 2020 at 14:58 #49900

    Hi folks,

    as the title states, I added a ON/OFF script via -S option to the advanced settings of the squeezelite player.
    When I turn the player on via LMS the script won’t run, when I turn the player off the script will run twice.
    So it seems like the first call of the script goes out but is on hold until squeezelite is shut down.

    When I run the script via SSH it works as espected. Via GPIO I actuate a relay which triggers my amp.
    Down below the used script

    
    #!/bin/sh
    # sudo gpio export 21 out
    echo 'GPIO21 als Output geschaltet'
    sudo gpio -g write 21 0
    echo 'Set GPIO21 to low'
    echo 'wait 1 sec'
    sleep 1
    echo 'waited 1 sec'
    sudo gpio -g write 21 1
    echo 'Set GPIO21 to high'
    

    Max2play and Squeezlite are updated again today. The problem is exists for a few weeks now. It doesen’t matter if squeezlite is set up as one instance or via the Multisqueeze plugin.
    Hardawre is a Raspberry Pi 3.
    My only hipe out of it righ now is to get fresh image and reset all. But I think I did that a few months ago already.
    Since a week or so squeezlite also needs to be restarted almost every day because it won’t play anything other than a weird sound and won’t react to controls. LMS that runs on this Pi is fine tho, as I can control and provide my other Squeezelite player on a different Pi.
    So maybe resetting everything is the right call as something seems to be broken with squeezlite on this Pi anyways.

    27. Oktober 2020 at 12:23 #49921

    Hi Julz,

    If Squeezelite has irregular problems, a fresh image may actually help. Apart from that, are errors displayed in the Health Checker? In such a case, the power supply could cause problems too. Please try to test the system first without your own script and only use your script when it runs normally with the new image.

    Have you made any other settings in Squeezelite? Please post your debug info from the audio player plugin here.

    17. November 2020 at 11:36 #50249

    Hi MarioM sorry for the late reply.

    The issue is resolved for a few days now and I made sure the solution is solid.

    First the powersupply is a original Raspberry Pi PSU, but as i t ran for like 4-5 years now 24/7 this could have been an issue for sure.
    But it was not.

    I tried testing the system with an other script, that just writes something into a log, same behavior. Script gets executed only when turning the player off, and then it executes twice.

    The thing that resolved the issue was a setting on the LMS side, in Settings>Player Tab> Audio settings of the corrosponding player: I had to switch the Power On Resume settings from „Pause at power off/Resume at power on“ to „Stop at power off/Restart song at power on“.
    With that change the behavior that was pre existent for years is back, the script gets executed for one time when the player is turned on and when it gets shut down.

    Edit:
    I want to add how I got to the solution. I accidently clicked the pause button in the iPeng iOS app befor actually shutting the player down, on my way to power off the amp by hand again i recognized that the script wasn’t excuded twice. I actually tested that for a few days. Always first kill the playback befor powering the player down and it worked.

    Oh and also the player didn’t crash for like 5 days now. I guess that makes sense, as most of the time I listen to web radio, and maybe just pausing that for 12h will crack the players head open.

    • This reply was modified 6 days, 8 hours ago by  Julz.
    17. November 2020 at 16:26 #50259

    Hi Julz,

    Cool that you found the solution. Thank you for your detailed report and support!

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

Register here