[SOLVED] Squeezelite not starting with hifiberry Amp2

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI [SOLVED] Squeezelite not starting with hifiberry Amp2

This topic contains 11 replies, has 3 voices, and was last updated by  Heiner Moderator 1 month, 2 weeks ago.

Viewing 12 posts - 1 through 12 (of 12 total)
  • 27. December 2017 at 1:00 #33109

    Hello guys,
    I write you after hours of searching without any success.
    I bought 1 hifiberry AMP2 and 2 RPI3 B and on both of them none of the squeezelite is launching.
    I precise that I bought also a premium licence.
    The message of squeelite is always the same :
    [23:56:06.733915] test_open:384 playback open error: No such file or directory
    [23:56:06.734142] output_init_common:382 unable to open output device

    Does anyone have an idea ?

    thank you for your help !

    27. December 2017 at 14:19 #33112

    Nobody ?

    27. December 2017 at 16:14 #33113

    Do have the Squeezebox Server installed and running?

    27. December 2017 at 23:40 #33123

    Thank you for answering.
    No, in fact the squeezebox server is running on a synology nas. But I also tried with installing it on the RPI and nothing happened.
    I disabled shairport, try to update kernel and debian packages…
    I notice that I don’t have a third option on the listbox where you have to choose the audio output. I have only hdmi and jack.

    29. December 2017 at 16:29 #33142

    Hi Bacalow,

    Sorry about the late response, we are currently on holiday break as mentioned in my Sticky Post 😉

    With your AMP2 bundle, please make sure to select the AMP2 in the HiFiBerry plugin and immediately reboot with the link provided in the yellow text after saving your selection. Afterwards, you should see the output device “sysdefault_snd_rpi_hifiberry_dacplus…” selected in the Soundcard option of the advanced options of Squeezelite.

    With the Pi3 without sound card, make sure that the out device “sysdefault_bcm…” is selected in the advanced options.

    30. December 2017 at 13:21 #33155

    Sorry, I didn’t see the sticky post…
    I tried your solution but sill the same.
    Here is the screenshots :

    And as you can see, I don’t have the option sysdefault_snd_rpi_hifiberry_dacplus…
    As if the amp2 board was undetected.

    30. December 2017 at 13:22 #33156

    here is the screen :

    2. January 2018 at 15:29 #33182

    Hi Bacalow,

    Please try deactivating the build-in audio in the Raspberry Settings, again selecting none, reboot, selecting Amp2.

    Also, what power supply do you use for your setup?

    2. January 2018 at 21:39 #33189

    thank you for answering.
    When I select none and reboot the squeezelite service is launched but when I select Amp2, always the same error.
    i bought the supply advised by hifiberry : Meanwell GS60A18-P1J.
    I also thought about this option if the supply was not this one…
    I can’t believe that the amp2 board is out of service.
    Is there an other way to test it ?


    3. January 2018 at 12:22 #33195

    Hi Bacalow,

    You can try out a different OS to make sure this issue is not related to Max2Play’s drivers for the sound card or any other aspect of our image.

    3. February 2018 at 11:26 #33826

    I solved my problem. In fat the amp2 board was defective.
    I sent it back to Hifiberry and they confirm me there was a problem.
    All is workin with the news board.
    Thx for your time.
    Max2play is great 🙂

    5. February 2018 at 15:11 #33856

    Thank you, for the follow-up and the kind words 🙂

Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.

Register here